Mantis Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000744FSSCP---------public2006-01-24 15:032012-07-21 19:26
ReporterSadisticSid 
Assigned ToGoober5000 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000744: Inferno - protect-ship and play-dead don't work
DescriptionPlay-dead orders are ignored for turrets. For example, the frigate in mission 3 shouldn't fire on anything but its turrets actively target enemy fighters even while it's told to play-dead. The rotating coil around the ship doesn't start moving until it's given the order to fly to waypoints though, so it does play dead in that sense. I've been told that play-dead fighters may suddenly come to life, but I've never seen it happen yet.

Protect-ship flags are also ignored, although this can happen quite randomly. In mission 13, the Oberon sometimes attacks the Melia with its large plasma guns despite the Melia being protected. In mission 12, some friendly units can go off to attack the Melia as well.
Additional InformationTested with 05-01-23 Inferno build, although we've recognised this behaviour since last year. Not sure if it applies to the FS2 campaign as well.

Command line:
-glow -jpgtga -mipmap -nomotiondebris -2d_poof -dualscanlines -rearm_timer -3dwarp -snd_preload -spec_exp 11 -spec_static 1.2 -spec_tube 0.4 -ambient_factor 80 -spec
TagsNo tags attached.
Attached Files? file icon 744 Test.fs2 [^] (3,985 bytes) 2008-11-24 15:54
? file icon ai_profiles.tbl [^] (1,799 bytes) 2008-12-09 14:02

- Relationships
has duplicate 0001832closedGoober5000 play-dead sexp INF Build Bug 
has duplicate 0002192resolvedGoober5000 EMP on an A.I. that has been ordered to play dead, brings it back 'alive' again 
has duplicate 0001956resolvedkarajorma Disarm/Disable results in protection for some ship classes for others not. 

-  Notes
(0007171)
Goober5000 (administrator)
2006-11-25 19:36

Okay, sorry for the delay here. Can I have a link to the latest mod, so I can test this out? PM is fine.
(0007172)
Goober5000 (administrator)
2006-11-25 19:37

Reminder sent to: SadisticSid, Woomeister

I'm checking out your Inferno bug.
(0007955)
Goober5000 (administrator)
2007-04-11 03:23

Is this still a problem?
(0010261)
Goober5000 (administrator)
2008-11-24 04:17

No response in... two years. >.< I'm going to assume this is no longer a problem.
(0010264)
chief1983 (administrator)
2008-11-24 15:55

Just for posterity, I tested the play-dead portion of this bug. The Fenris in the test mission I uploaded did not attack me as I flew around it. So I think it's good as resolved.
(0010286)
shiv_pl (reporter)
2008-11-27 11:06

Okay. I see it's reopened.
playerdead sexp bug still appear in INF builds. Here're some copy-pastes from INFA internal from guys who tested it:

"[mobius]Uhm, looks like protect-ship doesn't work with our current build. In m9(old m10), for example, Aemilia station(Asteria-class) has the protect-ship flag but pirate forces keep attacking it... :wtf:[/mobius]"

"In that regular build the flag "protect-ship" works properly. This bug seems to affect INF builds, only."
(0010287)
phreak (developer)
2008-11-27 11:32

are there any ai_profiles tables in effect?
(0010289)
shiv_pl (reporter)
2008-11-27 14:12

I think yes. Should I give you the table?
(0010290)
phreak (developer)
2008-11-27 15:24

yea, attach the table and we can take a look
(0010350)
shiv_pl (reporter)
2008-12-05 10:54

I'm attatching ai_profiles.tbl as you requested.
(0010387)
shiv_pl (reporter)
2008-12-09 11:08

Hello? Anyone here?
(0010388)
Goober5000 (administrator)
2008-12-09 11:25

We still need you to attach ai_profiles.tbl.

Can you also attach the broken mission, and provide a link to the internal thread?
(0010389)
shiv_pl (reporter)
2008-12-09 14:03

AI. Profiles uplaoded. I don't have that mission but internal link is here: http://www.hard-light.net/forums/index.php/topic,57577.0.html [^] Discussion starts on page 2 I think.
(0010420)
shiv_pl (reporter)
2008-12-15 16:26

Again hello? ai_profiles.tbl posted.
(0012536)
The_E (developer)
2010-12-10 19:19

Is this still current?
(0013794)
MjnMixael (manager)
2012-07-02 11:35

Just tested this with the attached mission and ai_profiles.tbl

I also edited to mission to test protect-ship stuff.

I can't reproduce the issues on build 8972.
(0013803)
The Trivial Psychic (reporter)
2012-07-02 13:10

This may be related, but during my FRED work for the team, I encountered an instance when protect-ship'd escape pods (hostile) were still being fired upon by friendly fighters. However, when I checked all four of the sub categories: beam-protect-ship, flak-protect-ship, laser-protect-ship, and missile-protect-ship, then they are left alone. I'm not sure if this symptom extends beyond Inferno, but on our end at least it seems that protect-ship is not acting as a global flag. BTW, I was using 3.6.14 RC4.
(0013813)
Goober5000 (administrator)
2012-07-04 02:19

It probably depends on what weapon the fighter is using. Can you attach a mission which demonstrates the bug?

I've also posted a thread in the Inferno internal forum.
(0013876)
Goober5000 (administrator)
2012-07-21 19:26

The play-dead part of the bug is caused by the EMP issue, and the protect-ship part of the bug is caused by the disarm/disable issue. This has been confirmed with internal discussion. So I'm closing this as duplicate.

- Issue History
Date Modified Username Field Change
2006-01-24 15:03 SadisticSid New Issue
2006-05-22 22:22 Goober5000 Status new => assigned
2006-05-22 22:22 Goober5000 Assigned To => Goober5000
2006-11-25 19:36 Goober5000 Note Added: 0007171
2006-11-25 19:37 Goober5000 Note Added: 0007172
2007-04-11 03:23 Goober5000 Note Added: 0007955
2008-11-24 04:17 Goober5000 Note Added: 0010261
2008-11-24 04:17 Goober5000 Status assigned => closed
2008-11-24 04:17 Goober5000 Resolution open => unable to reproduce
2008-11-24 15:54 chief1983 File Added: 744 Test.fs2
2008-11-24 15:55 chief1983 Note Added: 0010264
2008-11-26 16:38 Goober5000 Status closed => feedback
2008-11-26 16:38 Goober5000 Resolution unable to reproduce => reopened
2008-11-26 16:39 Goober5000 Relationship added has duplicate 0001832
2008-11-27 11:06 shiv_pl Note Added: 0010286
2008-11-27 11:32 phreak Note Added: 0010287
2008-11-27 14:12 shiv_pl Note Added: 0010289
2008-11-27 15:24 phreak Note Added: 0010290
2008-12-05 10:54 shiv_pl Note Added: 0010350
2008-12-09 11:08 shiv_pl Note Added: 0010387
2008-12-09 11:25 Goober5000 Note Added: 0010388
2008-12-09 14:02 shiv_pl File Added: ai_profiles.tbl
2008-12-09 14:03 shiv_pl Note Added: 0010389
2008-12-15 16:26 shiv_pl Note Added: 0010420
2010-12-10 19:19 The_E Note Added: 0012536
2012-07-02 11:35 MjnMixael Note Added: 0013794
2012-07-02 13:10 The Trivial Psychic Note Added: 0013803
2012-07-04 02:19 Goober5000 Note Added: 0013813
2012-07-21 19:22 Goober5000 Relationship added has duplicate 0002192
2012-07-21 19:22 Goober5000 Relationship added has duplicate 0001956
2012-07-21 19:26 Goober5000 Note Added: 0013876
2012-07-21 19:26 Goober5000 Status feedback => closed
2012-07-21 19:26 Goober5000 Resolution reopened => duplicate


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker