2018-08-16 18:21 EDT


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0002192FSSCPAIpublic2012-07-21 19:22
ReporterSpoon 
Assigned ToGoober5000 
PrioritynormalSeveritytrivialReproducibilityalways
StatusresolvedResolutionfixed 
Product Version3.6.12 RC2 
Target VersionFixed in Version 
Summary0002192: EMP on an A.I. that has been ordered to play dead, brings it back 'alive' again
DescriptionTested with a primary weapon with
$EMP Intensity: 175.0
$EMP Time: 1.5
these EMP settings
TagsNo tags attached.
Attached Files

-Relationships
duplicate of 0000744closedGoober5000 Inferno - protect-ship and play-dead don't work 
+Relationships

-Notes

~0011931

Sushi_CW (developer)

Does this bug exist in retail as well?

~0011932

Sushi_CW (developer)

To answer my own question: yes it does.

The good news is that it's easy to fix. What happens is that when EMP is applied to a ship, that ship will randomly pick new targets to simulate confusion. It's simple enough to stick a check in that skips this if the ship is playing dead.

Naturally, this is going to have to be toggled with an AI profiles flag, since it affects retail behavior.

It does make me wonder, however: does EMP permanently screw up any other AI goals? If so, we might as well fix those at the same time. Is anyone willing to test this?

~0011933

Sushi_CW (developer)

Oh, for the record, the bit of code to look at for this is (about) emp.cpp:355

~0011934

Spoon (reporter)

I just did a test, giving the A.I. attack orders on a cargo container with a priority of 200 and the no dynamic goals flag. I could attack it with normal weapons all I want and it would ignore me and focus on the container. But hitting it with an EMP missile made it really really angry. Same with the initial orders to ignore Alpha 1. Hitting it with EMP made the A.I. forget all about its original goal.

So yes, it seems EMP screws up all AI goals.

~0011935

FUBAR-BDHR (developer)

Well one of the uses of EMP was to keep formations of bombers from attacking their target so that part does make sense.

~0013779

Goober5000 (administrator)

EMP shouldn't disrupt play-dead though. I'm committing a fix.

~0013780

Goober5000 (administrator)

Fix committed to trunk@8971.

~0013793

Spoon (reporter)

Today I also learned that the A.I. forgets which ships are set as 'Protected' after getting EMP'd. And will thus attack them once the EMP wears off.

~0013807

Goober5000 (administrator)

Fixed, again.

~0013819

Zacam (administrator)

Fix committed to fs2_open_3_6_14@8984.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2010-04-22 17:46 Spoon New Issue
2010-04-22 17:46 Spoon Status new => assigned
2010-04-22 17:46 Spoon Assigned To => Sushi_CW
2010-05-03 10:38 Sushi_CW Note Added: 0011931
2010-05-03 11:00 Sushi_CW Note Added: 0011932
2010-05-03 11:05 Sushi_CW Note Added: 0011933
2010-05-03 11:19 Spoon Note Added: 0011934
2010-05-03 19:05 FUBAR-BDHR Note Added: 0011935
2012-07-01 23:45 Goober5000 Note Added: 0013779
2012-07-01 23:45 Goober5000 Assigned To Sushi_CW => Goober5000
2012-07-01 23:47 Goober5000 Changeset attached => fs2open trunk r8971
2012-07-01 23:47 Goober5000 Note Added: 0013780
2012-07-01 23:47 Goober5000 Status assigned => resolved
2012-07-01 23:47 Goober5000 Resolution open => fixed
2012-07-02 09:11 Spoon Note Added: 0013793
2012-07-02 09:11 Spoon Status resolved => feedback
2012-07-02 09:11 Spoon Resolution fixed => reopened
2012-07-03 01:01 Goober5000 Changeset attached => fs2open trunk r8976
2012-07-03 01:02 Goober5000 Note Added: 0013807
2012-07-03 01:02 Goober5000 Status feedback => resolved
2012-07-03 01:02 Goober5000 Resolution reopened => fixed
2012-07-04 15:46 Zacam Changeset attached => fs2open fs2_open_3_6_14 r8984
2012-07-04 15:46 Zacam Note Added: 0013819
2012-07-04 15:49 Zacam Changeset attached => fs2open fs2_open_3_6_14 r8988
2012-07-21 19:22 Goober5000 Relationship added duplicate of 0000744
+Issue History