2019-12-06 20:36 EST


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0000624FSSCPcutscenespublic2012-01-09 13:06
ReporterARSPR 
Assigned Totaylor 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionwon't fix 
PlatformWindowsOSXPOS VersionPRO SP 2
Product Version3.6.7 
Target VersionFixed in Version3.6.9 
Summary0000624: At least, intro.avi clip doesn't show up right
DescriptionWith the last CVS version, at least the intro video has a strange background frame that is just as big as the video.

I attach a picture. I'm sorry but my screen capturing program does not work, so please imagine that in the center you are watching Intro.avi

You can see the background rectangle in the upper left corner.

This problem doesn't existed with P4 2005-11-01 version (or earlier).
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0003877

phreak (developer)

I think thats just an artifact from compressing the movie and not an actual code problem. Don't think its fixable unless the movie is recompressed using a higher bitrate which would fix the artifact, but result in a larger filesize.

~0004172

phreak (developer)

Are we still having problems with this?
Has anyone been able to recreate this bug?
Does anyone know what the heck is going on in the screencap?

Stay tuned and find out.

~0005323

phreak (developer)

Are we still having problems with this?
Has anyone been able to recreate this bug?
Does anyone know what the heck is going on in the screencap?

Stay tuned and find out.


I feel like i've been here before.

~0005328

taylor (administrator)

I'm actually wondering if this isn't the -noscalevid issue. If that option is set then the movie would just be centered in the screen rather than filling it. That would happen with all movies though and this bug report is a little vague on that point.

If there isn't a rapid response from the reporter then I say we just close this a user-error or something. No one else seems to have this issue unless then turned on -noscalevid by mistake.

~0005416

ARSPR (reporter)

Sorry, I forgot about it.

Yes this issue still exists, although it isn't really important.

Recently I have changed from a Radeon 9800Pro to a nVidia 7800GS and the problem is still present so it can't be a video driver isue.

Next week I will try some checks (switching from OGL to D3D and some more).

Taylor: -noscalevid works fine so I have an unscaled movie playing in the center of the monitor. I'm sorry the attached image is very dark but playing with monitor brightness you can see that there is a background rectangle moved to the upper left corner.

~0005422

ARSPR (reporter)

Last edited: 2006-04-28 16:58

I've made several fast checks:

+ This issue happens with any *.avi. At least with intro.avi and bastion.avi

+ It only happens in OGL not in D3D.

+ With my new 7800GS (and new builds and latest nVidia drivers), the background rectangle is always fixed at the upper left corner. It seems as if the movie was going to play in this position but then it is centered leaving a "shadow".

+ But I remember with my former 9800Pro (and older Catalyst drivers and older builds), the background rectangle changed its position.

(I can't take a proper screenshot as FS2 screenshots don't work within movies and FRAPS only takes a screenshot of the movie itself not the full screen)


OTOH, I think this should be a very low priority bug. It's just a bit ugly but it hasn't got any other importance. Please, only spend time in it if you are really really bored.

edited on: 04-28-06 16:58

~0005426

Backslash (developer)

I can confirm seeing this problem as well, with -noscalevid. Just so you know it's not just ARSPR.

The background rectangle mentioned is made of the 'magic' color (#100010) that is used to project the overlay. As ARSPR says, it looks as if it is going to play the video in this position, but then centers and plays there instead. If you take a screenshot, all you get is this color, in this mentioned rectangle and also where the movie was actually playing.

But I agree, hardly an issue worth worrying about much. I might stab at it someday, once we run out of bugs that are not too hard for me to understand :-P

~0005522

taylor (administrator)

I wouldn't say that this is actually fixed, but see if it's still and issue in a newer build (20060513 or newer).

~0005533

ARSPR (reporter)

Yes, with Taylor's 20060513 is still present.

~0005908

taylor (administrator)

Does RC3 make a difference?

~0005914

ARSPR (reporter)

Nope, it's the same. A little more info:
+ With Intro.avi the background rectangle is dark purple.
+ But with Bastion.avi at the begining of the last mission the background rectangle is grey. And as it takes a little the movie to start, during this half-second or so the main movie rectangle is also grey.

~0006095

taylor (administrator)

Think I may have made some actual progress on this. I'll post a new test build later today and you can try it out and let me know if it's better or not.

~0006099

taylor (administrator)

Try the RC5.1 build, a few movie related changes/fixes there.

~0006108

ARSPR (reporter)

I feel sorry to say it keeps happening. But now the background rectangle is always purple.

OTOH, the first time a movie is played, there is a little delay because it is been loaded from HD rather than from Disk Cache. So in this very first time it is clearly noticeable how the movie was going to be played in a wrong position and then it is centered leaving the background shadow.

~0006515

ARSPR (reporter)

I've just made some tries with 3.6.9. RC6 and RC7 and intro movie in avi and mve formats.

+ MVE player does NOT show the background rectangle. It only appears with avi player.

+ OTOH RC7 does not play avi movies. And you have to put mve movies in data\movies (inside or outside a vp container). They aren't played anymore from Freespace2 main folder.

~0006516

taylor (administrator)

The 3.6.9 build was updated yesterday with a fix for not playing AVIs. Download it again and give the AVI test another try.

MVEs should be loaded from anywhere, but it will try and use an AVI first. So when testing that please make sure that you only have either an AVI or MVE movie, just to help make sure it's not a load order issue. MVE movies work anywhere for me so I know it's not a code issue.

~0006523

ARSPR (reporter)

You're right, Taylor (as always).

It was RC7 NOT-playing highier priority avi which made me think movies weren't load from Freespace2 main directory.

(OTOH, can you copy RC7-1 to fs2source.warpore.org, please? I cannot access icculus from work and my home ADSL connetion is going to be out for some time)

~0006524

taylor (administrator)

I just re-uploaded the RC7 build to have everything except for the sexp change that rc7-1 has. The movies should work now if you redownload RC7. If it doesn't work then let me know and I'll move rc7-1 to warpcore.

~0007000

ARSPR (reporter)

Some more info for this minor bug.

If I do not use -noscalevid then:

1st. The movie seems to be played with 1x1 ratio (like with -noscalevid) in a not-centered position.

2nd. Then it is scaled and centered but leaving the background shadow in its first position.

Maybe with this info you can detect when this bug happens (it seems to be before -noscalevid code is applied).

Remember it only happens with avi files, not mve ones. I'm using RC7.8 now.

~0007003

taylor (administrator)

I think it's pretty safe to say that this isn't going to get fixed at this point. I'm working on the Theora player, which will be the default format for 3.6.9, followed by MVE, followed by AVI. Version 3.6.9 will be the last to have AVI support though and it will get ripped out of CVS builds as soon as the Theora code is publicly available.

I'll give this another try over the weekend, but if I can't fix it then come Monday this bug (and all other open AVI related bugs) will be officially declared "Won't Fix".

~0007005

ARSPR (reporter)

Then, do not waste your time in it, and close the bug.

I, (and I suppose everyone), prefer you advancing in the new pilot code, solving any other bug or just drinking a beer rather than wasting your time in an "obsolete" feature.

~0007107

taylor (administrator)

Please give this build a try: http://icculus.org/~taylor/fso/willrobinson/vidtest.rar

It is a debug-only exe and a new Launcher (updated 5.5). The game exe has *many* known problems, so don't use it as a normal build, but if the movies work properly for you now then I'll get those code fixes in CVS and make a real build for you.

This has numerous changes to how the game window is handled, which will/may help with the movie problems, focus issues, the white screen flash issue, active window issues (OpenGL only), mouse cursor problems (OpenGL only), minimize/restore issues (OpenGL only), and should hopefully fix the old DivX6 toolbar screwup for AVI movies too (or at least I can't replicate it now).

~0007111

ARSPR (reporter)

With your new build it is fixed :)

There's only a little issue barely noticeable, and just once, because the second time the movie is played it is in Disk Cache so its loading time is nearly none. When the movie is played it happens the following, (or it seems to happen):

+ It is loaded in the center of the screen.

+ Then it is offcentered, leaving a purple background rectangle in the middle.

+ Then it is centered again leaving NO background rectangle, and of course the very first background is also hidden.

So, now, I just see a brief purple flash in the middle.

~0007113

taylor (administrator)

Awesome. :D

The off-center/re-center thing was a possibility (in some cases, shouldn't happen in general) so I was a little curious about whether it was going to properly fix itself immediately or not. I have no clue how to fix it though, and no real desire to figure it out. The changes I have made here were needed to clean up and fix numerous things not only for 3.6.9 but for 3.7 too, the fact that I could fix the AVI movie problem with it was just a bonus. :)

I'm pretty happy with how it works now, so unless you have any objections, I'll just consider this fixed and resolve it once the code hits CVS.

~0007114

ARSPR (reporter)

Close it, kill it, mark it as fixed and delete it from Mantis database...

~0007121

taylor (administrator)

Fixered (or close enough at least).

~0007255

ARSPR (reporter)

Taylor, your latest hoopla (2nd version, December 6th) HAS this bug back.

Original RC7.9x or the first hoopla (November 28th) didn't suffer it.

~0007257

taylor (administrator)

Hmm, that shouldn't be. The code changes that could have make this break again never get triggered when playing a movie (on purpose, it will actually know that a movie is playing and skip the problem causing code). I did make a couple of other changes to the movie code so that generic set/reset of some things that get done for MVEs will happen for AVIs too (like stopping any playing music, clearing the screen properly, making sure the game knows to hide the mouse, etc.). Not sure why (or how) that might have messed something up though.

Not sure what's going on with it then. The first hoopla has very little different in the movie playing or window handling areas than the new hoopla build.

But let's just make sure that it's not some strange build specific bug (since the new hoopla build was from unstable code in general, unlike the first one). When the next RC build becomes available (if there actually is one) then give it a try and see if this is still a problem there.

~0007326

ARSPR (reporter)

I'm sorry to say that your cousinarnold is sick ... ;)

~0007329

taylor (administrator)

Eh, that's ok. cousinarnold has the new Theora movie player in it, so all AVI bugs are getting obsoleted. Future builds won't even have AVI support, 3.6.9 will be the last one. :)

~0007363

ARSPR (reporter)

Ogg player works fine. Close and forget this error.

~0007370

taylor (administrator)

Obsolete. New Theora movies should be used instead.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2005-11-16 11:02 ARSPR New Issue
2005-11-16 11:02 ARSPR File Added: Intro.jpg
2005-11-16 17:09 phreak Note Added: 0003877
2006-01-09 14:23 phreak Note Added: 0004172
2006-04-13 12:50 phreak Note Added: 0005323
2006-04-13 13:32 taylor Note Added: 0005328
2006-04-28 05:28 ARSPR Note Added: 0005416
2006-04-28 16:56 ARSPR Note Added: 0005422
2006-04-28 16:58 ARSPR Note Edited: 0005422
2006-04-28 21:05 Backslash Note Added: 0005426
2006-05-13 16:54 taylor Note Added: 0005522
2006-05-17 08:24 ARSPR Note Added: 0005533
2006-06-22 11:11 taylor Note Added: 0005908
2006-06-22 11:11 taylor Status new => assigned
2006-06-22 11:11 taylor Assigned To => taylor
2006-06-22 12:42 ARSPR Note Added: 0005914
2006-07-08 15:53 taylor Note Added: 0006095
2006-07-08 23:22 taylor Note Added: 0006099
2006-07-09 04:49 ARSPR Note Added: 0006108
2006-08-29 09:52 ARSPR Note Added: 0006515
2006-08-29 11:35 taylor Note Added: 0006516
2006-08-31 12:11 ARSPR Note Added: 0006523
2006-08-31 12:26 taylor Note Added: 0006524
2006-10-26 11:01 ARSPR Note Added: 0007000
2006-10-26 12:57 taylor Note Added: 0007003
2006-10-26 13:09 ARSPR Note Added: 0007005
2006-11-13 20:55 taylor Note Added: 0007107
2006-11-14 10:27 ARSPR Note Added: 0007111
2006-11-14 10:34 taylor Note Added: 0007113
2006-11-14 10:39 ARSPR Note Added: 0007114
2006-11-14 19:52 taylor Status assigned => resolved
2006-11-14 19:52 taylor Fixed in Version => 3.6.9
2006-11-14 19:52 taylor Resolution open => fixed
2006-11-14 19:52 taylor Note Added: 0007121
2006-12-06 04:42 ARSPR Status resolved => feedback
2006-12-06 04:42 ARSPR Resolution fixed => reopened
2006-12-06 04:42 ARSPR Note Added: 0007255
2006-12-06 05:08 taylor Note Added: 0007257
2006-12-26 03:44 ARSPR Note Added: 0007326
2006-12-26 04:27 taylor Note Added: 0007329
2007-01-02 05:38 ARSPR Note Added: 0007363
2007-01-02 11:57 taylor Status feedback => resolved
2007-01-02 11:57 taylor Resolution reopened => won't fix
2007-01-02 11:57 taylor Note Added: 0007370
2012-01-05 17:55 taylor Changeset attached => Import 2012-01-05 17:52:05 fs2_open_3_6_9 r3744
2012-01-05 17:55 taylor Changeset attached => Import 2012-01-05 17:52:05 trunk r3757
2012-01-09 13:06 taylor Changeset attached => fs2open_websvn fs2_open_3_6_9 r3744
2012-01-09 13:06 taylor Changeset attached => fs2open_websvn trunk r3757
+Issue History