2019-11-12 07:53 EST


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0000542FSSCPcutscenespublic2012-01-09 13:06
ReporterTieowbeijas 
Assigned Totaylor 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.9 
Summary0000542: Intro video is played in upper left corner of the screen
DescriptionWhen I start up FS2 and it plays the intro video, the video is played in the upper left corner of the screen, and it is really small.
Additional InformationSpecs:
3.0GHz P4
2GB RAM
SB Audigy Gamer (AFAIK it's just a normal Audigy)
Nvidia GeForce 6800GT 256MB

Using the 11/9/2005 cvs build by redmenace

Commandline:
D:\simulator\Freespace2\fs2_open_r.exe -spec -glow -pcx32 -jpgtga -d3dmipmap -nomotiondebris -2d_poof -3dwarp
(Have tried to deactivate all options, but the bug still persists)

My videos are encoded in DivX, codec version 6.0
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0003320

Goober5000 (administrator)

Rolling your DivX version back to v5 will fix this.

Is there anything the SCP can do here, or is this purely a DivX bug?

~0003329

Tieowbeijas (reporter)

Just a DivX bug, since rolling back fixed it.
So it's probably safe to close this.

~0003331

taylor (administrator)

I'm probably going to replace the current video code with something that's cross-platform. That would solve the problem but it would also work with a slightly smaller group of codecs.

If you (Goober) want the current code fixed I say leave this open and close it otherwise.

~0003335

Goober5000 (administrator)

It just occurred to me that we might have a bunch of people complaining about this for 3.6.7 like the various other bugs for 3.6 and 3.6.5. :(

This should be fixed somehow, so I say leave it open.

Taylor: What codecs would not be supported on the cross-platform version?

~0003337

taylor (administrator)

"Taylor: What codecs would not be supported on the cross-platform version?"

The newest DivX codec and I don't think the newest Sorensen codecs and only some of the WMV codec versions are fully supported (part of WMV8, not WMV9). Up to DivX 5 is supported though. I think H.264 (used by QuickTime 7) is fully supported as is VP3 and Theora. All of this would be handled by the code shipped with the game and doesn't use any system specific codecs or require any other system software. Some of the features normally supported won't be in our case because they are GPLed and can't be compiled in the lib. I'm not 100% sure how many formats won't work because of not using that code but that will be known and tested before I attempt to put the code in CVS.

~0003340

taylor (administrator)

Someone in the SCP site forum may have figured out what's wrong. Assuming we can get a proper fix tested in short order I'd say this could be fixed for 3.6.7.

http://scp.indiegames.us/forum_viewtopic.php?9.593

I don't have the ability to test this myself right now (no working Windows system) but someone else may be able to (Goober?). I don't like the current patch that was posted but it does point out the basic problem which could possibly be fixed a better way.

~0003342

Goober5000 (administrator)

I'd be glad to test it but I'm currently house hunting and won't be back for a few days.

The patch does look hackish but at least it's something. :) If someone can test it, we can just put it in CVS, leave the bug open, and apply a proper patch when we figure out the real problem.

~0003347

Mongoose (reporter)

I don't have access to that part of the forum, but I'd be happy to test out the fix if someone could provide me with it.

~0003348

taylor (administrator)

If you can edit code/directx/dx8show.cpp make a test build to check a couple of things that would help. In the PlayMovieInWindow() function, after the RenderFile() call, see if the return value of GetActiveWindow() is the same as the value of ghApp. If not then try SetActiveWindow(ghApp) and see if that does anything good or bad.

~0003350

Mongoose (reporter)

Crap; I thought you were referring to a patch that someone had already coded/compiled. Fooling around with code's a little bit out of my league for the time being. Sorry about that. Since I have been experiencing the problem, though, I'll be sure to confirm it if/when a fix build is released.

~0003368

taylor (administrator)

I'm going to grab a windows laptop from someone and test this in the morning.

~0003746

taylor (administrator)

Ok, I've got several game code fixes to better deal with this but nothing 100%. I did figure exactly what the problem is however, the DivX Toolbar. It's not actually a toolbar, just that little icon in the systray to change settings, but is the cause of the problem. That had been guessed before but now it's the known problem. Running the re/uninstall tool from DivX, a reboot later, and it works fine afterwords. I'm currently looking for a way to bypass it without having to uninstall but in the meantime my current changes will go in CVS before the weekend is over.

The uninstall tool (can also reinstall the toolbar) can be found here:
http://support.divx.com/cgi-bin/divx.cfg/php/enduser/std_adp.php?p_faqid=1630&p_created=1120759037&p_sid=LBhz1NTh&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MyZwX3Byb2RzPTAmcF9jYXRzPSZwX3B2PSZwX2N2PSZwX3NlYXJjaF90eXBlPWFuc3dlcnMuc2VhcmNoX25sJnBfcGFnZT0xJnBfc2VhcmNoX3RleHQ9dG9vbGJhcg**&p_li=&p_topview=1

~0005900

taylor (administrator)

Since we know the cause, DivX 6, and how to fix it I guess this should just be closed. With MVE support now this isn't as much of an issue. And there doesn't appear to be a way for us to get around the DivX 6 toolbar without strange code hackage that may create more problems that it fixes. Hopefully this will be addressed with some newer DivX release (if it hasn't been addressed already) so lets just leave it there.

~0005901

taylor (administrator)

Closered.

~0007108

taylor (administrator)

Someone who is able to still reproduce this bug, please try it again with this build: http://icculus.org/~taylor/fso/willrobinson/vidtest.rar

DO NOT use this as a normal build, it has many other issues that aren't ready for general use. If the video problem is fixed (I'm not about to replicate it any longer) then I'll commit just those fixes to CVS for inclusion with a real build.

~0007122

taylor (administrator)

Finally, Fixered.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2005-09-11 16:00 Tieowbeijas New Issue
2005-09-11 22:16 Goober5000 Note Added: 0003320
2005-09-12 00:57 Tieowbeijas Note Added: 0003329
2005-09-12 02:03 taylor Note Added: 0003331
2005-09-12 12:22 Goober5000 Note Added: 0003335
2005-09-12 13:14 taylor Note Added: 0003337
2005-09-13 02:23 taylor Note Added: 0003340
2005-09-13 09:56 Goober5000 Note Added: 0003342
2005-09-14 00:25 Mongoose Note Added: 0003347
2005-09-14 00:59 taylor Note Added: 0003348
2005-09-14 02:01 Mongoose Note Added: 0003350
2005-09-15 01:00 taylor Note Added: 0003368
2005-09-15 01:00 taylor Assigned To => taylor
2005-09-15 01:00 taylor Status new => assigned
2005-11-04 19:28 taylor Note Added: 0003746
2006-06-22 10:48 taylor Note Added: 0005900
2006-06-22 10:49 taylor Status assigned => closed
2006-06-22 10:49 taylor Note Added: 0005901
2006-10-31 23:25 taylor Resolution open => not fixable
2006-11-13 20:57 taylor Note Added: 0007108
2006-11-13 20:57 taylor Status closed => assigned
2006-11-13 20:57 taylor Resolution not fixable => open
2006-11-13 20:58 taylor Status assigned => feedback
2006-11-14 19:52 taylor Status feedback => resolved
2006-11-14 19:52 taylor Fixed in Version => 3.6.9
2006-11-14 19:52 taylor Resolution open => fixed
2006-11-14 19:52 taylor Note Added: 0007122
2012-01-05 17:55 taylor Changeset attached => Import 2012-01-05 17:52:05 fs2_open_3_6_9 r3744
2012-01-05 17:55 taylor Changeset attached => Import 2012-01-05 17:52:05 trunk r3757
2012-01-09 13:06 taylor Changeset attached => fs2open_websvn fs2_open_3_6_9 r3744
2012-01-09 13:06 taylor Changeset attached => fs2open_websvn trunk r3757
+Issue History