2019-10-14 11:46 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002092FSSCPgraphicspublic2010-03-10 05:36
Reporterblowfish 
Assigned Totaylor 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
Product Version3.6.11 
Target VersionFixed in Version3.6.12 RC2 
Summary0002092: FSO will crash if no post-processing shaders are found when -post_process is enabled.
DescriptionIf the shaders necessary for post-processing are not present when the launcher flag is enabled, FSO will crash when you start a mission (when you click the commit button).
Additional InformationRelevant lines of fs2_open.log:

  Compiling special shader -> post-v.sdr / brightpass-f.sdr ...
Could not open text file 'post-v.sdr'.
Could not open text file 'brightpass-f.sdr'.
Vertex shader failed to compile:
ERROR: Parser found no code to compile in source strings.

ERROR! Unable to create vertex shader!
ASSERTION: "image" at gropenglpostprocessing.cpp:46
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0002093closedHery Exe ungracefully fails if -post_process is on, but shaders are not present 
+Relationships

-Notes

~0011522

blowfish (reporter)

Also the crash doesn't happen when -no_glsl is enabled, if that matters.

~0011526

Hery (developer)

This build should solve the problem: http://quarnos.org/dl/fso_2092_fix.zip

~0011527

Zacam (administrator)

Last edited: 2010-01-15 20:03

Compiling special shader -> post-v.sdr / brightpass-f.sdr ...
Could not open text file 'post-v.sdr'.
Could not open text file 'brightpass-f.sdr'.
Vertex shader failed to compile:
(0) : error C0000: syntax error, unexpected $end at token "<EOF>"
(0) : error C0501: type name expected at token "<null atom>"

ERROR! Unable to create vertex shader!
Post-processing disabled.

It does indeed, though the error C00000 and error C0501 have me concerned.

Though, a .patch would have been easier to distribute the testing of the fix on multiple platforms a lot easier, as I con only confirm that on windows, this executable does not have the reported problem.

~0011555

Hery (developer)

There is no check whether a shader file exist, since if it doesn't compilation will fail anyway and the post-processing will be disabled. However, I think that it will be much more elegant to do that test for file existance, since now debug log may be a bit misleading. I'll do that as soon as I have more time for SCP and that, unfortunately, means after February 8th.

~0011762

taylor (administrator)

Fixered.
+Notes

-Issue History
Date Modified Username Field Change
2010-01-15 00:15 blowfish New Issue
2010-01-15 00:20 blowfish Note Added: 0011522
2010-01-15 08:29 Hery Status new => assigned
2010-01-15 08:29 Hery Assigned To => Hery
2010-01-15 14:28 Zacam Relationship added has duplicate 0002093
2010-01-15 15:17 Hery Note Added: 0011526
2010-01-15 20:02 Zacam Note Added: 0011527
2010-01-15 20:03 Zacam Note Edited: 0011527
2010-01-21 11:06 Hery Note Added: 0011555
2010-03-10 05:36 taylor Note Added: 0011762
2010-03-10 05:36 taylor Status assigned => resolved
2010-03-10 05:36 taylor Fixed in Version => 3.6.12 RC2
2010-03-10 05:36 taylor Resolution open => fixed
2010-03-10 05:36 taylor Status resolved => assigned
2010-03-10 05:36 taylor Assigned To Hery => taylor
2010-03-10 05:36 taylor Status assigned => resolved
+Issue History