2018-12-18 13:09 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000924FSSCPmediaVPpublic2008-10-27 05:01
ReporterARSPR 
Assigned ToDa_Brain 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
PlatformP4 2.8 HT - 1.5GB - 7800GSOSWindows XPOS VersionSP2
Product Version 
Target VersionFixed in Version 
Summary0000924: Wrong name for "Turn off targeting window" action
DescriptionWell, it's a little stupid thing but while I was testing Backslash beta multitargeting builds I wanted to turn off the target window and it took a while to notice that it is actually wrongly name "Turn-off Auto-Targeting" (by default Alt-T).

This action has nothing to do with Auto-Targeting so it's confusing. I would name it "Turn-off Target Computer" or something like that.

Probably it's an error from Retail FS2
Additional InformationThe code is fixed; now all that needs to be done is a new modular strings.tbl in mv_core.vp.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0005700

Backslash (developer)

Wow, would you believe I've never tried that control before? (or Turn Off Auto-Targeting of Subsystems). Useful! And it's in retail even!

(Just so everyone ELSE knows, this has nothing to do with my build, it's just more desirable to use this control in my build ^^ )

How about the names:
"Deactivate Targeting"
"Deactivate Subsystem Targeting"
Other suggestions? It's only the names we're changing, to make it more clear what the controls do (switch target to nothing).

~0005825

ARSPR (reporter)

Last edited: 2006-06-11 13:02

I think this could be a cool tweak for 3.6.9.

Backslash's names are good but I prefer "Turn off" rather than "Deactivate"

edited on: 06-11-06 13:02

~0006123

ARSPR (reporter)

Last edited: 2006-07-09 14:11

*bump*

Just to remember SCP to tweak this serious and evil bug before 3.6.9. launch. Although I doubt you will be able to get rid of it with less than 3 years of hard team work.





Just a joke, don't get me wrong :o |).

edited on: 07-09-06 14:11

~0006247

Goober5000 (administrator)

Fixed. ;)

~0006392

ARSPR (reporter)

In 3.6.9. RC6 I still see:

Alt - T: Turn off auto-targeting
Alt - S: Turn off auto-targeting of subsystems

~0006393

Goober5000 (administrator)

Are you sure you're using RC6?

Because it's definitely fixed; I just checked.

~0006395

ARSPR (reporter)

I have just re-extracted fs2_open_3_6_9.exe from 3.6.9-RC6.rar, I have created even a new pilot and I still get the old names. I attach a screenshot.

~0006412

Goober5000 (administrator)

Ugh. It's using the localized version in strings.tbl.

I guess we have two alternatives. Either have FSO use the version in the code when doing English translations, or fix strings.tbl in the mediaVPs.

~0006422

ARSPR (reporter)

I think the best fix you can do is:

+ Add support for a modular string tables.
+ Add one "Targeting-str.tbm" file to the new media vp with the fixed text in English, German and French (any translators please?).

(If something isn't hardcoded, I think it's a bad idea to hardcode it.)

But maybe it's too much work to solve such little issue. In this case just put a fixed Strings.tbl in next Media vp. (I didn't know about Strings.tbl so I'm fixing my vp just now)

~0006424

taylor (administrator)

Adding support for modular strings.tbl shouldn't be a big deal, I can do that without much trouble. It's only part of the translation system though.

The problem is that tstrings.tbl can't really be made modular without a rather large rewrite of the localization code. That tbl isn't actually parsed, it's opened and accessed at lookup time by seeking in the file. This reason for that is simple, it's a very large tbl with an arbitrary number of entries. Making it modular wouldn't be an easy task if it was done even remotely right.

If everyone would be happy with one tbl and not the other then I'll work on making strings.tbl modular later today.

~0006425

Goober5000 (administrator)

I seriously don't think it's necessary. How often is strings.tbl used (by third-party campaigns that is), anyway? The only reason for making it modular would be to fix this bug, and that's overkill IMO.

I doubt this is even worth a mediaVP fix, considering that new keys may be added or changed in the future. I strongly recommend to just add something to XSTR that uses the version in the code if the language is English, then close this bug and that'll be the end of the matter. :)

~0006426

taylor (administrator)

The benefit of modular strings.tbl is that we can localize our own strings, not just the original :V: ones. Making it modular would allow us to not only replace but also add translated strings. Everything that we have added to the code needs to be translated too, but we would have to include a strings.tbl in the MediaVPs for that, or hard code the translations (which is a very bad idea). A modular strings.tbl wouldn't be just for this bug. And strings.tbl is only for internal code translations, so it wouldn't really be used by mods anyway, they would just make use of tstrings.tbl if anything.

The XSTR hack, unless it's a flag set per call, would be a bad idea. Not all of the strings in the code are exactly what is in the tbl, so we would actually have to go check everything to make sure that the strings in the code are correct. Plus, the strings in the code are mainly for a last ditch fallback when the line doesn't exist in the tbl, and as a simple coder reference for what should be said. Using the in-code strings for anything should actually be considered a bug, and not as a fix for anything.

~0006427

Goober5000 (administrator)

*grumble grumble*

Okay, well at the very least we should have a built-in modular table, in def_files, to correct those key descriptions I fixed in CVS. Hopefully, this is a compromise and doesn't fall too far afoul of hard coding. :)

~0006428

taylor (administrator)

Last edited: 2006-08-09 17:34

Is this actually such a big thing that it needs to be hard coded? It doesn't seem that way to me, but, whatever. Hard coding translations, not to mention translation fixes, is never a good idea, and the code is already bad enough about that crap.

Adding it to def_files means that a coder will have to take the time to do the non-English translations, or at least make the changes submitted by others. A significant portion of the FS2 user base is non-English so only having the correct English translation still leaves the bug, and this wouldn't have actually been "fixed" at all.

I guess I'll try and take care of all of that when I make strings.tbl modular though, just so no one else will have to deal with it later. And so I don't have to deal with the non-English guys going on a rampage again, since I can't always understand what the hell they are talking about.

edited on: 08-09-06 17:34

~0006429

Goober5000 (administrator)

IMHO it's such a *little* thing that it needs to be hard-coded. I made about a dozen changes total, and the only one where I actually changed the phrasing was the "Turn-off Auto-Targeting" command mentioned here. All the other changes were merely changes in capitalization to make the whole thing consistent. That hardly needs to be duplicated for the other locales, IMHO; they're just nitpicks.

~0006453

ARSPR (reporter)

IMO, do not hard-code anything. I've just upload a fixed Strings.tbl at least for English (French and German are unchanged).

Add it to next vp distribution and forget about this little bug, (it doesn't worth your effort).

~0006456

Goober5000 (administrator)

You're not the Grammar Inquisition. :p I fixed several typos in addition to the one in this bug.

~0006457

ARSPR (reporter)

I'm not native English speaker so I'm not risking checking any other's grammar. ;)

OTOH, I made TWO changes, not only one: 517 and 521 strings.

~0007956

Goober5000 (administrator)

Okay, taylor, are there any plans to do anything with this, or shall we mark it as not fixable?

~0007957

Goober5000 (administrator)

Reminder sent to: taylor

Just a question. ;)

~0007962

taylor (administrator)

Yeah, sorry, forgot to ever get back to this.

I'm in the process of making the strings stuff modular so that stuff like this can be easily fixed. That's a lot easier said that done though, and I just haven't gotten it working yet. It's sort of working for strings.tbl, but since tstrings.tbl works differently it's quite a bit more difficult to manage that one.

I might just finish getting strings.tbl working (since that would address this bug) and deal with tstrings.tbl at a later date, if there is a real need for it.

~0007966

taylor (administrator)

Modular strings.tbl support is now in CVS (*-lcl.tbm). Consider this fixed?

~0007972

Goober5000 (administrator)

Cool. :)

Not "fixed" fixed, unfortunately, as we still need new strings. But the good news is that it's no longer our concern. :) I'll reassign it to DaBrain.

~0007978

taylor (administrator)

Probably should have done this before, but just attached a tbm to make use of the code fix. Should be something that DaBrain can go ahead and add to the MediaVPs though, since it won't hurt anything for builds that don't support it yet.

~0007979

Goober5000 (administrator)

Good, but the mediaVPs should include a few more changes IMHO. Here are the my commits from earlier in this thread:

http://fs2source.warpcore.org/cgi-bin/cvsweb/cvsweb.cgi/fs2_open/code/controlconfig/controlsconfigcommon.cpp.diff?r1=text&tr1=2.14&r2=text&tr2=2.15
http://fs2source.warpcore.org/cgi-bin/cvsweb/cvsweb.cgi/fs2_open/code/controlconfig/controlsconfigcommon.cpp.diff?r1=text&tr1=2.16&r2=text&tr2=2.17

~0008185

Da_Brain (developer)

Last edited: 2007-06-20 19:05

"mv_strings-lcl.tbm" added to MV_Core.

Can be closed after the MediaVP 3.6.10 release.

~0008186

Goober5000 (administrator)

DaBrain, did you add the extra fixes in the links that I mentioned?

~0008205

Da_Brain (developer)

Not yet.

I'm not really sure how to 'translate' that into the tables. But I didn't take a really close look at it.

~0008807

Wanderer (developer)

I posted DaBrain the fix for this one which includes the files Goober mentioned later. Should be in the 3.6.10 Mediavps (not in beta)

~0010130

Wanderer (developer)

Fixed in 3.6.10 mediavps (not in beta)
+Notes

-Issue History
Date Modified Username Field Change
2006-05-25 14:28 ARSPR New Issue
2006-05-25 20:03 Goober5000 Assigned To => Backslash
2006-05-25 20:03 Goober5000 Status new => assigned
2006-06-01 17:54 Backslash Note Added: 0005700
2006-06-11 13:00 ARSPR Note Added: 0005825
2006-06-11 13:01 ARSPR Note Edited: 0005825
2006-06-11 13:02 ARSPR Note Edited: 0005825
2006-07-09 14:10 ARSPR Note Added: 0006123
2006-07-09 14:11 ARSPR Note Edited: 0006123
2006-07-19 21:17 Goober5000 Status assigned => resolved
2006-07-19 21:17 Goober5000 Resolution open => fixed
2006-07-19 21:17 Goober5000 Assigned To Backslash => Goober5000
2006-07-19 21:17 Goober5000 Note Added: 0006247
2006-08-08 10:26 ARSPR Status resolved => feedback
2006-08-08 10:26 ARSPR Resolution fixed => reopened
2006-08-08 10:26 ARSPR Note Added: 0006392
2006-08-08 10:47 Goober5000 Note Added: 0006393
2006-08-08 11:02 ARSPR File Added: Binding Screen.jpg
2006-08-08 11:03 ARSPR Note Added: 0006395
2006-08-08 15:57 Goober5000 Note Added: 0006412
2006-08-09 12:12 ARSPR Note Added: 0006422
2006-08-09 13:19 taylor Note Added: 0006424
2006-08-09 13:54 Goober5000 Note Added: 0006425
2006-08-09 14:06 taylor Note Added: 0006426
2006-08-09 15:27 Goober5000 Note Added: 0006427
2006-08-09 17:33 taylor Note Added: 0006428
2006-08-09 17:34 taylor Note Edited: 0006428
2006-08-09 18:53 Goober5000 Note Added: 0006429
2006-08-15 14:41 ARSPR File Added: strings.tbl (English fixed).zip
2006-08-15 14:45 ARSPR Note Added: 0006453
2006-08-15 16:24 Goober5000 Note Added: 0006456
2006-08-16 10:14 ARSPR Note Added: 0006457
2007-04-11 03:26 Goober5000 Note Added: 0007956
2007-04-11 03:27 Goober5000 Note Added: 0007957
2007-04-11 03:50 taylor Note Added: 0007962
2007-04-11 03:51 taylor Assigned To Goober5000 => taylor
2007-04-11 03:51 taylor Status feedback => assigned
2007-04-11 03:51 taylor Resolution reopened => open
2007-04-11 19:34 taylor Note Added: 0007966
2007-04-12 02:10 Goober5000 Note Added: 0007972
2007-04-12 02:10 Goober5000 Assigned To taylor => Da_Brain
2007-04-12 02:10 Goober5000 Category user interface => mediaVP
2007-04-12 02:10 Goober5000 Additional Information Updated
2007-04-12 02:28 taylor File Added: mv_strings-lcl.tbm
2007-04-12 02:30 taylor Note Added: 0007978
2007-04-12 02:58 Goober5000 Note Added: 0007979
2007-06-20 19:04 Da_Brain Note Added: 0008185
2007-06-20 19:05 Da_Brain Note Edited: 0008185
2007-06-21 04:33 Goober5000 Note Added: 0008186
2007-07-03 23:08 Da_Brain Note Added: 0008205
2008-01-10 21:18 Wanderer Note Added: 0008807
2008-10-27 05:01 Wanderer Status assigned => resolved
2008-10-27 05:01 Wanderer Resolution open => fixed
2008-10-27 05:01 Wanderer Note Added: 0010130
+Issue History