2018-06-20 02:51 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000009FSSCPgameplaypublic2006-10-26 23:28
Reporterdiamondgeezer 
Assigned ToGoober5000 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6 
Summary0000009: Inappropriate message head animations
DescriptionEach pilot persona has three head anis - moving, moving a lot and dying. Sometimes FS2 will play the dying animation for a pilot whose just sending a simple message. Obviously this looks completely stupid and needs fixing so it will only choose from the two 'normal' anis.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000082

Goober5000 (administrator)

Ok... this should now be fixed; check the 1-20-2004 build.

~0000161

Goober5000 (administrator)

Nope, *now* it's fixed. It looks like the problem was caused by having a message with no persona assigned. This would cause FS to access some undefined location of memory and cause weird things to happen.

I fixed the code so that it will now behave properly on messages with no personas.
+Notes

-Issue History
Date Modified Username Field Change
2003-12-18 16:27 diamondgeezer New Issue
2004-01-20 18:00 Goober5000 Note Added: 0000082
2004-01-20 18:00 Goober5000 Assigned To => Goober5000
2004-01-20 18:00 Goober5000 Status new => assigned
2004-02-05 04:47 Goober5000 Note Added: 0000161
2004-02-05 04:47 Goober5000 Status assigned => resolved
2004-02-05 04:47 Goober5000 Resolution open => fixed
2006-10-26 23:28 Goober5000 Status resolved => closed
2006-10-26 23:28 Goober5000 Fixed in Version => 3.6
2006-10-26 23:28 Goober5000 Summary Innapropriate message head animations => Inappropriate message head animations
+Issue History