2019-12-09 05:22 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000853FSSCPFREDpublic2008-03-28 01:12
Reporterstarman01 
Assigned Totaylor 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.10 
Summary0000853: FRED can't play voicefiles anymore
DescriptionThe function to play a voicefile doesn't work anymore. When I push the button I just receive the "Ehhh"-Sound from the internal-speacker.

Voice-lines are definitly there (since the mission works ingame)
Additional InformationNoticed that first with the "fred2_open_r-P420060226.exe", but I haven't updated Fred vor a while
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0005050

starman01 (reporter)

Oh, and on a sidenote, it appears that the problem has returned, where the wingmen info (in ships editor) is partially deleted, when you switch through the different wing in the wing-edit screen :-(

~0005060

Goober5000 (administrator)

No sidenotes please. If it's a different bug, open a different bug report for it.

~0005431

phreak (developer)

fixed.

~0006152

Goober5000 (administrator)

Starman reports that this is back with RC5.

~0006154

phreak (developer)

works for me. Make sure that the file is located in a folder covered by the selected mod or is in the main data directory. The sound can NOT be in a VP File.

~0006167

starman01 (reporter)

Last edited: 2006-07-14 12:50

The sounds were always in the correct folders under the data-tree. I try again

(edit) Just copied the fred.exe from RC5 again into the game folder and tried it, I only get a error-twiep from the internal pc-speaker when I hit the play button, nothing more.

edited on: 07-14-06 12:50

edited on: 07-14-06 12:50

~0006224

starman01 (reporter)

Are you guys still waiting for a feedback here? I edited my last post, so maybe you missed that. I copied the exe again, and while everything is at it's proper location (though of course I use a unique folder, D:\095\ ) no wavs are being played anymore. I just get the alarm sound of the internal pc-speaker (not even over the soundcard, just a motherboard honk ).

~0006226

phreak (developer)

looking at the original post:

"I just figured out that in the RC5 build the mantis bug 0000853 has come back. Additionally what I posted back then, I can't also play briefing and debriefing wavs anymore. You might want to reopen that mantis bug then again (if I'm not the only one with that problem)"

You should have said debriefing and briefing since this bug report only deals with the event editor, from the picture at least.

~0006227

starman01 (reporter)

Sorry, might be a little confusing since the original post didn't include briefing/debriefing (at least I'm not sure it worked or not).

However, I also can't play the wavs in the Event-editor, that's why I mentioned this bug-report. No wavs are working anymore. It's strange that it's working for you though, maybe there is a problem with my machine and/or config.

~0006242

Goober5000 (administrator)

K. A file placed in FreeSpace2/data/voice/special will play for me in the event editor. However, a file placed in FreeSpace2/data/voice/briefing will not play in the briefing editor; instead the standard Windows ping plays.

Moreover, if I try to play a nonexistent file in the event editor, the following error appears:

"You can not preview sounds inside a .VP packfile.
yarr.wav is in the packfile รณ■■:■.
If you've since extracted this file, restart FRED2 Open to preview this sound."

~0006252

taylor (administrator)

Honestly, I think it would probably be better if we just had this run though OpenAL instead of the Windows thing. I can either add support for using OpenAL directly through FRED2, or add an extra *_raw() sound playing interface to go through the regular FS2 sound system (which would still be OpenAL basically). Going through OpenAL directly shouldn't be too bad (basically just make a simple FRED2 specific sound interface) and would allow the same supported formats (OGG, WAVs) plus allow playing sounds out of a VP.

Unless there are any objections I'll try and get that done by this weekend.

~0006371

starman01 (reporter)

O.K, obviously I had multiple codec-problems on my machine due to all those testings. I have now made a complete new install of my OS, and now I can play voicelines in the Event-Editor again. But I can now also confirm that the briefing and debriefing is still dead when I try to play the file.

~0007911

karajorma (administrator)

That might have something to do with a rather silly error in the way the function is being called. I've fixed this now and I'll be committing it tomorrow.

~0007936

karajorma (administrator)

Well this is fixed for .wav files now but I don't know what to do with .ogg. I think I'll leave them for the time being.

~0009043

taylor (administrator)

I've got this fixed locally and should be able to commit later tonight or tomorrow. It should now work through the audiostr code, and so will play files out of VPs, as well as support both WAV and OGG files. It's a little work intensive, since it loads and unloads the file every time, but through FRED that should never really be an issue (unlike it would be with the real game).

~0009045

taylor (administrator)

Fixered.
+Notes

-Issue History
Date Modified Username Field Change
2006-03-05 08:53 starman01 New Issue
2006-03-05 08:53 starman01 File Added: fred-error6.jpg
2006-03-05 08:55 starman01 Note Added: 0005050
2006-03-07 12:23 Goober5000 Note Added: 0005060
2006-04-30 11:50 phreak Status new => resolved
2006-04-30 11:50 phreak Resolution open => fixed
2006-04-30 11:50 phreak Assigned To => phreak
2006-04-30 11:50 phreak Note Added: 0005431
2006-07-12 15:03 Goober5000 Status resolved => feedback
2006-07-12 15:03 Goober5000 Resolution fixed => reopened
2006-07-12 15:03 Goober5000 Note Added: 0006152
2006-07-12 16:51 phreak Note Added: 0006154
2006-07-14 12:18 starman01 Note Added: 0006167
2006-07-14 12:50 starman01 Note Edited: 0006167
2006-07-14 12:50 starman01 Note Edited: 0006167
2006-07-19 11:23 starman01 Note Added: 0006224
2006-07-19 11:32 phreak Note Added: 0006226
2006-07-19 11:39 starman01 Note Added: 0006227
2006-07-19 20:28 Goober5000 Note Added: 0006242
2006-07-19 22:20 taylor Note Added: 0006252
2006-07-30 08:57 starman01 Note Added: 0006371
2007-04-05 21:08 karajorma Status feedback => assigned
2007-04-05 21:08 karajorma Assigned To phreak => karajorma
2007-04-05 22:24 karajorma Note Added: 0007911
2007-04-09 18:11 karajorma Note Added: 0007936
2008-03-27 22:29 taylor Assigned To karajorma => taylor
2008-03-27 22:33 taylor Note Added: 0009043
2008-03-28 01:12 taylor Status assigned => resolved
2008-03-28 01:12 taylor Fixed in Version => 3.6.10
2008-03-28 01:12 taylor Resolution reopened => fixed
2008-03-28 01:12 taylor Note Added: 0009045
+Issue History