2018-09-25 23:59 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000007FSSCPHT&Lpublic2006-10-26 23:24
ReporterFry_Day 
Assigned ToFry_Day 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6 
Summary0000007: Engine glows render as white, nontransparent quads in OpenGL
Descriptionnt
Additional InformationMost of the time they render wrong, but it seems to be affected by the most strange and unrelated things, such as the fact that firing primaries sometimes causes them to revert to being drawn normally for a short while, or that in some specific angle (which is seemingly random) they also draw correctly. wierd.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000001

Fry_Day (developer)

Note that this is in OpenGL HT&L (Which is why I placed it under the HT&L category and mentioned OpenGL)

~0000002

Fry_Day (developer)

I've been unable to trace this one, because everything seemed to be moving along just fine, but I'll try again.

Also, it seems that particles are affected too, but other things, such as sun glows and lens flares (Which I seem to be the only person using :) render just fine.

~0000003

Fry_Day (developer)

The bug itself is definitely rendering the quads when the texture is set to NULL (or 0, rather, in OpenGL's case), but when I debugged through it, the texture seemed to be set just fine.

~0000004

Fry_Day (developer)

Finally! It seems that the culprit was the call to glMaterialfv(GL_FRONT_AND_BACK,GL_AMBIENT_AND_DIFFUSE, &col.r); which sets the material diffuse and ambient to 1.0f. For some reason that caused problems with some of the unlit primitives. I suspect a driver bug, but I'm not sure.
+Notes

-Issue History
Date Modified Username Field Change
2003-11-23 06:13 Fry_Day New Issue
2003-11-23 06:14 Fry_Day Note Added: 0000001
2003-11-23 06:18 Fry_Day Note Added: 0000002
2003-11-25 05:23 Fry_Day Note Added: 0000003
2003-11-25 07:48 Fry_Day Status new => resolved
2003-11-25 07:48 Fry_Day Resolution open => fixed
2003-11-25 07:48 Fry_Day Assigned To => Fry_Day
2003-11-25 07:48 Fry_Day Note Added: 0000004
2006-10-26 23:24 Goober5000 Status resolved => closed
2006-10-26 23:24 Goober5000 Fixed in Version => 3.6
+Issue History