2018-06-21 17:07 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000530FSSCPdockingpublic2012-07-01 22:02
ReporterThe Trivial Psychic 
Assigned ToGoober5000 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformAMD-2600+ 1GB DDR400 ATI9600XTOSWin98SEOS VersionSE
Product Version3.6.5 
Target Version3.6.14Fixed in Version 
Summary0000530: Multi-Dock And Wings
DescriptionWhen a wing of ships is docked to a larger ship, as part of its initial status, after saving FRED will deny the Wing editor access to that wing, and upon saving, the following error will be displayed:

Ship "Alpha 1" in wing should be called "XXXXX"

In this case "XXXXX" refers to the first wing docked to a ship (again, as part of its initial status) and it will be the last ship in that wing, no matter how many ships are ain it.
Steps To ReproduceCreate a ship model (or modify an existing one) with enough dockpoints to dock a wing. Place it in FRED, create a non-player wing and dock all ships in this wing to the carrier model. As always, be sure that there is an Alpha wing for the player to be part of, and give the docked wing initial orders of "play dead" (if you plan on playing said mission). Save the mission, then access the wing editor and attempt to select the docked wing. Attempt a second save to view the error message.
Additional InformationI haven't tried multi-docking such as this, in a case when the parasite craft are not in a wing. Also, attempts to play the above scinario result in a CTD soon after carrier arrival. A debug build will bring up an error message during mission load with the following:

Assert: objp->wingnum == -1
File: C:\fs2_open\code\Mission\MissionParse.cpp
Line: 3828
[This filename points to the location of a file on the computer that built this executable]

Call stack:
------------------------------------------------------------------
    parse_wings() parse_mission() parse_main() mission_load() game_start_mission() game_enter_state() gameseq_set_state() game_process_event() gameseq_process_events() WinMainSub() WinMain() WinMainCRTStartup() KERNEL32.DLL bff8b560()
    KERNEL32.DLL bff8b412()
    KERNEL32.DLL bff89dd5()
------------------------------------------------------------------
TagsNo tags attached.
Attached Files

-Relationships
related to 0001185resolvedz64555 Red alert and docked player = BUG 
has duplicate 0001848closedGoober5000 When ai-goal "undock" is set for the "fighers" game crashes 
+Relationships

-Notes

~0003262

Goober5000 (administrator)

Duplicate of 424.
http://lore.maxgaming.net/~scp/mantis/bug_view_page.php?bug_id=0000424

~0004516

Goober5000 (administrator)

Reopened just in case this is still an issue. With the new initial-docking code allowing stuff to dock to wings, this may be fixed. TP, can you check the next CVS?

~0004633

Goober5000 (administrator)

Reminder sent to The Trivial Psychic

Yoo hoo... ;)

~0004634

The Trivial Psychic (reporter)

Sorry, I missed the bug resurrection. I'll give this a try the next chance I get.

~0004648

The Trivial Psychic (reporter)

OK, I just tested this out again. I had a wing of ships docked to a capital ship and the mission wouldn't even load. A debug build gave me:

Warning: There are multiple dock leaders in the docking group containing the leader DH Destroyer 2! Setting DH Destroyer 2 as the sole leader...

It refused to load the mission no matter what I did.

~0004651

Goober5000 (administrator)

Was the wing's arrival cue set to true?

~0004657

The Trivial Psychic (reporter)

The ships in the wing were set to false, but the wing itself was set to true.

~0004658

Goober5000 (administrator)

And yet the wing itself is docked to a carrier.

Try setting the wing's arrival cue to false.

~0004676

The Trivial Psychic (reporter)

When I assign the wing arrival cue to "false", the mission loads fine, so that's solved, but there are other issues I'm now facing. So I'd have some comparisson, I had 2 ships in the mission. One had 6 individual fighters docked to it, while the other had a wing of 6 docked to it. I gave the 6 individual ships in the non-wing "play dead" orders while I have the entire real wing a "play dead" order. When the first ship warped in, the one with the non-wing, I noticed that the individual fighters also generated their own warp effect. For the 2nd ship with the wing attatched, it came out of the warp vortex in a completely different vector than what the vortex was. It then proceeded to flip out widely as it shed the various ships docked to it until there were just 2. Those that were cast out, were destroyed. I even tried giving all the ships "none" for AI. That didn't seem to make a difference. Those that were in the non-wing, also started to act stragely once I fired a heavy weapon at one of them. Primaries and anti-fighter secondaries caused no problems, but when I fired an anit-cap weapon, they suddenly started flipping the ship they were docked to, around and around like the winged ships had. The only solution I can see would be to disable and take out the weapons systems on all docked ships in this instance. I'm concerned that a ship with no AI class and a play-dead 89 order, could suddenly start doing something.

Be advised, all of my recent tests have been with Redmenace's 2006/02/02 build.

~0004696

StratComm (reporter)

On the seperate warp graphics; I had noticed that before with even paired dockings. IIRC it was a triton+cargo in Derelict, and there were two distinct warp holes that opened for the group. It should be one.

~0005723

Goober5000 (administrator)

Okay, there's too much information here. TP, can you open another report that only mentions the existing bug? There are several bugs described here, many of which are fixed, and I don't want to waste time chasing after fixed bugs. If there is more than one bug that still exists, open one report for each bug.

Once that's done, I'll close this.

~0005724

Goober5000 (administrator)

Oh, and if you don't know whether a set of issues is one bug or two, err on the side of making too many bug reports. It's much easier to close duplicate reports than it is to keep track of the status of multiple problems in one report.

~0005756

The Trivial Psychic (reporter)

Well, most of the issues I encountered have disappeared. However, a wing that's docked to another ship, must have its wing arrival set to "false", which isn't done by default. Perhaps, this is the only thing of the original bug, that should get fixed. As a note to anyone trying this, regardless of whether the docked ships are individual or in a wing, they MUST be individually given Play Dead orders, which I set to 89. This works whether AI is set to "none" or not.

As for the rest of the stuff, as long as the above is adhered to, there's no problems. The "Huge" weapons prompting AI resurection isn't happenning, the ship is arriving from subspace in the proper angle, no extra warp effects for the docked craft, no flipping out of the carrier, and no shedding of the parasite fighters. I think that once the issue with a docked wing not being set to "false" arrival in the wing editor is fixed, we can call this closed and there'll be no need to open up any more.

~0005762

Goober5000 (administrator)

From what you said, there still appear to be two bugs:

1) a wing that's docked to another ship must have its wing arrival set to "false", which isn't done by default

2) regardless of whether the docked ships are individual or in a wing, they MUST be individually given Play Dead orders, which I set to 89. This works whether AI is set to "none" or not.

Can you post two Mantis reports regarding these?

~0005828

The Trivial Psychic (reporter)

2 bugs posted. You may close this one.

~0005832

Goober5000 (administrator)

Kthx. :)

~0007164

Goober5000 (administrator)

I'll resolve this when all three child bugs are resolved.

~0008588

Goober5000 (administrator)

Hmm. Upon further examination, this *particular* bug description is caused by something subtly different.

~0013777

Goober5000 (administrator)

Should be fixed as of r8967. (Many of the trunk revisions from 8914 to 8967 were mentioned in this ticket in one way or another.)
+Notes

-Issue History
Date Modified Username Field Change
2005-09-04 12:36 The Trivial Psychic New Issue
2005-09-04 14:42 Goober5000 Note Added: 0003262
2005-09-04 14:42 Goober5000 Assigned To => Goober5000
2005-09-04 14:42 Goober5000 Status new => closed
2006-01-27 22:49 Goober5000 Status closed => feedback
2006-01-27 22:49 Goober5000 Resolution open => reopened
2006-01-27 22:49 Goober5000 Note Added: 0004516
2006-02-01 21:48 Goober5000 Note Added: 0004633
2006-02-01 23:08 The Trivial Psychic Note Added: 0004634
2006-02-04 20:05 The Trivial Psychic Note Added: 0004648
2006-02-04 20:51 Goober5000 Note Added: 0004651
2006-02-05 12:32 The Trivial Psychic Note Added: 0004657
2006-02-05 13:05 Goober5000 Note Added: 0004658
2006-02-06 09:16 Goober5000 Category FRED graphics => docking
2006-02-06 10:52 Goober5000 Status feedback => assigned
2006-02-06 14:56 The Trivial Psychic Note Added: 0004676
2006-02-09 11:43 StratComm Note Added: 0004696
2006-06-03 01:41 Goober5000 Note Added: 0005723
2006-06-03 01:42 Goober5000 Note Added: 0005724
2006-06-04 02:11 The Trivial Psychic Note Added: 0005756
2006-06-04 14:48 Goober5000 Note Added: 0005762
2006-06-11 15:17 The Trivial Psychic Note Added: 0005828
2006-06-11 23:54 Goober5000 Status assigned => closed
2006-06-11 23:54 Goober5000 Note Added: 0005832
2006-11-24 17:58 Goober5000 Resolution reopened => fixed
2006-11-24 17:58 Goober5000 Fixed in Version => 3.6.9
2006-11-24 17:59 Goober5000 Relationship added parent of 0000424
2006-11-24 18:01 Goober5000 Relationship added parent of 0000944
2006-11-24 18:04 Goober5000 Relationship added parent of 0000945
2006-11-24 18:05 Goober5000 Status closed => assigned
2006-11-24 18:05 Goober5000 Resolution fixed => open
2006-11-24 18:05 Goober5000 Fixed in Version 3.6.9 =>
2006-11-25 02:06 Goober5000 Note Added: 0007164
2007-10-22 01:40 Goober5000 Relationship added related to 0001185
2007-10-22 01:41 Goober5000 Relationship deleted parent of 0000424
2007-10-22 01:41 Goober5000 Relationship deleted parent of 0000945
2007-10-22 01:41 Goober5000 Relationship deleted parent of 0000944
2007-10-22 01:42 Goober5000 Note Added: 0008588
2012-07-01 04:55 Goober5000 Relationship added has duplicate 0001848
2012-07-01 22:02 Goober5000 Note Added: 0013777
2012-07-01 22:02 Goober5000 Status assigned => resolved
2012-07-01 22:02 Goober5000 Resolution open => fixed
2012-07-01 22:02 Goober5000 Target Version => 3.6.14
+Issue History