2019-10-16 14:15 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000464FSSCPgameplaypublic2008-04-01 20:03
ReporterGoober5000 
Assigned Totaylor 
PrioritynormalSeveritytweakReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.10 
Summary0000464: Weapons fire immediately upon bank change
DescriptionDuring a recent mission I experienced the following bug: I fired the last tornadoes in my current weapon bank at a ship, and then the bank switched and I fired a round of tornadoes from that bank too. Unfortunately this second round didn't do much good, as target lock is lost when you switch banks.

I think the problem arose when a different bug (the fire delay carryover) was fixed. Since there was no fire delay, the weapon fired immediately because of one of two reasons:

1) The player was still pressing the secondary launch button (understandable, since it requires a small delay to stop pressing) and the weapon was a streaming weapon; or

2) The weapon was set to double-fire but there were only enough rounds for a single-fire launch in the first bank. The double-fire thus spanned both banks.

Both these possibilities need investigation. The first could be fixed by adding an internal check to see that the launch button has been released and then pressed again before starting to fire the second bank. The second could be fixed by preventing double-fire across two banks.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0002745

phreak (developer)

usually the 2nd case occurs most often. the missile banks usually carry an amount of missiles that are divisible by 4 and not 8, like 60. Probably the best solution would be to check the next bank if the current one runs out and fire from those if the weapon types are the same. lock should also be maintained in this case.

~0002800

WMCoolmon (developer)

I dunno, if the lock is going to be maintained then, wouldn't it be maintained if you switched banks of the same type?

~0002802

Goober5000 (administrator)

The lock shouldn't be maintained if you switch banks.

~0008492

Goober5000 (administrator)

I think the first case is the real problem. This bug only occurs with streaming weapons, which fire as long as the button is held down.

~0009136

taylor (administrator)

The second case is now fixed (by resetting swarm/corkscrew counts to 0 if out of ammo). I tested that this case demonstrates the same behavior that you described.

I don't think that the first case is a bug though, it sounds like it's doing exactly what it's supposed to do. It may be inconvenient, but that isn't a reason to introduce some hack to address it. Plus, the fix for the second case also makes it honor the 1 second fire delay on bank change again, so that should help avoid this altogether since there should be time to stop pressing the button.

I'm going to go ahead and resolve this, but you can open it back if you still want something else done about the first case (though it really shouldn't be an issue now).

~0009137

taylor (administrator)

Fixered.
+Notes

-Issue History
Date Modified Username Field Change
2005-07-11 11:20 Goober5000 New Issue
2005-07-11 16:15 phreak Note Added: 0002745
2005-07-17 16:58 WMCoolmon Note Added: 0002800
2005-07-17 20:02 Goober5000 Note Added: 0002802
2007-09-04 21:49 Goober5000 Note Added: 0008492
2008-04-01 20:00 taylor Note Added: 0009136
2008-04-01 20:02 taylor Status assigned => resolved
2008-04-01 20:02 taylor Fixed in Version => 3.6.10
2008-04-01 20:02 taylor Resolution open => fixed
2008-04-01 20:02 taylor Note Added: 0009137
2008-04-01 20:03 taylor Status resolved => assigned
2008-04-01 20:03 taylor Assigned To Goober5000 => taylor
2008-04-01 20:03 taylor Status assigned => resolved
+Issue History