2019-10-18 23:35 EDT


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0000043FSSCPgameplaypublic2012-01-09 13:06
Reporterkasperl 
Assigned Totaylor 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.9 
Summary0000043: 7< glowpoints crashes FRED and FS3,4
Descriptioni've found in testing, that in fs_open 3.4 there seems to be a limit on the #
of thruster glows on a player flyable ship-capped at 7, while in the normal exe
there doesn't seem to be such a limit, or it is over 8, because the same model
worked in fred and game, but killed fred_open and FS_open with the very un-
informing illegal operation error when i tried to place the offending model. i
went through each chunk and found it is definitly the # of glows in the fuel
chunk. 7 works, 8 doesn't.
to reproduce:
1) add two glow points to the herc2. (complete with radius, position & normal)
2)open fred 3.4 and try to place a herc2 anywhere. it dies. it will work in the
originals though
thanks for listening :)

------- Additional Comment 0000001 From VA 2003-07-14 09:28 -------
Ok, i've just noticed that this limit seems to apply to the number of glow-
points per bank as well. If you exceed 7 glow-points in any one glowbank, it
crashes upon placing the offending ship in fred. Could this limit be bumped
possibly?
It *seems* an easy enough fix. :)
Additional InformationReporter: Vasudan_Ad@hotmail.com (VA)
Assigned To: fs2source@warpcore.org (Edward Gardner)
http://fs2source.warpcore.org/bugzilla/show_bug.cgi?id=58
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000470

Goober5000 (administrator)

Assigning to Bobboau.

~0000490

Bobboau (developer)

the number of glow points you can have is currently set to 30, it has been for a while now, this bug is so out of date I don't think it can be relied upon

though this has brought my attention back to gloe points again, I realy should probly organise them better, they use a bunch of uggly paralel arrays, I did the origonal code for this before I realy knew what I was doing

~0000495

Goober5000 (administrator)

Wondering about memory usage: is 30 an ideal number? How much memory does each glowpoint use? Might it be a good idea to lower the number?

~0000506

Bobboau (developer)

Last edited: 2004-03-18 04:25

well it's two vectors and a float * 30

what number would you think is better, I beleve this is exactly twice the retail number (this is used in glow points and thruster glows)

I think I'm going to restructure this now

edited on: 03-18-04 04:25

~0000532

Bobboau (developer)

seeing as this seems to be based on an old biuld and should be resolved, I'm closeing this

~0007057

taylor (administrator)

I just went ahead and made all of this stuff dynamic, since the glow point banks are dynamic now too. My changes should make both glow points and thruster points dyanmic.

Fixered.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2004-01-16 05:15 kasperl New Issue
2004-03-15 22:33 Goober5000 Note Added: 0000470
2004-03-15 22:33 Goober5000 Assigned To => Bobboau
2004-03-15 22:33 Goober5000 Status new => assigned
2004-03-16 23:33 Bobboau Note Added: 0000490
2004-03-17 00:20 Goober5000 Note Added: 0000495
2004-03-18 04:06 Bobboau Note Added: 0000506
2004-03-18 04:25 Bobboau Note Edited: 0000506
2004-03-21 19:16 Bobboau Status assigned => closed
2004-03-21 19:16 Bobboau Note Added: 0000532
2006-11-01 12:33 taylor Note Added: 0007057
2006-11-01 12:33 taylor Assigned To Bobboau => taylor
2006-11-01 12:33 taylor Status closed => resolved
2006-11-01 12:33 taylor Resolution open => fixed
2006-11-01 12:33 taylor Fixed in Version => 3.6.9
2012-01-05 17:55 taylor Changeset attached => Import 2012-01-05 17:52:05 fs2_open_3_6_9 r3678
2012-01-05 17:55 taylor Changeset attached => Import 2012-01-05 17:52:05 trunk r3717
2012-01-09 13:06 taylor Changeset attached => fs2open_websvn fs2_open_3_6_9 r3678
2012-01-09 13:06 taylor Changeset attached => fs2open_websvn trunk r3717
+Issue History