2018-06-24 12:06 EDT


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0002959FSSCPgraphicspublic2013-11-26 14:36
Reporterchief1983 
Assigned Tochief1983 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusresolvedResolutionfixed 
Platformx86OSWindows XP32OS VersionSP3
Product Version3.7.1 
Target Version3.7.2Fixed in Version3.7.1 
Summary0002959: r10111 Assertion Failure Scene_depth_texture != 0
DescriptionPlaying a 2 person Aeolus Duel with retail data. Took out a few fighters, then suddenly the game ended when the remote client I had running over VNC crashed out with this assertion. Server running 10129, other client also running 10111 I believe.
Steps To ReproducePlay Aeolus Duel on multi for a while, may or may not happen. Wish I had more info, but just want it known that this assert is reachable somehow. Will try to at least get a call stack next time I try to run this.
Additional InformationAssert: Scene_depth_texture != 0
File: gropengldraw.cpp
Line: 1452

<no module>! KiFastSystemCallRet
<no module>! WaitForSingleObject + 18 bytes
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! RegisterWaitForInputIdle + 73 bytes
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0015439

chief1983 (administrator)

Assert: Scene_depth_texture != 0
File: gropengldraw.cpp
Line: 1452

<no module>! KiFastSystemCallRet
<no module>! WaitForSingleObject + 18 bytes
<no module>! SCP_DumpStack + 354 bytes
<no module>! WinAssert + 194 bytes
<no module>! gr_opengl_render_effect + 123 bytes
<no module>! geometry_batcher::render + 157 bytes
<no module>! batch_render_distortion_map_bitmaps + 284 bytes
<no module>! batch_render_all + 381 bytes
<no module>! obj_render_all + 1340 bytes
<no module>! game_render_frame + 664 bytes
<no module>! game_frame + 749 bytes
<no module>! game_do_frame + 237 bytes
<no module>! game_do_state + 379 bytes
<no module>! gameseq_process_events + 237 bytes
<no module>! game_main + 782 bytes
<no module>! WinMain + 330 bytes
<no module>! __tmainCRTStartup + 358 bytes
<no module>! WinMainCRTStartup + 15 bytes
<no module>! RegisterWaitForInputIdle + 73 bytes

Got a call stack at least now. Not much else.

~0015445

chief1983 (administrator)

Ignore 10132 being linked, goofed on the commit number in the message.

~0015447

chief1983 (administrator)

Ok, I let the XP box be the host this time, and my primary Win7 machine be the client, and the XP box is still the one that asserted. 27 seconds into the mission.

~0015451

chief1983 (administrator)

It is framebuffer shockwaves breaking, because of my lack of apparent hardware support for the feature. GLView reports it at 1.5.7 even though I thought it was a GL2 compliant card. This feature should probably be checked to make sure the required extensions are available before using it.

~0015453

chief1983 (administrator)

Fix committed to trunk@10145.

~0015454

niffiwan (developer)

to add credit
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2013-11-20 02:06 chief1983 New Issue
2013-11-20 02:06 chief1983 File Added: fs2_open.log
2013-11-20 22:13 chief1983 Note Added: 0015439
2013-11-20 23:15 chief1983 Changeset attached => fs2open trunk r10132
2013-11-20 23:15 chief1983 Status new => resolved
2013-11-20 23:15 chief1983 Resolution open => fixed
2013-11-20 23:16 chief1983 Assigned To => chief1983
2013-11-20 23:16 chief1983 Status resolved => assigned
2013-11-20 23:18 chief1983 Status assigned => resolved
2013-11-20 23:18 chief1983 Fixed in Version => 3.7.1
2013-11-20 23:18 chief1983 Assigned To chief1983 =>
2013-11-20 23:18 chief1983 Status resolved => new
2013-11-20 23:18 chief1983 Resolution fixed => open
2013-11-20 23:20 chief1983 Note Added: 0015445
2013-11-21 01:33 chief1983 Note Added: 0015447
2013-11-21 19:05 chief1983 Note Added: 0015451
2013-11-21 23:38 chief1983 Changeset attached => fs2open trunk r10145
2013-11-21 23:38 chief1983 Note Added: 0015453
2013-11-21 23:38 chief1983 Status new => resolved
2013-11-21 23:38 chief1983 Resolution open => fixed
2013-11-21 23:56 niffiwan Assigned To => niffiwan
2013-11-21 23:56 niffiwan Note Added: 0015454
2013-11-21 23:56 niffiwan Status resolved => feedback
2013-11-21 23:56 niffiwan Resolution fixed => reopened
2013-11-21 23:56 niffiwan Status feedback => resolved
2013-11-21 23:56 niffiwan Resolution reopened => fixed
2013-11-21 23:56 niffiwan Assigned To niffiwan => chief1983
2013-11-26 14:36 Goober5000 Changeset removed fs2open trunk r10132 =>
+Issue History