2019-12-07 16:56 EST


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0002912FSSCPmultiplayerpublic2014-02-21 07:05
ReporterHalcyonY2K 
Assigned Tokarajorma 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.16 
Summary0002912: Hud-set-max-targeting-range SEXP for Multiplayer
DescriptionWhen creating multiplayer missions, the SEXP "Hud-set-max-targeting-range" will limit the radar range on the fighter flown by the server but it won't limit any client connected to the server. The client end ships continue to operate with radar range up to infiniti.
Steps To ReproduceAdd "Hud-set-max-targeting-range" on any multiplayer mission.

Observe that it only limits the fighter played by the server and that the client machines are not affected by the limitation.

TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0015246

karajorma (administrator)

I've just fixed the problem, but it seems to me that the SEXP really should have another optional parameter so that you can specify which player is affected. Right now you give the command and everyone is affected in the same way.

~0015247

karajorma (administrator)

Fix committed to trunk@9750.

~0015248

karajorma (administrator)

I'll close this properly once I add the extra parameter I mentioned earlier.

~0015627

karajorma (administrator)

Since I've decided to make that extra parameter something that a lot more SEXPs can use, there's no need to half-arse it for this SEXP.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2013-08-27 21:49 HalcyonY2K New Issue
2013-08-29 03:19 karajorma Assigned To => karajorma
2013-08-29 03:19 karajorma Status new => assigned
2013-08-29 03:27 karajorma Note Added: 0015246
2013-08-29 03:33 karajorma Changeset attached => fs2open trunk r9750
2013-08-29 03:33 karajorma Note Added: 0015247
2013-08-29 03:33 karajorma Status assigned => resolved
2013-08-29 03:33 karajorma Resolution open => fixed
2013-08-29 03:34 karajorma Note Added: 0015248
2013-08-29 03:34 karajorma Status resolved => feedback
2013-08-29 03:34 karajorma Resolution fixed => reopened
2013-09-28 17:55 Goober5000 Project wxFRED => FSSCP
2013-12-03 07:21 Echelon9 Category => multiplayer
2014-02-21 07:04 karajorma Note Added: 0015627
2014-02-21 07:05 karajorma Status feedback => resolved
2014-02-21 07:05 karajorma Fixed in Version => 3.6.16
2014-02-21 07:05 karajorma Resolution reopened => fixed
+Issue History