2017-11-17 20:53 EST


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0002905FSSCPgameplaypublic2013-12-04 03:17
ReporterThe Trivial Psychic 
Assigned Toniffiwan 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformAMD Ph-II-X2 560 4G ATI-5770-1GOSWindows 7 64-bitOS VersionProfessional
Product Version3.6.19 
Target VersionFixed in Version3.7.1 
Summary0002905: Heat Seeking Weapons Show In Range When Target Subsystem Is Not
DescriptionI've found that weapons that use heat-seeking targeting, will show that a target subsystem is in range because one portion of the host ship is in range. Turrets and subsystems that are out of range on a selected ship, will appear to be within range. This will cause new players to waste missiles unnecessarily against targets they can't hit.
Steps To ReproducePlaying the attached mission, move your fighter within Stiletto firing range of the hostile Colossus' nearest turret. Fire off a salvo and you will see that it will hit the target subsystem. Then turn slightly and target one of the turrets along the Colossus' port side towards the nose, which should be well out of range of the Stiletto. You will see that it is still listed as within range by the target indicator. Fire off a salvo and watch as it tracks to the subsystem, but destructs short of it. Then repeat the process using one of the supplied Harpoons. You will see that it won't throw up the target lock animation until you are actually within range of the subsystem. Therefore, this behavior is limited to heat-seeking weapons only.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0015376

niffiwan (developer)

Fix committed to trunk@9998.

~0015377

niffiwan (developer)

Please grab the next nightly build that includes r9998 and confirm that this fixes the issue.
http://www.hard-light.net/forums/index.php?board=173.0

The cause of the problem was that the target ships bounding box was being used for the secondaries "in range" lead sight when targeting a subsystem. This can be quite inaccurate when targeting large ships.

~0015379

The Trivial Psychic (reporter)

Copy that. I await with baited breath.

~0015411

niffiwan (developer)

Have you had a chance to confirm that the problem is gone in the latest nightlies?

~0015503

niffiwan (developer)

OK - its been a month and I believe this is resolved. Please reopen if you of believe its not fixed properly :)
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2013-07-29 21:37 The Trivial Psychic New Issue
2013-07-29 21:37 The Trivial Psychic File Added: MissileRangeTest.fs2
2013-11-02 04:39 niffiwan Assigned To => niffiwan
2013-11-02 04:39 niffiwan Status new => assigned
2013-11-02 04:51 niffiwan Changeset attached => fs2open trunk r9998
2013-11-02 04:51 niffiwan Note Added: 0015376
2013-11-02 04:51 niffiwan Status assigned => resolved
2013-11-02 04:51 niffiwan Resolution open => fixed
2013-11-02 04:54 niffiwan Note Added: 0015377
2013-11-02 04:54 niffiwan Status resolved => feedback
2013-11-02 04:54 niffiwan Resolution fixed => reopened
2013-11-02 07:09 The Trivial Psychic Note Added: 0015379
2013-11-02 07:09 The Trivial Psychic Status feedback => assigned
2013-11-16 00:35 niffiwan Note Added: 0015411
2013-12-04 03:17 niffiwan Note Added: 0015503
2013-12-04 03:17 niffiwan Status assigned => resolved
2013-12-04 03:17 niffiwan Fixed in Version => 3.7.1
2013-12-04 03:17 niffiwan Resolution reopened => fixed
+Issue History