2020-08-13 03:27 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000029FSSCPgraphicspublic2004-10-11 15:43
ReporterFlipside 
Assigned ToGoober5000 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000029: Skyboxes centre on targetted object.
DescriptionPhreak's skyboxes will place their centre on the currently targetted object, so they jump around a lot during play.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000015

Lightspeed (reporter)

this also happens with the subspace models.

They dont jump around here, they just vanish as soon as something's targetted.

~0000017

Goober5000 (administrator)

This is interesting. It appears that all Phreak's code does is assign the skybox model to the existing background POF code for displaying FS1-style nebulas. Which means that the actual Volition code somehow got screwed up between FS1 and FS2. Phreak, want to take a look?

~0000064

phreak (developer)

whats going on is that the T&L matrices aren't setup when the skybox is drawn. The normal bitmaps and such don't use T&L so all the T&L setup code goes after when the stars are drawn.

a quick hack would be to set Cmdline_nohtl to 1 and then resore it to its original value when the stars are done drawing.

A more long term solution would be to rewrite the stars_draw function to make it use the T&L pipeline

~0000101

Goober5000 (administrator)

I'd rather the long term solution than the quick hack.

~0000127

Flipside (reporter)

I don't know if this is anything to do with the problem, but I've also noticed a strange 'lag' in the skybox response when I turn the ship, so I see the ship in view rotate as I move, and the skybox almost rubberbands behind it? I wish I could post pics, but they really would not show what I mean. I might be able to get a short AVI of the effect and Email to Phreak if needed.

~0000392

Bobboau (developer)

this has been fixed, veiw zoom was getting set incorectly

~0000398

phreak (developer)

Last edited: 2004-03-08 17:20

well in OpenGL, the matrices can't be set or the normal nebulas won't be drawn correctly

but if the t&l matrices aren't set the skybox doesn't show up

right now i have something like this going on to fix it until we can have stars use T&L

    //fugly hack. this will make the skybox render in HT&L
    //i want the stars_draw() function to get ported to HT&L quick
    int nohtl_save = Cmdline_nohtl;
    Cmdline_nohtl = 1;
    if ( Game_subspace_effect ) {
        stars_draw(0,0,0,1);
    } else {
        stars_draw(1,1,1,0);
    }
    Cmdline_nohtl = nohtl_save;

this is the final incarnation of said hack. ignore all the edits i've done :)

edited on: 03-08-04 17:20

~0000709

Kazan (developer)

so is this bug resolved as far as 3.6 is concerned?

~0000711

phreak (developer)

i wouldn't say so since its not fixed gracefully. i'll resolve/close this once the backgrounds are drawn correctly using HTL and not using that hack

~0000713

Kazan (developer)

is it resolved as far as releasing 3.6 is concerned since AFAIK stars are not going to be HTL drawn in 3.6?

~0000716

Goober5000 (administrator)

It works from a gameplay standpoint and it won't hold up the release of 3.6. But don't "resolve" it lest we forget about it.

~0000727

Kazan (developer)

k

~0001128

taylor (administrator)

This should be properly fixed now. With Bob's index buffers the starfield bitmaps are rendered in HTL.

~0001163

phreak (developer)

awesome

~0001297

Goober5000 (administrator)

Resolvage!
+Notes

-Issue History
Date Modified Username Field Change
2004-01-09 18:55 Flipside New Issue
2004-01-10 20:10 Lightspeed Note Added: 0000015
2004-01-14 00:26 Goober5000 Assigned To => user22
2004-01-14 00:26 Goober5000 Status new => assigned
2004-01-14 00:26 Goober5000 Additional Information Updated
2004-01-14 00:27 Goober5000 Additional Information Updated
2004-01-14 00:29 Goober5000 Note Added: 0000017
2004-01-14 00:29 Goober5000 Additional Information Updated
2004-01-17 15:53 Goober5000 Assigned To user22 => phreak
2004-01-18 11:57 phreak Note Added: 0000064
2004-01-25 23:35 Goober5000 Note Added: 0000101
2004-01-28 19:08 Flipside Note Added: 0000127
2004-03-08 12:41 Bobboau Status assigned => resolved
2004-03-08 12:41 Bobboau Resolution open => fixed
2004-03-08 12:41 Bobboau Assigned To phreak => Bobboau
2004-03-08 12:41 Bobboau Note Added: 0000392
2004-03-08 13:42 phreak Status resolved => feedback
2004-03-08 13:42 phreak Resolution fixed => reopened
2004-03-08 13:42 phreak Note Added: 0000398
2004-03-08 14:24 phreak Note Edited: 0000398
2004-03-08 14:25 phreak Status feedback => assigned
2004-03-08 14:25 phreak Assigned To Bobboau => phreak
2004-03-08 14:27 phreak Note Edited: 0000398
2004-03-08 14:27 phreak Note Edited: 0000398
2004-03-08 17:20 phreak Note Edited: 0000398
2004-04-06 21:18 Kazan Note Added: 0000709
2004-04-06 22:06 phreak Note Added: 0000711
2004-04-06 22:27 Kazan Note Added: 0000713
2004-04-07 01:27 Goober5000 Note Added: 0000716
2004-04-07 08:59 Kazan Note Added: 0000727
2004-08-04 09:36 taylor Note Added: 0001128
2004-08-20 09:55 phreak Note Added: 0001163
2004-10-11 15:43 Goober5000 Status assigned => resolved
2004-10-11 15:43 Goober5000 Resolution reopened => fixed
2004-10-11 15:43 Goober5000 Assigned To phreak => Goober5000
2004-10-11 15:43 Goober5000 Note Added: 0001297
+Issue History