2020-12-02 16:04 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002827FSSCPmultiplayerpublic2020-11-19 20:47
ReporterHunter 
Assigned ToFSCyborg 
PriorityhighSeverityblockReproducibilityalways
StatusresolvedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0002827: Problems configuring multiplayer connections
DescriptionThread renamed to reflect non widespread nature of the original reporter's problem

It doesnt matter how much you play with port forwarding, dmz or going over to friends houses, we are permablocked. This has been an ongoing problem for many many years and has kept me from playing for a long long time. The only standalones availilble for play run 400ms here in america and is completely unplayable. Please help us find a way to get us back online!!!
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0014852

Echelon9 (developer)

While possible, it sounds a little hyperbolic to say definitively that all American DSL connections are somehow blocked without further evidence.

Have you discussed this on the Freespace Multiplayer sub-forum? http://www.hard-light.net/forums/index.php?board=135.0

I'm inclined to view this as more likely to be a configuration issue that can be more effectively resolved in the forums, rather than an engine issue or bug for fixing here on Mantis.

~0014853

Hunter (reporter)

Last edited: 2013-03-29 06:01

View 8 revisions

5 connections i have access too, and 4 friends accross the states who also are in the same situation. Yeah ALL. I have spent TOO MUCH time trying to figure it out, and talking to people in the community i have on chat about this issue. We just want to play this game!!!

Fubars Standalones are generous but we arent on that side of the planet. 400ms in game is unplayable.

~0014854

Echelon9 (developer)

Okay, but a Mantis issue for this type of problem you're experiencing isn't going to resolve much.

Better to test your configuration setup thoroughly on the forums / IRC where we can help you figure it out.

~0014855

Zacam (administrator)

FUBAR's Standalones are in America, fyi.

Sounds more like an ISP or network (local) issue.

~0014856

Hunter (reporter)

How can it be local when it affects friends in Wisconsin and Missouri aswell, If fubars servers are in america, then there is something seriously wrong with the new code. FS2 should be pingging below 100ms california to wisconsin 50ms in the PXO days

~0014857

Zacam (administrator)

*sighs*

Well, for one, I can tell you that the networking portions of the code itself? Have not had anywhere near the kind of over haul that you think they have.

Granted, that may be a part of the problem in and of itself. What works for modem based IP stack play doesn't generally tend to scale well for broadband.

But if you and your friends are having HUGE ms latency issues reaching standalones (that are merely portaled off the FS2NetD on HLP), then either the Standalone hosts connections are having an issue, or your ISPs peering is having difficulty.

And as for it being a local issue (that repeats in various locations across the states) that can happen very easily if you've all made the same assumptions about your network setups.

~0014858

FUBAR-BDHR (developer)

Yep my standalones are in the US and up until a couple of months ago were on DSL. Now they are on Uverse but in this area that is actually still DSL. So DSL in the US is not blocked in any way by FS2netD. If your having issues it's elsewhere.

~0014859

Hunter (reporter)

Last edited: 2013-03-29 22:22

View 2 revisions

How do i get 400ms on the same ISP as fubar. WTF

~0014920

Zacam (administrator)

Maybe run a tracert (Trace Route) from your connection to the Standalone's IP address and view where the packets take the most time? That will be your problem, not FSO.

~0015489

Echelon9 (developer)

Mantis is not for general support requests. Also not fire and forget bug tracking.

~0015501

Hunter (reporter)

Last edited: 2013-12-03 22:56

View 9 revisions

Its still broken for everyone. Why was this closed. We are still waiting for this issue to be resolved. It seems like if your not a DEV you get the middle finger. I wonder if this game will ever be playable again. Nobody can host, not turey, not anyone I know. I posted this here because I was told to by members of your community.

This ticket needs resolution, not closure. People who wern't blocked and didn't change their internet are now blocked. The world is changing how the internet works. The problem is your code.

~0015502

niffiwan (developer)

o_O I've been able to connect to FUBAR's standalones and play a game. Not that they're up at the moment, but go back 3-6 months when they were and it was OK. If we can't reproduce the problem, it makes it exceedingly difficult to troubleshoot.

Maybe organise a time (using the Multi Forum) to connect to the #multi IRC channel and attempt to work through the problems in realtime? Maybe you could also run that tracert that Zacam suggested in April and post the results?

~0015504

Hunter (reporter)

Last edited: 2013-12-04 12:24

View 7 revisions

Fine, I will be uploading video to youtube showing you configurations on everyones connection!!! We arent idiots and two of us are employed in IT. But apparently you need a walk through. I have been playing this game for 13 years, I know how to set it up.

~0015505

niffiwan (developer)

Last edited: 2013-12-04 16:32

View 2 revisions

Hey - if you're in IT can you provide packet captures of your connection attempts as well?

It'd also help to have a read of this:
http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

~0015506

chief1983 (administrator)

Pretty sure there are definitely some connection establishment bugs in the code, not sure how old they are but they're definitely there. I have run a standalone at my house that I have not been able to connect to from work, but others can, and even from within the same house it can be somewhat of a crapshoot. It should not be that difficult for computers on the same LAN to connect, and any computer with port forwarding set up for anyone to connect to, should be connectable by everyone, assuming there's not blocking going on on the client's side. But that does not currently seem to be the case, and now that the *nix standalone itself seems to be getting pretty stable and usable, figuring out why they're so difficult to connect to was going to be one of the next things I pushed for. I just don't think it's any one specific bug.

~0017028

FSCyborg (developer)

A port bug was fixed in the IPv6 branch. This would keep hosts from being seen unless they were using the default port, 7808, iirc.

All other known connection issues are currently multiple firewall issues or NAT issues, which are not possible for us to code around. The best we can do is help people configure around those connection issues. And these are only server issues. Clients can connect to any server that has their port forwarding and NAT settings correctly configured.

We also know have a link on the PXO server that will show if a server is discoverable. Luckily all of this has been demystifying the process.

The only bug that remains is that servers will not show up immediately on pxo because of a slight packet error that eventually resolves itself. This just means it may take up to 20 minutes for the server to show on the list after creation, although often it does not take this long.

~0017041

taylor (administrator)

Just wanted to update this to say that I have been able to recreate various connection issues locally. I did this by using tools which alter my network config to change speed, ping, introduce packet loss, etc. This allows me to test a wide range of connection types. However, I have /not/ been able to reproduce these issues reliably enough to diagnose the problems in the code.

The addition of port forwarding code and changes to PXO to make it easier to identify and fix problems does help for some of these issues. But there are also some weird gremlins hiding out in psnet2 which are causing problems too. Some of the little ones were hopefully squashed as part of the IPv6 upgrade.

Although it's pretty low priority, tracing those remaining psnet2 issues down is still on my todo list.
+Notes

-Issue History
Date Modified Username Field Change
2013-03-28 22:09 Hunter New Issue
2013-03-29 05:17 Echelon9 Note Added: 0014852
2013-03-29 05:17 Echelon9 Status new => feedback
2013-03-29 05:52 Hunter Note Added: 0014853
2013-03-29 05:52 Hunter Status feedback => new
2013-03-29 05:57 Hunter Note Edited: 0014853 View Revisions
2013-03-29 05:59 Hunter Note Edited: 0014853 View Revisions
2013-03-29 05:59 Hunter Note Edited: 0014853 View Revisions
2013-03-29 05:59 Hunter Note Edited: 0014853 View Revisions
2013-03-29 06:00 Hunter Note Edited: 0014853 View Revisions
2013-03-29 06:01 Hunter Note Edited: 0014853 View Revisions
2013-03-29 06:01 Hunter Note Edited: 0014853 View Revisions
2013-03-29 08:28 Echelon9 Note Added: 0014854
2013-03-29 08:54 Zacam Note Added: 0014855
2013-03-29 08:57 Hunter Note Added: 0014856
2013-03-29 09:15 Zacam Note Added: 0014857
2013-03-29 22:05 FUBAR-BDHR Note Added: 0014858
2013-03-29 22:12 Echelon9 Status new => feedback
2013-03-29 22:12 Echelon9 Summary Completely blocked on all American DSL connections. => Problems configuring multiplayer connections
2013-03-29 22:12 Echelon9 Description Updated View Revisions
2013-03-29 22:21 Hunter Note Added: 0014859
2013-03-29 22:21 Hunter Status feedback => new
2013-03-29 22:22 Hunter Note Edited: 0014859 View Revisions
2013-04-13 19:42 Zacam Note Added: 0014920
2013-12-03 04:49 Echelon9 Note Added: 0015489
2013-12-03 04:49 Echelon9 Status new => closed
2013-12-03 04:49 Echelon9 Resolution open => no change required
2013-12-03 22:42 Hunter Note Added: 0015501
2013-12-03 22:42 Hunter Status closed => feedback
2013-12-03 22:42 Hunter Resolution no change required => reopened
2013-12-03 22:44 Hunter Note Edited: 0015501 View Revisions
2013-12-03 22:45 Hunter Note Edited: 0015501 View Revisions
2013-12-03 22:46 Hunter Note Edited: 0015501 View Revisions
2013-12-03 22:47 Hunter Note Edited: 0015501 View Revisions
2013-12-03 22:48 Hunter Note Edited: 0015501 View Revisions
2013-12-03 22:52 Hunter Note Edited: 0015501 View Revisions
2013-12-03 22:55 Hunter Note Edited: 0015501 View Revisions
2013-12-03 22:56 Hunter Note Edited: 0015501 View Revisions
2013-12-03 23:06 niffiwan Note Added: 0015502
2013-12-04 12:18 Hunter Note Added: 0015504
2013-12-04 12:18 Hunter Status feedback => new
2013-12-04 12:19 Hunter Note Edited: 0015504 View Revisions
2013-12-04 12:20 Hunter Note Edited: 0015504 View Revisions
2013-12-04 12:21 Hunter Note Edited: 0015504 View Revisions
2013-12-04 12:23 Hunter Note Edited: 0015504 View Revisions
2013-12-04 12:24 Hunter Note Edited: 0015504 View Revisions
2013-12-04 12:24 Hunter Note Edited: 0015504 View Revisions
2013-12-04 16:31 niffiwan Note Added: 0015505
2013-12-04 16:31 niffiwan Assigned To => niffiwan
2013-12-04 16:31 niffiwan Status new => feedback
2013-12-04 16:31 niffiwan Assigned To niffiwan =>
2013-12-04 16:32 niffiwan Note Edited: 0015505 View Revisions
2013-12-04 16:49 chief1983 Note Added: 0015506
2020-11-01 10:21 FSCyborg Assigned To => FSCyborg
2020-11-01 10:21 FSCyborg Status feedback => resolved
2020-11-01 10:21 FSCyborg Note Added: 0017028
2020-11-19 20:47 taylor Note Added: 0017041
+Issue History