2022-01-26 06:40 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002719FSSCPOpenGLpublic2012-11-18 13:41
ReporterAdmiral MS 
Assigned ToValathil 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSWindowsOS Version
Product Version 
Target Version3.6.16Fixed in Version 
Summary0002719: Lab crash after switchting from ship debris to another ship
DescriptionThe Lab crashes with a memory access violation (windows is closing the application when not using MSVC for debugging) after switching from ship debris to another ship (not relevant if it's to debris or to normal LODs). It seems that the crash was introduced in revision 9101 (was unable to reproduce it with 9100) and happens in release and debug builds. Tested it without any mods or mediavps active.
Steps To Reproduce1. Open the F3 Lab and the ships menu
2. Select debris of any ship
3. Select another ship
4. repeat 2. and 3. until it crashes

Usually the crash happens during the first or second switch but sometimes it takes more.
Additional InformationCall stack: http://pastebin.com/vFehiWSc
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0013991

Admiral MS (developer)

Some additions:

Debug Log: http://pastebin.com/QVV7hS0b

And crash doesn't happen when using intel graphics instead of the nvidia graphics card.

~0013993

The_E (administrator)

It would be good if you (or anyone else who can repro this with a debugger attached) could analyze the state of the program when this crash is hit; especially the state of the pointers passed to opengl during opengl_draw_coloured_quad.

~0014019

Swifty (developer)

I can't reproduce this crash. Has this been fixed in another commit I wonder? Have you tried testing this on the latest nightlies?

~0014024

Admiral MS (developer)

It's still present in the latest nightlies. I also tested it on two other computers where the same happens (both have a nivida card).

~0014025

MjnMixael (manager)

Last edited: 2012-11-17 11:32

View 2 revisions

I can also reproduce this crash on the latest trunk builds. (Build 9340)

~0014030

Swifty (developer)

Anyone on an AMD card reproduce this crash?

~0014045

m_m (developer)

I'm on a AMD card and I can't reproduce this crash using retail data.

~0014048

FUBAR-BDHR (developer)

AMD card here as well and can't reproduce.

~0014052

Valathil (developer)

Fixed in Trunk @ 9357
+Notes

-Issue History
Date Modified Username Field Change
2012-10-16 17:38 Admiral MS New Issue
2012-10-16 20:25 Swifty Assigned To => Swifty
2012-10-16 20:25 Swifty Status new => assigned
2012-10-22 15:16 Admiral MS Note Added: 0013991
2012-10-26 04:00 The_E Note Added: 0013993
2012-10-27 21:36 Goober5000 Target Version => 3.6.16
2012-11-10 19:19 Swifty Note Added: 0014019
2012-11-11 05:49 Admiral MS Note Added: 0014024
2012-11-11 08:59 MjnMixael Note Added: 0014025
2012-11-11 19:14 Swifty Note Added: 0014030
2012-11-17 07:27 m_m Note Added: 0014045
2012-11-17 11:32 MjnMixael Note Edited: 0014025 View Revisions
2012-11-18 10:45 FUBAR-BDHR Note Added: 0014048
2012-11-18 13:41 Valathil Note Added: 0014052
2012-11-18 13:41 Valathil Status assigned => resolved
2012-11-18 13:41 Valathil Resolution open => fixed
2012-11-18 13:41 Valathil Assigned To Swifty => Valathil
2012-11-18 13:41 Valathil Status resolved => feedback
2012-11-18 13:41 Valathil Resolution fixed => reopened
2012-11-18 13:41 Valathil Status feedback => resolved
2012-11-18 13:41 Valathil Resolution reopened => fixed
+Issue History