2022-01-26 06:36 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002702FSSCPsoundpublic2012-11-19 00:58
ReporterMjnMixael 
Assigned Toiss_mneur 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
Product Version3.6.13 
Target Version3.6.16Fixed in Version 
Summary0002702: Mainhall sounds not panning correctly
DescriptionMainhalls sounds used to have variable panning ability where -1.0 = left, 0.0 = center, and 1.0 = right. You could fade your sounds across as you might expect.

However, it was recently brought to my attention that this is no longer the case. Now anything < 0 will be fully Left and anything > 0 will be fully Right. 0.0 is the only way to get the sound from both channels.
Steps To ReproduceRun nomods. Mouseover the Ready Room door. The sound in the retail table is set to 0.07 and should basically be center so you should hear it from both speakers. However it only comes out the Right channel.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0013943

Alan Bolte (reporter)

Last edited: 2012-08-23 22:22

View 2 revisions

I encountered the same problem with beam weapons in RC6 and RC7.

~0014033

Goober5000 (administrator)

Assigning to Zacam for advice. Not sure who's best qualified to look at this... maybe you could delegate it to someone who worked on the new sound code.

~0014056

iss_mneur (developer)

I am unable to reproduce this issue with current trunk (revision 9357), retail assets, and stereo headphones. Please confirm that this issue still exists.

~0014057

MjnMixael (manager)

Issue still exists (revision 9357).

~0014060

iss_mneur (developer)

After working with MjnMixael on #SCP, it appears that this issue is an environmental issue and/or hardware issue, related to the use of OpenALSoft, wxLauncher, and sound card drivers.

Specifically the fact that if OpenALSoft is installed in the Freespace2 directory (the recommended location) then wxLauncher doesn't load it, resulting in wxLauncher being unable to "see" the same sound cards as the 5.5g launcher or FSO. This meant that MjnMixael was unable to select a sound card driver that doesn't cause issues.
+Notes

-Issue History
Date Modified Username Field Change
2012-08-21 20:39 MjnMixael New Issue
2012-08-23 08:40 Alan Bolte Note Added: 0013943
2012-08-23 22:22 Alan Bolte Note Edited: 0013943 View Revisions
2012-11-08 23:06 niffiwan Target Version => 3.6.16
2012-11-12 01:12 Goober5000 Note Added: 0014033
2012-11-12 01:12 Goober5000 Assigned To => Zacam
2012-11-12 01:12 Goober5000 Status new => assigned
2012-11-12 01:19 Goober5000 Priority normal => high
2012-11-12 01:19 Goober5000 Severity minor => major
2012-11-18 18:06 iss_mneur Note Added: 0014056
2012-11-18 18:06 iss_mneur Assigned To Zacam => iss_mneur
2012-11-18 18:06 iss_mneur Status assigned => feedback
2012-11-18 18:21 MjnMixael Note Added: 0014057
2012-11-18 18:21 MjnMixael Status feedback => assigned
2012-11-18 21:01 MjnMixael File Added: fs2_open.log
2012-11-19 00:56 iss_mneur Note Added: 0014060
2012-11-19 00:56 iss_mneur Status assigned => resolved
2012-11-19 00:56 iss_mneur Resolution open => no change required
2012-11-19 00:58 Goober5000 Status resolved => closed
+Issue History