2022-01-26 05:55 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002649FSSCPPilot datapublic2012-11-06 21:10
ReporterDragon_HLP 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
PlatformPCOSWindows Vista BusinessOS VersionLatest
Product Version 
Target Version3.6.16Fixed in Version 
Summary0002649: Crash upon proceeding to ship or weapon loadout after manually aborting a mission
DescriptionAfter aborting a mission from "ESC" menu and loading it again, proceeding to either ship or weapons loadout causes a crash. In debug, this warning message appears:
Invalid model number -1 requested. Please post the call stack where an SCP coder can see it.

ntdll.dll! KiFastSystemCallRet
kernel32.dll! WaitForSingleObject + 18 bytes
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
fs2_open_3_6_13d_SSE2_BP.exe! <no symbol>
kernel32.dll! BaseThreadInitThunk + 18 bytes
ntdll.dll! RtlInitializeExceptionChain + 99 bytes
ntdll.dll! RtlInitializeExceptionChain + 54 bytes
 
Attempt to proceed past it causes a crash.
Steps To Reproduce1. Load a mission (I've tested it on Dimensional Eclipse, Talos Station mission).
2. Exit the mission by the "ESC" menu.
3. Reload the mission.
4. Proceed to ship or weapon loadout.
Additional InformationI suspect that this bug is related to the way the game saves selected loadout, since resaving the mission in FRED after any minor change results in this bug disappearing once you abort the mission from the "ESC" menu again. I've found no other way to get around this bug once it's triggered.
TagsNo tags attached.
Attached Files

-Relationships
related to 0002710closed Crash at ship selection after restarting mission. 
+Relationships

-Notes

~0013526

Echelon9 (developer)

Garrrgh, we're seeing a bevy of odd mission-restart-changes-the-world bugs in Diaspora start popping up.

Although it's perhaps incorrect to say they are popping up, as some reports put them as far back as early 2011.

This description sounds very similar.

~0013527

karajorma (administrator)

If the bug can be reproduced though, this might be the easiest place to track it down. It's certainly a lot easier than trying to track down all the reasons a turret might not fire.

Now that I think about it, I wonder if this is the reason I was getting bloody strange behaviour with the key-pressed SEXP this weekend.

~0013986

Goober5000 (administrator)

Any progress on this?

~0014011

karajorma (administrator)

I'm still of the opinion that this bug was killed shortly before Diaspora was released. We certainly haven't seen the issue in Diaspora any more.

~0014014

Goober5000 (administrator)

That's good news. Dragon also tells me that he doesn't recall seeing it recently. I've asked him to check for sure with a nightly build and post here with his findings.

~0014015

Dragon_HLP (reporter)

Tested with both BP builds and latest nightly. It seems that the bug's been squished. On Dimensional Eclipse mission 03-19, on both builds exiting the mission from the escape menu and going back didn't cause the crash. I've also checked the BP build on my own test mission which was prone to that bug (the nightly is incompatible with the modpack) and wasn't able to replicate it. So, it seems that it's been taken care of.

~0014016

Goober5000 (administrator)

Awesome. :) I'll count that as a fix.
+Notes

-Issue History
Date Modified Username Field Change
2012-05-07 18:19 Dragon_HLP New Issue
2012-05-07 18:19 Dragon_HLP File Added: fs2_open.log
2012-05-08 12:09 Echelon9 Note Added: 0013526
2012-05-09 06:58 karajorma Note Added: 0013527
2012-09-09 04:41 niffiwan Relationship added related to 0002710
2012-10-19 01:43 Goober5000 Note Added: 0013986
2012-11-03 01:46 karajorma Note Added: 0014011
2012-11-05 02:41 Goober5000 Target Version => 3.6.16
2012-11-05 02:43 Goober5000 Note Added: 0014014
2012-11-06 15:53 Dragon_HLP Note Added: 0014015
2012-11-06 21:09 Goober5000 Note Added: 0014016
2012-11-06 21:09 Goober5000 Status new => closed
2012-11-06 21:09 Goober5000 Resolution open => no change required
2012-11-06 21:10 Goober5000 Status closed => resolved
2012-11-06 21:10 Goober5000 Resolution no change required => fixed
+Issue History