2022-01-26 06:13 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002600FSSCPuser interfacepublic2012-11-19 00:57
ReporterMjnMixael 
Assigned ToCommanderDJ 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSWindows 7 64bitOS Version
Product VersionAntipodes 8 
Target VersionFixed in Version 
Summary0002600: Misc Anims Sounds Are Duplicated
Descriptionhttp://www.youtube.com/watch?v=UD6vZFjQdFc

This video showcases an annoying issue. In this case I just finished the campaign 'Z-Galatea A'. I had switched to 'Z-Bastion A' to load that mainhall for testing. Then I wanted to switch back to 'Z-Galatea A' however the game wouldn't let me. Probably because the campaign was completed. So I then click to restart the campaign and then Accept. FSO still denied my clicks on Accept. Finally I just pressed 'Escape' which returned me to the mainhall, obviously with 'Z-Galatea A' loaded anyway. Why does FSO deny the Accept button in this case? It really shouldn't.

If the campaign is completed when you try to load it, it should tell you to restart the campaign OR just load it and let the Ready Room tell you to restart the campaign.
Steps To ReproduceSee description.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0013256

MjnMixael (manager)

Last edited: 2012-02-08 10:39

View 2 revisions

WOOPS. I was tired when I put this bug in. The description was for an Antipodes bug that I meant to report as well.

The REAL description: Misc anim sounds are duplicated after they are played the first time. In the video, pay attention to the welding sound and how it gets louder. The sound is definitely doubled if you listen closely. (Playing two or more instances of the same sounds.)

~0013263

Goober5000 (administrator)

This seems like designed behavior. The misc sounds are specified to start playing at a particular frame of the misc animation. If the first sound is longer than the time between trigger frames, then it will overlap with the second triggered sound.

Example timeline, using ASCII art:

|-----1-----2-----3-----4-----|
______/-----------\____________
____________/-----------\______

~0013270

MjnMixael (manager)

no, you need to watch the video. The sound is played twice within a frame of it self or something.

~0013271

Goober5000 (administrator)

I did watch the video, multiple times. I can't hear any instance of two sounds being played almost simultaneously. What I *can* hear is what seems to be two instances of the same sound that partly (but significantly less than completely) overlap.

~0013272

MjnMixael (manager)

Last edited: 2012-02-10 09:23

View 2 revisions

Ok, well you probably just don't know what to listen for.

But if you want more to check, then this is not duplicated pre-mainhall refactor code. Even more so that the sound used there and the frames the sound is called to play on are the same as the original FSPort mainhall....

Also, all the welding sounds are finished playing before that anim loops again. So it can't be that sort of sound overlap issue.

~0013513

CommanderDJ (developer)

MjnMixael, could you please check if the issue persists in the latest AP build? I don't have any particular reason for believing it's been fixed, but I thought I'd make sure before chasing a bug that's not there. And also I can't actually hear the bug anymore, though I remember I could when you first reported it.

~0013548

Goober5000 (administrator)

Do we have an approximate time for when this bug appeared? Or will someone have to perform divide-and-conquer using the recent builds?

~0013606

CommanderDJ (developer)

WELP.

Guess what? The bug has been around since before my code. Revert trunk to before my code went in (yeah, trunk, not just AP) and the bug is still there. That is, two sounds are still being played. In the test pack you sent me, Mjn, there's still a slight "stutter" once the welding starts on second and subsequent times. The difference between previous builds and new ones is the volume increase. Old builds (as in, AP 8105 and older (possibly newer, haven't had time to test them yet)) would play the sound twice but the volume would stay the same. New ones stack the volume so the bug is much more noticeable.

Also I'm deleting my last note. Given this new information, I don't think it's even slightly relevant. So yeah.

~0013607

MjnMixael (manager)

Interesting. Well at least it's not your code that is the culprit!

~0013939

MjnMixael (manager)

Update: This only happens on the first sound listed. My work around is to make the first sound an empty sound on frame 0.

~0014059

CommanderDJ (developer)

This turned out not to be an issue with FSO. Closing.
+Notes

-Issue History
Date Modified Username Field Change
2012-02-08 03:18 MjnMixael New Issue
2012-02-08 03:37 CommanderDJ Assigned To => CommanderDJ
2012-02-08 03:37 CommanderDJ Status new => assigned
2012-02-08 10:13 MjnMixael Note Added: 0013256
2012-02-08 10:39 MjnMixael Note Edited: 0013256 View Revisions
2012-02-09 01:35 Goober5000 Note Added: 0013263
2012-02-09 07:56 MjnMixael Note Added: 0013270
2012-02-10 03:55 Goober5000 Note Added: 0013271
2012-02-10 09:04 MjnMixael Note Added: 0013272
2012-02-10 09:23 MjnMixael Note Edited: 0013272 View Revisions
2012-05-03 04:41 CommanderDJ Note Added: 0013513
2012-05-11 22:46 Goober5000 Note Added: 0013548
2012-05-22 09:34 CommanderDJ Note Added: 0013606
2012-05-22 09:45 MjnMixael Note Added: 0013607
2012-08-22 12:42 MjnMixael Note Added: 0013939
2012-11-19 00:55 CommanderDJ Note Added: 0014059
2012-11-19 00:55 CommanderDJ Status assigned => closed
2012-11-19 00:55 CommanderDJ Resolution open => fixed
2012-11-19 00:57 Goober5000 Resolution fixed => no change required
+Issue History