2018-05-21 02:04 EDT


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0002548FSSCPAIpublic2012-07-01 21:26
ReporterAlan Bolte 
Assigned ToGoober5000 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version3.6.14 RC1 
Target Version3.6.14Fixed in Version 
Summary0002548: Cargo containers try to dodge shockwave missiles
DescriptionGrab some piranhas. Shoot them so they just miss a cargo container. The container will rotate prior to the missile exploding, and if you swap the POF for something that has thrusters, the thrusters will elongate as if it's trying to move.

This doesn't happen with non-shockwave missiles or any other weapon I can see. As far as I can tell, the AI for ships with the 'cargo' flag is trying to evade that type of missile, but containers can't because they have 0 top speed and a rotation time of 20.
Additional InformationTried running without any launcher flags and IIRC without media vps - no change.

Confirmed in 3.6.14RC1 and 3.6.12 but haven't tried retail yet.
TagsNo tags attached.
Attached Files
  • patch file icon mantis2548.patch (639 bytes) 2011-12-13 07:15 -
    Index: code/ai/aicode.cpp
    ===================================================================
    --- code/ai/aicode.cpp	(revision 8049)
    +++ code/ai/aicode.cpp	(working copy)
    @@ -13199,8 +13199,8 @@
     {
     	vec3d	safe_pos;
     
    -	// BIG|HUGE do not respond to shockwaves
    -	if (Ship_info[Ships[objp->instance].ship_info_index].flags & (SIF_BIG_SHIP|SIF_HUGE_SHIP)) {
    +	// BIG|HUGE do not respond to shockwaves -- added NOT_FLYABLE to fix Mantis #2548
    +	if (Ship_info[Ships[objp->instance].ship_info_index].flags & (SIF_NOT_FLYABLE|SIF_BIG_SHIP|SIF_HUGE_SHIP)) {
     		// don't come here again
     		aip->ai_flags &= ~AIF_AVOID_SHOCKWAVE;
     		return 0;
    
    patch file icon mantis2548.patch (639 bytes) 2011-12-13 07:15 +

-Relationships
+Relationships

-Notes

~0012995

Alan Bolte (reporter)

Looks like the AI doesn't care about the 'cargo' flag at all - I removed it, and the target still won't try to dodge when I shoot at it with guns or normal missiles, only shockwave missiles.

~0012996

Alan Bolte (reporter)

I know nothing about the AI code so the attached patch may be a horrible hack, but it seems to work.

~0013019

Goober5000 (administrator)

Closing as duplicate. See 0000945.

~0013024

Goober5000 (administrator)

Reopening because this is for undocked cargo.

~0013710

Goober5000 (administrator)

Fix committed to trunk@8902.

~0013771

Zacam (administrator)

Fix committed to fs2_open_3_6_14@8960.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2011-12-09 01:24 Alan Bolte New Issue
2011-12-09 01:24 Alan Bolte Status new => assigned
2011-12-09 01:24 Alan Bolte Assigned To => Sushi_CW
2011-12-13 05:45 Alan Bolte Note Added: 0012995
2011-12-13 07:15 Alan Bolte File Added: mantis2548.patch
2011-12-13 07:15 Alan Bolte Note Added: 0012996
2012-01-03 03:01 Goober5000 Relationship added related to 0002557
2012-01-03 03:08 Goober5000 Assigned To Sushi_CW => Goober5000
2012-01-03 03:08 Goober5000 Relationship added child of 0000945
2012-01-03 03:14 Goober5000 Note Added: 0013019
2012-01-03 03:14 Goober5000 Status assigned => closed
2012-01-03 03:14 Goober5000 Resolution open => duplicate
2012-01-03 03:58 Goober5000 Note Added: 0013024
2012-01-03 03:58 Goober5000 Status closed => assigned
2012-01-03 03:58 Goober5000 Resolution duplicate => open
2012-01-03 03:58 Goober5000 Relationship deleted related to 0002557
2012-01-03 03:58 Goober5000 Relationship deleted child of 0000945
2012-06-23 07:51 Goober5000 Changeset attached => fs2open trunk r8902
2012-06-23 07:51 Goober5000 Note Added: 0013710
2012-06-23 07:51 Goober5000 Status assigned => resolved
2012-06-23 07:51 Goober5000 Resolution open => fixed
2012-06-23 07:51 Goober5000 Target Version => 3.6.14
2012-07-01 21:26 Zacam Changeset attached => fs2open fs2_open_3_6_14 r8960
2012-07-01 21:26 Zacam Note Added: 0013771
+Issue History