2018-02-24 10:02 EST


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0002410FSSCPHUDpublic2012-07-01 20:55
ReporterAxem 
Assigned ToThe_E 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product VersionAntipodes 7 
Target Version3.6.14Fixed in Version3.6.13 
Summary0002410: No head ani appears when hud disabled except messages and in cutscene camera
DescriptionSo if you use cutscene sexps and do a disable-hud-except-messages, no head anis will show up. It's like this in 3.6.12 as well.

Bug number deux in linked mission: http://lazymodders.fsmods.net/files/hudbugs.fs2
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0012637

Axem (reporter)

Forgot to mention, training messages also do not appear in this condition. But they do appear in this condition in 3.6.12.

~0012661

The_E (administrator)

Fixed in revision 7125

~0012733

Axem (reporter)

As of Rev 7266 this is still broken. :(

~0012802

Backslash (developer)

Did some testing myself and I confirm it is broken. Tried a few things and I have narrowed it down: The problem is not that disable-hud-except-messages is set. If that's all you do, the head anis (and training messages) do show up. The problem Axem is running into is when he changes the camera:
   ( set-camera-host "Alpha 1" )
   ( set-camera-position 0 10 -30 )
   ( set-camera-target "Alpha 1" )
the head ani and the training messages don't show up. But so far I can't figure out how to fix this.

"Bug 3" (in the mission) is easily 'fixed': hudmessage.cpp line 1243, the 'culprit' is
if(Playing_messages[i].play_anim && Playing_messages[i].id != msg_id)
Removing the second half of the && makes it work as Axem wishes.

~0013541

The_E (administrator)

Fix committed to trunk@8772.

~0013542

The_E (administrator)

Reopen because only partial fix in

~0013544

The_E (administrator)

Regarding the bug with the missing Comm ani: That's actually caused by the camera code calling hud_set_render(0) as part of the camera setup process, thus disabling the Comm ani.

~0013546

The_E (administrator)

Added mod.tbl setting "$Cutscene camera disables HUD:" under HUD settings to allow control over the behaviour that caused one of the bugs.

~0013620

niffiwan (developer)

I just run a test & the mod.tbl setting seems to work as advertised for the missing head ani. I guess that just leaves the missing training messages? And that's a regression from 3.6.12?

~0013758

Zacam (administrator)

Fix committed to fs2_open_3_6_14@8930.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2011-03-09 20:01 Axem New Issue
2011-03-09 20:03 Axem Note Added: 0012637
2011-03-31 13:13 chief1983 Target Version => 3.6.14
2011-04-15 08:15 The_E Note Added: 0012661
2011-04-15 08:15 The_E Status new => resolved
2011-04-15 08:15 The_E Fixed in Version => 3.6.13
2011-04-15 08:15 The_E Resolution open => fixed
2011-04-15 08:15 The_E Assigned To => The_E
2011-06-27 20:35 Axem Note Added: 0012733
2011-06-27 20:35 Axem Status resolved => feedback
2011-06-27 20:35 Axem Resolution fixed => reopened
2011-09-05 21:33 Backslash Note Added: 0012802
2012-05-10 17:36 The_E Changeset attached => fs2open trunk r8772
2012-05-10 17:36 The_E Note Added: 0013541
2012-05-10 17:36 The_E Status feedback => resolved
2012-05-10 17:37 The_E Note Added: 0013542
2012-05-10 17:37 The_E Status resolved => feedback
2012-05-10 17:47 The_E Note Added: 0013544
2012-05-11 04:02 The_E Note Added: 0013546
2012-05-29 06:45 niffiwan Note Added: 0013620
2012-05-29 06:45 niffiwan File Added: game_settings.tbl
2012-06-10 23:45 niffiwan Changeset attached => fs2open trunk r8870
2012-06-10 23:48 niffiwan Status feedback => resolved
2012-06-10 23:48 niffiwan Resolution reopened => fixed
2012-07-01 20:55 Zacam Changeset attached => fs2open fs2_open_3_6_14 r8930
2012-07-01 20:55 Zacam Note Added: 0013758
+Issue History