2019-11-20 10:01 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000024FSSCPgraphicspublic2005-07-22 01:01
ReporterCP5670 
Assigned Totaylor 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000024: Subsystem/turret positions not correctly displayed in target monitor
DescriptionThe crosshairs marking the position of the selected subsystem or turret in the HUD target monitor (the box in the lower left corner that displays the currently targeted ship) are not being shown correctly; they are in completely different positions here than they are in the main view. It seems to occur for all ships. I can't recall seeing it in the last version and it could be a new thing. This is in the 12_05_2003 version with -htl, -jpgtga, -d3dmipmap, -fps and -fov 0.65 (I tried removing the fov flag but that didn't help).
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000171

Sticks (developer)

This was due to the ship being rendered in the incorrect location, and thus has been fixed.

~0000950

CP5670 (reporter)

Last edited: 2004-05-22 02:42

This bug is back in the 05/03 version. I'm not sure how long it has been around as I had not played the game for a while, but I noticed it again today on every ship I targeted.

edited on: 05-22-04 02:42

~0001114

Svizel (reporter)

This bug is still here...
I had it on every single build i tried and every flag combination i used so far. I'm using ATI Radeon 9700 with Catalyst 4.3.
Btw i noticed those wrong possitions are always more near the center of model than they should be.

~0001899

administrator (administrator)

Very stale, this needs reassigned.

~0001931

Goober5000 (administrator)

Phreak, weren't you working on this at some point?

~0001950

phreak (developer)

perhaps a year ago. i haven't looked at the graphics code in ages. I'll take a look and pass it off to someone if i can't figure it out.

~0002622

Goober5000 (administrator)

Okay, this should really be fixed for 3.6.7. Phreak, see what you can do, and play hot potato if you can't figure it out.

I'm pinging Bobboau to see if he has anything to say about this.

~0002623

Goober5000 (administrator)

Reminder sent to Bobboau

Take a look at this bug and see if you can shed some light on it.

~0002718

Goober5000 (administrator)

:bump:

Any ideas, Phreak? Bobboau still hasn't responded.

~0002808

taylor (administrator)

I think this should be fixed now. I reworked some of the related code for non-standard resolutions and removed/fixed some of the old cruft that had been built up.

There currently isn't a build which has all of the changes, they weren't complete until after Goober's current build. Maybe Goober will update his build to current CVS but if not, e-mail me, and I'll get you a test build.

~0002813

Goober5000 (administrator)

Eww... cruft is one of the grosser words in the English language.

Anyway, I'll be happy to update my build. :)

~0002836

WMCoolmon (developer)

Just tested current CVS with "Monster in the Mist", looks like this is fixed for nonstandard res.

Didn't try with a diff fov though.

~0002837

taylor (administrator)

It's deffinitely not fixed for FOV stuff. It should be good otherwise but I just don't know how to account for 3D FOV with 2D line drawings.

So should this be considered fixed or do we want to roll the FOV problem into this bug as well?

~0002839

Goober5000 (administrator)

If this bug is fixed for everything but nonstandard FOVs, then we should put it in the nonstandard FOV category. ;)

~0002845

taylor (administrator)

Fixered.

The FOV problems apply to standard and non-standard resolutions though. The non-standard resolutions only show it worse.
+Notes

-Issue History
Date Modified Username Field Change
2004-01-07 23:32 CP5670 New Issue
2004-02-10 00:27 Sticks Status new => resolved
2004-02-10 00:27 Sticks Resolution open => fixed
2004-02-10 00:27 Sticks Assigned To => Sticks
2004-02-10 00:27 Sticks Note Added: 0000171
2004-05-22 00:54 CP5670 Status resolved => feedback
2004-05-22 00:54 CP5670 Resolution fixed => reopened
2004-05-22 00:54 CP5670 Note Added: 0000950
2004-05-22 02:42 CP5670 Note Edited: 0000950
2004-07-29 15:42 Svizel Note Added: 0001114
2004-07-30 04:32 kasperl Status feedback => assigned
2005-03-14 09:02 administrator Note Added: 0001899
2005-03-14 09:03 administrator Assigned To Sticks => Goober5000
2005-03-14 19:55 Goober5000 Note Added: 0001931
2005-03-14 19:55 Goober5000 Assigned To Goober5000 => phreak
2005-03-14 20:39 phreak Note Added: 0001950
2005-06-08 22:07 Goober5000 Note Added: 0002622
2005-06-08 22:07 Goober5000 Note Added: 0002623
2005-06-29 21:40 Goober5000 Note Added: 0002718
2005-07-19 11:47 taylor Note Added: 0002808
2005-07-19 11:48 taylor Assigned To phreak => taylor
2005-07-19 12:50 Goober5000 Note Added: 0002813
2005-07-21 21:22 WMCoolmon Note Added: 0002836
2005-07-21 22:44 taylor Note Added: 0002837
2005-07-21 23:36 Goober5000 Note Added: 0002839
2005-07-22 01:01 taylor Status assigned => resolved
2005-07-22 01:01 taylor Resolution reopened => fixed
2005-07-22 01:01 taylor Note Added: 0002845
+Issue History