2019-10-14 12:50 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002254FSSCPHUDpublic2010-12-27 10:24
ReporterWoolie Wool 
Assigned ToThe_E 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusresolvedResolutionfixed 
Product Version3.6.13 
Target VersionFixed in VersionAntipodes 7 
Summary0002254: $Speed Unit Multiplier to go with $Length Unit Multiplier in hud_gauges.tbl
DescriptionCurrently $Length Unit Multiplier multiplies both speeds and distances together (a value of 6.4 converts Saga speeds in m/s into Wing Commander kps, for instance). A better behavior would be for $Length Unit Multiplier to affect distances only, and a second unit multiplier, $Speed Unit Multiplier, to be added to affect speed only. This would allow, for instance, reporting distances in meters like in regular FreeSpace while reporting speeds in km/h (or even using imperial measurements like reporting speed in knots and distances in feet!).
Additional InformationIt should also be noted that right now, $Length Unit Multiplier does not affect the speed shown in the loadout screen. This seems to be a bug.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0012534

The_E (administrator)

Fixed in antipodes branch. Note that, if you use custom speed units, you need to alter entry 743 in strings.tbl to match the unit you wish to use.

~0012580

Zacam (administrator)

Last edited: 2010-12-27 10:23

Ship Selection screen now lists ships as having '0 MS' under Retail data with the chanegs in missionshipchoice.cpp.






 Setting floats to fl2i when multiplying them to int values is a good idea. Fixed in 6900.

+Notes

-Issue History
Date Modified Username Field Change
2010-07-09 02:33 Woolie Wool New Issue
2010-12-10 13:17 The_E Note Added: 0012534
2010-12-10 13:21 The_E Status new => resolved
2010-12-10 13:21 The_E Fixed in Version => Antipodes 7
2010-12-10 13:21 The_E Resolution open => fixed
2010-12-10 13:21 The_E Assigned To => The_E
2010-12-27 09:51 Zacam Note Added: 0012580
2010-12-27 09:51 Zacam Status resolved => feedback
2010-12-27 09:51 Zacam Resolution fixed => reopened
2010-12-27 10:23 Zacam Note Edited: 0012580
2010-12-27 10:24 Zacam Status feedback => resolved
2010-12-27 10:24 Zacam Resolution reopened => fixed
+Issue History