2019-10-16 12:57 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000211FSSCPuser interfacepublic2007-03-23 04:22
ReporterCP5670 
Assigned Totaylor 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.5 
Summary0000211: FSO no longer remembers last used pilot
DescriptionThe game used to arrange pilots by when they were last used but stopped doing that in one of Bobboau's post-3.6 builds and always puts the pilots in alphabetical order now. It's a small thing but can get annoying when one is used to it being the other way for so long; it's easy to accidentally click on the wrong pilot without realizing it and play a mission with custom tables, frequently messing up the pilot.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001046

WMCoolmon (developer)

This won't fix the bug, but it's a good idea to store your pilots in their respective -mod directories so something like that doesn't happen.

~0001048

taylor (administrator)

I've got this fixed but forgot to update CVS. I think it was WMCoolmon who added a reverse sort but that broke time sorting. I redid the reverse sort to work just like the other two sorting techniques (name, time) so this isn't a problem. I'll get this updated as soon as I get the chance.

Sorting from -mod directories is a different issue. Pilots in a main directory get listed with pilots form the mod directory. I have this fixed in the Linux version since I don't like that but I haven't made this change affect Windows in case people hated it.

~0001070

taylor (administrator)

It be fixered.

You might want to check this though WMCoolmon just in case my fix wasn't your intent with this code.
+Notes

-Issue History
Date Modified Username Field Change
2004-07-07 23:14 CP5670 New Issue
2004-07-08 03:37 WMCoolmon Note Added: 0001046
2004-07-08 21:29 taylor Note Added: 0001048
2004-07-08 21:29 taylor Status new => assigned
2004-07-08 21:29 taylor Assigned To => taylor
2004-07-17 21:18 taylor Status assigned => resolved
2004-07-17 21:18 taylor Resolution open => fixed
2004-07-17 21:18 taylor Note Added: 0001070
2007-03-23 04:22 taylor Status resolved => closed
2007-03-23 04:22 taylor Fixed in Version => 3.6.5
+Issue History