2019-10-23 12:43 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000207FSSCPOpenGLpublic2007-03-23 04:23
ReporterThe Trivial Psychic 
Assigned Totaylor 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformAMD-800, ASUS A7V, 256MB, GF2MXOSWindows98SEOS Version
Product Version 
Target VersionFixed in Version3.6.5 
Summary0000207: OGL Won't display tga, jpg, dds effects
DescriptionI've decided to post a new bug entry, since previous discussion in another bug was a tangent, and did not match the title. Whenever I run FSO in OGL mode, things like tga and dds effects won't display. Weapon effects like those of Lightspeed and Carl will not be displayed, neither are engine plumes. The DDS engine plumes in the beta Inferno R1 patch are not visible either. Since tga and jpg go hand-in-hand in FS2, I'm guessing that they aren't visible either, but I haven't tried anything using them. I also haven't tried this with textures in these formats.
Additional InformationCheck bugnotes the thread refering to OGL crashing after 2nd mission for more details and history.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001013

taylor (administrator)

DDS doesn't work either? I must have missed that one. DDS is done differently than jpgtga so it should work regardless, as long as the drivers support compressed textures. Do DDS planets work or is it just the engine plumes that don't. Have you tried using just the standard MediaVPs to make sure it's deffinitely the code that's the problem? Also what video driver version are you using?

~0001075

taylor (administrator)

Try this build and see if you still have problems:

http://icculus.org/~taylor/fso/testing/20040717-win32.zip

~0001268

taylor (administrator)

I'm guessing this is fixed since other DDS issues are solved and no one has compained since.

Fixered.
+Notes

-Issue History
Date Modified Username Field Change
2004-06-28 01:48 The Trivial Psychic New Issue
2004-06-28 17:12 taylor Note Added: 0001013
2004-06-28 17:12 taylor Status new => assigned
2004-06-28 17:12 taylor Assigned To => taylor
2004-07-18 17:05 taylor Note Added: 0001075
2004-09-26 16:03 taylor Status assigned => resolved
2004-09-26 16:03 taylor Resolution open => fixed
2004-09-26 16:03 taylor Note Added: 0001268
2007-03-23 04:23 taylor Status resolved => closed
2007-03-23 04:23 taylor Fixed in Version => 3.6.5
+Issue History