2019-10-16 14:14 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000205FSSCPOpenGLpublic2007-03-23 04:18
ReporterThe Trivial Psychic 
Assigned Totaylor 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformAMD-800 256MB SD-100 GF2 MX 32MBOSWin98SEOS Version
Product Version 
Target VersionFixed in Version3.6 
Summary0000205: Illegal Operation Crash When Commiting to 2nd Mission in OGL HTL Mode.
DescriptionI've only realy tried this using Inferno, since my other tables are configed to use tga, jpg, & dds, which OGL doesn't support. Anyway, every time I commit to a mission after playing another, or restart a mission, I get an illegal operation message, followed by a CTD. I also run my desktop in a higher res than 1024/768, and following the crash, windows will be in 1024/768 mode, but focused on the top-left corner of the screen, as though zooming to said resolution of the larger res desktop.
Steps To ReproducePlay a mission in OGL HTL... then try to commmit to a second, or restart the first mission.
Additional Information-spec -glow -jpgtga -fps -dnoshowvid -mod InfernoR1

I know the jpgtga flag is useless in OGL, but I keep it in there none-the-less.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000991

taylor (administrator)

I don't suppose you have an nVIDIA card do you? If so, or just anyway, try using the -novbo option. novbo turns off Vertex Buffer Object support and prevents a crash from a bug in some of nVIDIA's drivers. VBO helps speed up rendering of models with *lots* of polygons but shouldn't be that much help yet. You don't lose any features by turning it off.

And the jpgtga flag does work in OGL now but only if it's compiled with DevIL support (like 3.6).

~0001002

The Trivial Psychic (reporter)

Last edited: 2004-06-26 16:05

Thanks Taylor, that flag helped alot. It should definitely be in the Wiki (once HLP gets back on its feet). It doesn't stop the crashes completely, but it fixes the main one.

Regarding jpgtga, does that only work for textures & backgrounds, cause things like Lightspeed's weapon effects don't work in OGL, which are tga-based. I'm also guessing that dds won't work, as that is directX-based, correct?

edited on: 06-26-04 16:05

~0001004

taylor (administrator)

jpgtga should work fine on anything and Lightspeed's effects work fine for me. What version are you trying with? It should work fine with 3.6 final and anything released by me after April. I'm not sure about some of the other builds though.

DDS didn't work at one point in OGL but I fixed that just before 3.6 was released and it should work properly now. I've cleaned up the DDS loading code a little but that code isn't in CVS yet and it wouldn't really help anyone but developers anyway.

~0001005

The Trivial Psychic (reporter)

I just tested both 3.6 and WMcoolmon's June 25th build and neither one shows ANY tga effects, in OGL mode. I can't see any of the (tga) weapon effects, or the engine plumes... its only showing stock engine glows. I do believe however, that it was showing the ani impact effects. Now, I also tried making a new pilot, but it made no difference.

-spec -glow -jpgtga -fps -dnoshowvid -novbo -snd_preload

Could this be something related to my GF2MX vid card?

~0001006

kasperl (developer)

What VP's, exactly, are you using? Also, what files are there in your data dir?

~0001012

The Trivial Psychic (reporter)

Right now, I'm mainly using my own custom combination of files extracted from VPs. As far as the weapon effects however, I wanted to use the Port, but still enjoy the advanced weapon effects. As the VP version of the weapons advances uses a fusion of effects from Lightspeed and Carl, I picked and chose which ones of Carl's I wanted, and which of Lightspeed's I wanted, from his separate release zip file. I patched in the required lines of code to the affected weapons, made sure the weapons explosion table file was in order, and made sure the tga and ani files I selected were in the proper directory. I even ran a debug FRED to make sure I wasn't missing anything. I played though the port FS1 main campaign with no problems, though only the PromS, Vasudan Light Laser, 3 shivan lasers and the Hornet were realy used before FS2. All of these worked in D3D, but the PromS is invisible when I went to OGL mode. There wouldn't be some undocumented OGL specific flag to activate this would there?

~0001014

taylor (administrator)

Since the main problem is resloved I'm closing this. Graphics problems are in the new bug.
+Notes

-Issue History
Date Modified Username Field Change
2004-06-24 00:14 The Trivial Psychic New Issue
2004-06-24 02:05 taylor Note Added: 0000991
2004-06-24 02:06 taylor Status new => assigned
2004-06-24 02:06 taylor Assigned To => taylor
2004-06-26 16:05 The Trivial Psychic Note Added: 0001002
2004-06-26 16:05 The Trivial Psychic Note Edited: 0001002
2004-06-26 20:27 taylor Note Added: 0001004
2004-06-26 21:22 The Trivial Psychic Note Added: 0001005
2004-06-27 06:47 kasperl Note Added: 0001006
2004-06-27 20:00 The Trivial Psychic Note Added: 0001012
2004-06-28 17:15 taylor Status assigned => resolved
2004-06-28 17:15 taylor Resolution open => fixed
2004-06-28 17:15 taylor Note Added: 0001014
2007-03-23 04:18 taylor Status resolved => closed
2007-03-23 04:18 taylor Fixed in Version => 3.6
+Issue History