2022-08-19 06:03 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002024FSSCPAIpublic2022-06-10 22:05
Reporterchief1983 
Assigned ToGoober5000 
PriorityhighSeverityminorReproducibilityN/A
StatusclosedResolutionsuspended 
Product Version3.6.11 
Target VersionFixed in Version 
Summary0002024: Design tweaks and refactoring in Sushi's AI code
DescriptionIt needs to be cleaned up. Per Goober.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0011281

Sushi_CW (developer)

More specific details/suggestions on what needs to be cleaned up and how would be uber-handy. I have "I wrote it" myopia. :)

~0013996

iss_mneur (developer)

Goober please provide Sushi with the feedback that he requested.

~0014191

The_E (administrator)

Closing this. Mantis is IMHO not the right venue for this kind of discussion; and simple one-liners like "a bit of a mess" are not constructive criticism.

~0014192

Goober5000 (administrator)

Last edited: 2012-11-26 19:04

View 2 revisions

Reopening. There are a bunch of legitimate design concerns that should be addressed here, but I need to sit down and outline them. There should be a thread on HLP where we've discussed some of them, such as putting all the AI arrays under the umbrella of a struct rather than as separate instances.

I'll provide Sushi with the requested feedback, but not until after 3.7 is out, since this is more of a design and future-proof ticket than a bugfix ticket.

I've renamed the ticket since the original name was of course not really descriptive or constructive.

~0016785

m_m (developer)

I have unset the target version because there is no clearly defined bug in the description.

~0017114

FSCyborg (developer)

This should never have been reopened. When you see a specific flaw, write an issue about that flaw. Reopening this so that it can stay open for another 10 years didn't solve anything.

~0017115

z64555 (developer)

Moving to github: https://github.com/scp-fs2open/fs2open.github.com/issues/4382

~0017143

Goober5000 (administrator)

> This should never have been reopened. When you see a specific flaw, write an issue about that flaw. Reopening this so that it can stay open for another 10 years didn't solve anything.

There were several specific critiques in the thread that prompted this ticket. I should have linked that thread at the time I opened it, but I wanted to refine the critiques before doing so. I'll try to find that thread and link it on GitHub.
+Notes

-Issue History
Date Modified Username Field Change
2009-11-09 23:41 chief1983 New Issue
2009-11-10 12:33 Zacam Status new => assigned
2009-11-10 12:33 Zacam Assigned To => Sushi_CW
2009-11-14 10:10 Sushi_CW Note Added: 0011281
2010-08-05 16:07 chief1983 Target Version 3.6.12 RC1 => 3.7.2
2012-10-27 20:57 iss_mneur Note Added: 0013996
2012-10-27 20:57 iss_mneur Assigned To Sushi_CW => Goober5000
2012-10-27 20:57 iss_mneur Status assigned => feedback
2012-10-27 20:57 iss_mneur Target Version 3.7.2 => 3.7
2012-11-26 06:35 The_E Note Added: 0014191
2012-11-26 06:36 The_E Status feedback => closed
2012-11-26 06:36 The_E Resolution open => suspended
2012-11-26 19:03 Goober5000 Note Added: 0014192
2012-11-26 19:03 Goober5000 Status closed => assigned
2012-11-26 19:03 Goober5000 Resolution suspended => open
2012-11-26 19:03 Goober5000 Category tables => AI
2012-11-26 19:03 Goober5000 Target Version 3.7 =>
2012-11-26 19:03 Goober5000 Summary Sushi's AI stuff is a bit of an organizational mess => Design tweaks and refactoring in Sushi's AI code
2012-11-26 19:03 Goober5000 Target Version => 3.7.2
2012-11-26 19:04 Goober5000 Note Edited: 0014192 View Revisions
2015-04-16 00:22 Goober5000 Target Version 3.7.2 => 3.7.4
2015-09-22 17:29 m_m Note Added: 0016785
2015-09-22 17:29 m_m Target Version 3.7.4 =>
2022-06-10 12:47 FSCyborg Note Added: 0017114
2022-06-10 12:48 z64555 Note Added: 0017115
2022-06-10 12:49 z64555 Status assigned => closed
2022-06-10 12:49 z64555 Resolution open => suspended
2022-06-10 22:05 Goober5000 Note Added: 0017143
+Issue History