2019-12-06 05:45 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000198FSSCPFRED graphicspublic2007-03-23 04:21
Reporterdarkchrono 
Assigned Totaylor 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.5 
Summary0000198: Fred crashes when grid clicked on
DescriptionI've downloaded the fs2_open and fred2 code from the CVS and compiled them. But when I try and run Fred it will work fine until I click somewhere on the grid and then it will crash. I get an Assert() error, here it is:

Assert: G3_count == 0
File: D:\Downloads\FS2\3_6_source\fs2_open\code\Render\3dSetup.cpp
Line: 234

Call stack:
------------------------------------------------------------------
    IMP_D.EXE 0061042f()
    IMP_D.EXE 0061068f()
    IMP_D.EXE 004320f3()
    IMP_D.EXE 0042ab10()
    IMP_D.EXE 0087ece4()
    IMP_D.EXE 0087daea()
    IMP_D.EXE 008858ae()
    IMP_D.EXE 0078bf98()
    IMP_D.EXE 00722866()
    KERNEL32.DLL bff8b560()
    KERNEL32.DLL bff8b412()
    KERNEL32.DLL bff89dd5()
------------------------------------------------------------------
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000984

darkchrono (reporter)

Actually this doens't occur when I click on the grid. It happens when I pass the cursor over a ship on the grid. And it doesn't seem to matter what display options I have checked. I can have everything unchecked and it will still crash if the the mouse over its position.

~0000988

RandomTiger (developer)

Are you sure you compiled it incorrectly?

~0001000

darkchrono (reporter)

It may have been linking to a bad code.lib or something. I went in and commented out all the G3_count asserts and rebuilt everything and everything seems to be fine now.

~0001001

RandomTiger (developer)

Last edited: 2004-06-26 02:01

DO NOT COMMIT THAT CODE!

Commenting out debug errors is no way to fix anything!
Im working on fred and the moment and I get no G3_count asserts.

edited on: 06-26-04 02:01

~0001003

darkchrono (reporter)

Last edited: 2004-06-26 18:31

Don't have to worry about anything getting commited since I'm not on the team. I'm thinking I must have had a bum code.lib because I was having some other weirdness with Fred. Commenting out those Asserts() would have no effect with the retail build. But when I did take them out I rebuilt everything at the same time. Putting them back in has not caused any other problems. So it had to have been a bum code.lib.

As far as I'm concerned the issue is fixed and you can close this.

edited on: 06-26-04 18:31

~0001016

taylor (administrator)

Looks to be fixed, closing.
+Notes

-Issue History
Date Modified Username Field Change
2004-06-19 09:53 darkchrono New Issue
2004-06-20 02:26 darkchrono Note Added: 0000984
2004-06-23 14:54 RandomTiger Note Added: 0000988
2004-06-25 13:13 darkchrono Note Added: 0001000
2004-06-26 01:59 RandomTiger Note Added: 0001001
2004-06-26 02:01 RandomTiger Note Edited: 0001001
2004-06-26 18:30 darkchrono Note Added: 0001003
2004-06-26 18:31 darkchrono Note Edited: 0001003
2004-06-29 10:39 taylor Status new => resolved
2004-06-29 10:39 taylor Resolution open => fixed
2004-06-29 10:39 taylor Assigned To => taylor
2004-06-29 10:39 taylor Note Added: 0001016
2007-03-23 04:21 taylor Status resolved => closed
2007-03-23 04:21 taylor Fixed in Version => 3.6.5
+Issue History