2019-10-18 10:53 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000193FSSCPFRED graphicspublic2007-03-23 04:23
Reporterkarajorma 
Assigned Totaylor 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.5 
Summary0000193: FRED2_OpenGL Crash on Exit
DescriptionFRED2 Open crashes on exit every single time. It first reports.

 Error: Unable to swap buffers
Error code: 0
File:.\graphics\gropengl.cpp
Line: 991

On clicking okay it repeats the messages (or one that looks similar) and the quits
Additional InformationWinXP
Asus A7N8X Deluxe
1GB DDR RAM
Radeon 9800
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000972

phreak (developer)

theres a trick to compiling the FRED code that prevents this. it was just compiled incorrectly

~0000977

kasperl (developer)

Shouldn't this be closed then?

~0000980

Skippy (reporter)

Last edited: 2004-06-18 17:13

Using version 06172004 of FRED :
Error: Unable to swap buffers
Error code: 0
File:.\graphics\gropengl.cpp
Line: 1002

Call stack:
------------------------------------------------------------------
fred2_open_C06172004.exe 004c52bc()
fred2_open_C06172004.exe 00517abe()
fred2_open_C06172004.exe 00420938()
fred2_open_C06172004.exe 00580ab4()
fred2_open_C06172004.exe 005829de()
fred2_open_C06172004.exe 00582a6e()
USER32.dll 77d13a50()
USER32.dll 77d13b1f()
USER32.dll 77d15b2c()
USER32.dll 77d15b4b()
OPENGL32.dll 5f092ccf()
USER32.dll 77d13a50()
USER32.dll 77d13b1f()
USER32.dll 77d144f5()
USER32.dll 77d14525()

Then

Error: Unable to swap buffers
Error code: 0
File:.\graphics\gropengl.cpp
Line: 1002

Call stack:
------------------------------------------------------------------
fred2_open_C06172004.exe 004c52bc()
fred2_open_C06172004.exe 00517abe()
fred2_open_C06172004.exe 004546e0()
fred2_open_C06172004.exe 00454744()
fred2_open_C06172004.exe 004c52bc()
fred2_open_C06172004.exe 00517abe()
fred2_open_C06172004.exe 00420938()
fred2_open_C06172004.exe 00580ab4()
fred2_open_C06172004.exe 005829de()
fred2_open_C06172004.exe 00582a6e()
USER32.dll 77d13a50()
USER32.dll 77d13b1f()
USER32.dll 77d15b2c()
USER32.dll 77d15b4b()
OPENGL32.dll 5f092ccf()

not same line :p

modifié le : 06-18-04 17:13

~0000981

WMCoolmon (developer)

Mind sharing the trick...?

~0001030

kasperl (developer)

Phreak: please post that compile trick so this bug can be closed?

~0001149

phreak (developer)

its not showing up for me anymore. i think taylor and/or randomtiger addressed this

~0001284

taylor (administrator)

I believe this was something that got fixed by some other changes I made to OGL. So since no one else seems to want to close this I'll do it.

Fixered!!
+Notes

-Issue History
Date Modified Username Field Change
2004-06-06 10:13 karajorma New Issue
2004-06-08 19:54 phreak Note Added: 0000972
2004-06-13 07:08 kasperl Note Added: 0000977
2004-06-18 17:12 Skippy Note Added: 0000980
2004-06-18 17:13 Skippy Note Edited: 0000980
2004-06-18 17:46 WMCoolmon Note Added: 0000981
2004-07-02 09:44 kasperl Note Added: 0001030
2004-08-18 21:01 phreak Note Added: 0001149
2004-10-06 02:30 taylor Status new => resolved
2004-10-06 02:30 taylor Resolution open => fixed
2004-10-06 02:30 taylor Assigned To => taylor
2004-10-06 02:30 taylor Note Added: 0001284
2007-03-23 04:23 taylor Status resolved => closed
2007-03-23 04:23 taylor Fixed in Version => 3.6.5
+Issue History