2018-06-18 10:45 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001917FSSCPmodelspublic2012-05-21 23:02
Reporterblowfish 
Assigned ToGoober5000 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
Product Version3.6.9 
Target VersionFixed in Version3.6.11 
Summary0001917: MAX_SHIP_BAY_PATHS limit very low; Should be bumped
DescriptionCurrently, the maximum number of bay paths that a ship can have is 10. I have run into at least two ships that suffer from this restriction, and I have heard from other people who believe that the limit should be bumped as well.

Note that 32 is probably the limit that it can be bumped to, because of path masks.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0011539

FUBAR-BDHR (developer)

I did a bunch of testing on this today. The current limit this can be bumped to is 99. Anything above that breaks the drop down to select bay paths in FRED.

~0011581

Goober5000 (administrator)

I bumped it to 32. It can't be bumped higher than that because of the way the arrival/departure flags currently work.

I am marking this as resolved. Reopen it if you find you need more than 32 paths.

~0011584

Goober5000 (administrator)

Reopened due to FUBAR's request.

A bump past 32 bay paths will require the re-engineering of the arrival flags to use a bitfield vector or a vector of booleans, so it'll be somewhat more work than simply changing a limit.

~0013601

Goober5000 (administrator)

Eh, re-resolving since FUBAR hasn't bugged me about it in two years.
+Notes

-Issue History
Date Modified Username Field Change
2009-04-16 02:12 blowfish New Issue
2009-04-22 13:16 Goober5000 Status new => assigned
2009-04-22 13:16 Goober5000 Assigned To => Goober5000
2010-01-19 03:30 FUBAR-BDHR Note Added: 0011539
2010-01-24 16:50 Goober5000 Note Added: 0011581
2010-01-24 16:50 Goober5000 Status assigned => resolved
2010-01-24 16:50 Goober5000 Resolution open => fixed
2010-01-24 16:50 Goober5000 Fixed in Version => 3.6.11
2010-01-24 21:45 Goober5000 Note Added: 0011584
2010-01-24 21:45 Goober5000 Status resolved => assigned
2010-01-24 21:45 Goober5000 Resolution fixed => reopened
2012-05-21 23:02 Goober5000 Note Added: 0013601
2012-05-21 23:02 Goober5000 Status assigned => resolved
2012-05-21 23:02 Goober5000 Resolution reopened => fixed
+Issue History