2019-10-14 13:54 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001729FSSCPgameplaypublic2009-03-16 18:22
ReporterFUBAR-BDHR 
Assigned Tokarajorma 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version3.6.9 
Target VersionFixed in Version3.6.10 
Summary0001729: Glide mode locks up computer at warpout.
DescriptionNot entirely sure of the exact nature of this one since I haven't had time to fully investigate it. Here's the basic scenario there is a jumpout when in the vicinity of a jumpgate. I tried for a few extra kills an enable glide just before hitting the jumpout point so I could fire my remaining missiles. Well when I backed up into the point the subspace drive engaged message showed up but the game kept playing and I couldn't do anything. Had to alt-ctrl-del and end task. Assuming this was with the force jump sexp.
Additional InformationTBP version of 3.6.9. Posted about it in the FRED forum and a few other people say they have had the same problem.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0009506

FUBAR-BDHR (developer)

Thought this one was already closed. Turned out it has nothing to do with glide. It's the same problem as 0001548. Don't know if it's ever been fixed though.

~0009569

phreak (developer)

I am getting a warning that says "Cannot warp out when gliding". I presume it is fixed in the trunk builds. If you can verify that, then I can close this bug.

~0010649

FUBAR-BDHR (developer)

This may be fixed for single but seems to still exist for multiplayer. We had an occurrence of this today. I(host) jumped while Vidmaster(client) was in glide mode. This resulted in him getting stuck in the game even though on the host end it showed him in debrief.

Build was r5063.

Really no good info in the multi.log file. It just shows him being dumped after I ended the game.

~0010650

karajorma (administrator)

Okay, this is pretty strange. I'm sure I fixed this one ages ago for multiplayer.

Hell I'm pretty sure I fixed it for 3.6.9 builds in time for one of the BtRL patches.

~0010651

FUBAR-BDHR (developer)

Sure your not thinking of the double respawn/spawning at warpout problems?

Of course it is always a possibility it was just one of those random multiplayer lockups that just happened to occur in glide mode at warpout.

~0010652

karajorma (administrator)

Just tested this in Diaspora and it worked perfectly. And I'm pretty certain I did fix this one for BtRL. It was a common complaint with the original release.

~0010653

FUBAR-BDHR (developer)

Strange I just tried it with both host and client in glide mode. Neither made it to debrief. Both froze with the subspace drive engaged message on the screen. Client will start responding again if I alt-ctrl-del and end task on the server. Log shows like the server made it to debrief:

Entering game at time = 90.321
Got event GS_EVENT_PLAYER_WARPOUT_START_FORCED (42) in state GS_STATE_GAME_PLAY (2)
1788 frames executed in 30.013 seconds, 59.574 frames per second.
Frame 2924 too long!!: frametime = 0.357 (0.357)
Frame 2926 too long!!: frametime = 0.417 (0.417)
Got event GS_EVENT_QUIT_GAME (5) in state GS_STATE_GAME_PLAY (2)
Unloading in mission messages
Freeing all existing models...
... Log closed, Fri Feb 06 19:49:11 2009

Any other mods using 3.6.10 have multi and ships with glide?

~0010657

karajorma (administrator)

I suppose I'll have to try it on TBP I guess. *sigh*

~0010658

FUBAR-BDHR (developer)

Not actually I could try enabling glide on a FS2 ship if I knew how.

~0010659

FUBAR-BDHR (developer)

I don't no how to make a FS2 ship glide capable but I did figure out how to put 0rph3u5's HP Aurora into FS2. Same lockup at warpout. Tried in TvT, dogfight, and coop. File was a bit too big to upload so you can grab it here. http://fubar4.fubar.org/mantis/hp_auroras.rar

It's about 2.5 meg. Just extract in your fs2 folder and set as a mod. Contains a test mission with just 1 aurora. Start the mission, turn on glide and try to warp. Might need to hold glide on it doesn't seem to stay on like in TBP.

~0010745

karajorma (administrator)

That should hopefully solve it.
+Notes

-Issue History
Date Modified Username Field Change
2008-07-18 14:08 FUBAR-BDHR New Issue
2008-07-25 13:27 phreak Status new => assigned
2008-07-25 13:27 phreak Assigned To => phreak
2008-07-25 14:29 FUBAR-BDHR Note Added: 0009506
2008-08-17 23:33 phreak Note Added: 0009569
2008-08-31 22:29 phreak Status assigned => closed
2008-08-31 22:29 phreak Resolution open => unable to reproduce
2009-02-05 17:19 FUBAR-BDHR Status closed => feedback
2009-02-05 17:19 FUBAR-BDHR Resolution unable to reproduce => reopened
2009-02-05 17:19 FUBAR-BDHR Note Added: 0010649
2009-02-05 17:37 karajorma Note Added: 0010650
2009-02-05 18:06 FUBAR-BDHR Note Added: 0010651
2009-02-06 03:51 phreak Assigned To phreak =>
2009-02-06 04:00 karajorma Status feedback => assigned
2009-02-06 04:00 karajorma Assigned To => karajorma
2009-02-06 15:28 karajorma Note Added: 0010652
2009-02-06 19:54 FUBAR-BDHR Note Added: 0010653
2009-02-07 14:20 karajorma Note Added: 0010657
2009-02-07 14:54 FUBAR-BDHR Note Added: 0010658
2009-02-07 17:08 FUBAR-BDHR Note Added: 0010659
2009-03-16 18:22 karajorma Status assigned => resolved
2009-03-16 18:22 karajorma Fixed in Version => 3.6.10
2009-03-16 18:22 karajorma Resolution reopened => fixed
2009-03-16 18:22 karajorma Note Added: 0010745
+Issue History