2019-12-13 08:14 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000017FSSCPgraphicspublic2006-10-26 23:39
Reporterdiamondgeezer 
Assigned Totaylor 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6 
Summary0000017: FRED2 doesn't like TGA backgrounds
DescriptionThe game will happily accept TGA backgrounds, but FRED2's background editor doesn't like them. It refuses to let me pull down the list of available backgrounds.
Additional InformationObvioulsy the simple solution is to convert the backgrounds to PCX, but that defeats the point of the lovely TGA art :)
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000060

RandomTiger (developer)

Currently fred cant display TGA's or JPG's so the best thing to do is to convert it to a PCX with the same name and select that with Fred.
Later when run with fs2_open if the tga of the same name is there then it will load that.

Perhaps someone could address this issue if current graphics work on Fred is fruitful

~0000704

Kazan (developer)

status pls

~0000909

RandomTiger (developer)

So is this fixed now?

~0000911

taylor (administrator)

Last edited: 2004-05-08 05:42

Code wise this is fixed as long as Fred2 and FS2_Open are built with DevIL support. The recent CFILE fix should be the last thing that was keeping this from working as expected. It just needs a new build to be tested to know for sure. I'm building a DevIL version now and will resolve this if it works.

Update: This works but currently Cmdline_jpgtga is disabled if bpp is not 32bit. I did this because it needs that value to figure out what to send to opengl calls. Fred2_Open only asks for 16bit color so JPG and TGA textures are not enabled.

Fred2 could be changed to use 32bit all of the time or just when -jpgtga is used. Suggestions?

edited on: 05-08-04 05:42

~0000915

taylor (administrator)

Fixered. Fred will now init OpenGL with 32bpp when you use -jpgtga and use 16bpp otherwise. This gets jpg, tga working and dds now works in 16bpp and 32bpp.
+Notes

-Issue History
Date Modified Username Field Change
2003-12-30 12:56 diamondgeezer New Issue
2004-01-18 11:25 RandomTiger Note Added: 0000060
2004-03-04 15:46 RandomTiger Status new => acknowledged
2004-04-06 21:13 Kazan Note Added: 0000704
2004-05-08 04:22 RandomTiger Note Added: 0000909
2004-05-08 04:22 RandomTiger Assigned To => taylor
2004-05-08 04:22 RandomTiger Status acknowledged => assigned
2004-05-08 05:16 taylor Note Added: 0000911
2004-05-08 05:42 taylor Note Edited: 0000911
2004-05-09 10:42 taylor Status assigned => resolved
2004-05-09 10:42 taylor Resolution open => fixed
2004-05-09 10:42 taylor Note Added: 0000915
2006-10-26 23:39 Goober5000 Status resolved => closed
2006-10-26 23:39 Goober5000 Fixed in Version => 3.6
+Issue History