2019-10-18 23:23 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001633FSSCPmultiplayerpublic2009-01-05 03:52
ReporterFUBAR-BDHR 
Assigned Tokarajorma 
PrioritynormalSeveritytrivialReproducibilityalways
StatusresolvedResolutionfixed 
Product Version3.6.9 
Target VersionFixed in Version3.6.10 
Summary0001633: Player ship AI do not obey play dead orders
DescriptionI have 2 wings of fighters Beta and Gamma. Both contain 4 player ships and have initial orders of play dead. At the start of the game they don't play dead. Works with regular AI ship wings.
Additional InformationTBP 3.6.9 but I remember this same issue in the FS2 3.6.9 release candidates as well. Mission is a work in progress. Alpha is escorting a transport Beta and Gamma should just sit there until after the transport docks.
TagsNo tags attached.
Attached Files

-Relationships
related to 0001815assignedGoober5000 Player AI ships do not initally attack on standalone 
+Relationships

-Notes

~0008966

FUBAR-BDHR (developer)

Might want to check other sexps too. I vaguely remember the same problem with ignore <target> in the 3.6.9 release candidates but have not tried it since.

~0008967

karajorma (administrator)

Player-use-AI was never built with multiplayer in mind. Not at all surprised it's not working. Even if you could make it work you'd then have the problem that you can't un-AI the ship again.

~0008970

FUBAR-BDHR (developer)

Not using player use AI. I am talking about player ships that aren't being used by players. For example a 12 player mission where only 3 people start. You can't get the other 9 ships to take the play dead order so they don't just go off shooting things.

~0008985

karajorma (administrator)

Ah. In that case I'll take a look.

~0010166

karajorma (administrator)

Is this still an issue? Just tried it and it worked fine for me with my own simple mission in FS2. Alpha 2 played dead just fine.....until I killed it. At that point it started moving around again.

~0010167

FUBAR-BDHR (developer)

Yep still exists. Attaching test mission. Every wing has play dead orders.

~0010179

karajorma (administrator)

Found the cause.

Initial orders eventually pass through ai_process_mission_orders() which contains this section of code

if ( !(Player_use_ai) && (objp->flags & OF_PLAYER_SHIP) && (current_goal->ai_mode != AI_GOAL_FORM_ON_WING) )
{
     return;
}

Problem is that the AI ships are OF_PLAYER_SHIPs and therefore they're not being given any orders.

SEXPs on the other hand are evaluated on mission start not mission load and by then the AI ships which don't have a player in them are no longer flagged as player ships and thus the SEXP works for them.

I've had a chat with him so I'm passing this one over to Goober now that the spade work has been done.

~0010194

karajorma (administrator)

Never mind. Figured out how to fix this one anyway.

~0010464

FUBAR-BDHR (developer)

Just tried using this in the latest builds. Tried giving the player wings orders and also tried giving the individual ships orders and neither seems to work. The ships just start the mission with do nothing in the orders and sit there.

~0010506

karajorma (administrator)

And stay resolved this time!
+Notes

-Issue History
Date Modified Username Field Change
2008-03-14 20:23 FUBAR-BDHR New Issue
2008-03-14 20:23 FUBAR-BDHR File Added: FUBAR_M03.fs2
2008-03-14 20:27 FUBAR-BDHR Note Added: 0008966
2008-03-14 21:09 karajorma Note Added: 0008967
2008-03-14 23:14 FUBAR-BDHR Note Added: 0008970
2008-03-17 12:14 karajorma Note Added: 0008985
2008-03-17 12:14 karajorma Status new => assigned
2008-03-17 12:14 karajorma Assigned To => karajorma
2008-11-10 15:05 karajorma Note Added: 0010166
2008-11-10 15:57 FUBAR-BDHR Note Added: 0010167
2008-11-10 15:58 FUBAR-BDHR File Added: playdead.fs2
2008-11-11 13:38 karajorma Note Added: 0010179
2008-11-11 13:38 karajorma Assigned To karajorma => Goober5000
2008-11-13 13:17 karajorma Assigned To Goober5000 => karajorma
2008-11-13 16:20 karajorma Status assigned => resolved
2008-11-13 16:20 karajorma Fixed in Version => 3.6.10
2008-11-13 16:20 karajorma Resolution open => fixed
2008-11-13 16:20 karajorma Note Added: 0010194
2008-12-25 03:15 FUBAR-BDHR Status resolved => feedback
2008-12-25 03:15 FUBAR-BDHR Resolution fixed => reopened
2008-12-25 03:15 FUBAR-BDHR Note Added: 0010464
2009-01-03 10:16 karajorma Relationship added related to 0001815
2009-01-03 10:16 karajorma Relationship added related to 0001860
2009-01-03 10:17 karajorma Relationship deleted related to 0001860
2009-01-05 03:52 karajorma Status feedback => resolved
2009-01-05 03:52 karajorma Resolution reopened => fixed
2009-01-05 03:52 karajorma Note Added: 0010506
+Issue History