2019-12-05 22:10 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001517FSSCPFREDpublic2008-06-04 11:22
ReporterARSPR 
Assigned Totaylor 
PrioritynormalSeveritytweakReproducibilityalways
StatusresolvedResolutionfixed 
PlatformDELL Dimension 9200OSWindows VistaOS VersionUltimate 32-bit
Product Version3.6.9 
Target VersionFixed in Version3.6.10 
Summary0001517: SEXP argument numbering just reaches 15
DescriptionTake a look at the screenshot.

It would be nice if you could get any amount of argument numbering in the Event editor. It would be pretty useful for the usually long set-message-list SEXP.

(Nevertheless, an EXTREMELY unimportant issue).
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0008629

karajorma (administrator)

The numbers don't seem to be generated at runtime, they're actually images compiled into the build. So to support 1-100 someone is going make the others.

~0008692

WMCoolmon (developer)

Not I, said the fly. :)

~0008693

ARSPR (reporter)

Last edited: 2007-11-24 11:10

I suggest another way with just a set of 19 bitmaps:

+ The current unit bitmaps from 1 to 9.
+ Adding ten bitmaps: 00, 10, 20, ..., 90.

In this way if you see 6 and 50 over it, either you are really dumb or you instantly know you are in 56.

When you reach 100, 200, ..., 1000, 1100, ... 2000, ... you just use 00. And of course you have to manually count the hundreds and thousands which shouldn't be difficult, (or a common situation BTW) ;)

I upload the tens pack. I've used a 12x14 size which maybe needs an extra white border. Tell me and I will resize them (or tell me if you want another looking BTW)

~0008698

Goober5000 (administrator)

"Not I, said the fly. :)"

Um, WMC, you were kinda the one who implemented this feature, so I think that means you're kinda the one responsible for it...

Can you at least tell me where in the code the bitmaps are displayed? I could add something that simply cycles the 1-10 bitmaps over and over.

~0008699

WMCoolmon (developer)

It's not irresponsible to refuse to spend the time to make 85 more bitmaps in Paint when it's clear that it's of limited utility. The minihelp box should already tell you which node you have selected.

For this particular instance, it's of limited utility since send-message-list goes by 4s anyway; you would have to do the math in your head if you relied on node numbers.

ARSPR's solution would be just as effective, require only 20 bitmaps, and could easily be expanded for 100th nodes as well.

~0009193

taylor (administrator)

Made new bitmaps and updated it to work by 5's and rotate 0-95, so it should work regardless of how many arguments you've got.

I'll commit in the morning, too tired to do it right now.

~0009202

taylor (administrator)

Fixered.

~0009311

ARSPR (reporter)

With newest builds the argument numbering has completely disappeared. We have just retail FRED looking.

I've noticed it from SVN 20080423 (Chief: http://www.hard-light.net/forums/index.php/topic,53473.0.html).

Even Kara's newest build suffers it (http://www.hard-light.net/forums/index.php/topic,53718.0.html)

~0009372

taylor (administrator)

Just checked that it works fine with a clean checkout. Must be build specific and nothing wrong with what's in SVN. I'll leave this open for a couple of days to see if the others end up commenting, but it's not broken code wise.

~0009378

karajorma (administrator)

I don't think this is a bug, It's a misunderstanding of what happens now.

Following Taylor's fix only multiples of 5 are numbered. So if all you're doing is using a send-message-list you won't see a number until you Add Data.

~0009380

ARSPR (reporter)

I'll try to re-check later with latest Kara or WCM builds.

~0009385

taylor (administrator)

Going to just assume that it's a misunderstanding as karajorma said. :)
+Notes

-Issue History
Date Modified Username Field Change
2007-11-08 10:47 ARSPR New Issue
2007-11-08 10:47 ARSPR File Added: SEXPArgumentNumbers.jpg
2007-11-09 08:55 karajorma Note Added: 0008629
2007-11-24 09:31 WMCoolmon Note Added: 0008692
2007-11-24 11:02 ARSPR Note Added: 0008693
2007-11-24 11:03 ARSPR File Added: Tens.rar
2007-11-24 11:10 ARSPR Note Edited: 0008693
2007-11-25 04:05 Goober5000 Note Added: 0008698
2007-11-25 05:58 WMCoolmon Note Added: 0008699
2007-11-25 05:58 WMCoolmon Status new => assigned
2007-11-25 05:58 WMCoolmon Assigned To => WMCoolmon
2008-04-05 05:03 taylor Assigned To WMCoolmon => taylor
2008-04-05 05:04 taylor Note Added: 0009193
2008-04-07 22:07 taylor Status assigned => resolved
2008-04-07 22:07 taylor Fixed in Version => 3.6.10
2008-04-07 22:07 taylor Resolution open => fixed
2008-04-07 22:07 taylor Note Added: 0009202
2008-05-08 14:25 ARSPR Status resolved => feedback
2008-05-08 14:25 ARSPR Resolution fixed => reopened
2008-05-08 14:25 ARSPR Note Added: 0009311
2008-06-02 11:28 taylor Note Added: 0009372
2008-06-02 15:49 karajorma Note Added: 0009378
2008-06-03 02:45 ARSPR Note Added: 0009380
2008-06-04 11:22 taylor Note Added: 0009385
2008-06-04 11:22 taylor Status feedback => resolved
2008-06-04 11:22 taylor Resolution reopened => fixed
+Issue History