2020-08-11 04:33 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001424FSSCPgameplaypublic2020-05-03 19:09
ReporterARSPR 
Assigned ToGoober5000 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version3.6.10 
Target VersionFixed in Version 
Summary0001424: New iff_defs.tbl teams appear wrongly in F3 hotkey assignement window.
DescriptionTake Procyon Insurgency MOD mission 14c (Mission 14 part 3). When the SC Agni appears and you are told to follow it, this ship is guarded by Taurus wing.

These ships are "Hostile" but in a quickly engaged event, (AI: Alpha move), they are changed to a "Hostile3" team (defined in PI own iff_defs.tbl)

But in F3 window Taurus wing appears in Friendly section.

(I've used Taylor's XT0615, but I suppose it really doesn't matter at all. But, if you want, I can retest with 3.6.9.)
Additional InformationI don't know if this is actually a bug...

Maybe, friendly or hostile in F3 window is actually based on whether I'm attacked or not by that team. And "Hostile3" doesn't actually attack friendlies:

$IFF Name: Hostile3
$Color: ( 255, 0, 0 )
$Attacks: ("Neutral" "Hostile2" "Traitor" )

In this way, maybe FS2 is OK and it's assigning all "Hostile3" ships to the friendly section. If this is how FS2 works, and just as a cosmetic fix for modding tricks like this one, (a "hostile" team which, in fact, isn't hostile at all), maybe you could add a "$F3ShowAs:" optional field in iff_defs.tbl which would modify the inferred friendly/hostile assignment.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0008214

Goober5000 (administrator)

Reminder sent to: CP5670

You might want to chime in on this.

~0008223

CP5670 (reporter)

Last edited: 2007-07-15 19:31

This behavior is in a sense correct, although as ARSPR said, it would be better if there was some way to specify how a team appears in the hotkeys window.

The Hostile3 ships appear red but do not attack (or get attacked by) Friendly ones. This was necessary for that mission because simply using protect-ship on the player made the enemies follow you around, even if they didn't fire at you.

~0014568

Valathil (developer)

This bug is 5 years old. I am assuming either this is fixed or noone cares enough about it. Closing

~0014571

Goober5000 (administrator)

No, it is perhaps not as severe a bug as others, but definitely a problem. I worked on it for a short period of time a few days ago, but it will need a little bit more effort.

~0016981

Goober5000 (administrator)

PR opened:
https://github.com/scp-fs2open/fs2open.github.com/pull/2336

~0016989

Goober5000 (administrator)

PR merged.
+Notes

-Issue History
Date Modified Username Field Change
2007-06-21 19:39 ARSPR New Issue
2007-07-15 06:09 Goober5000 Status new => assigned
2007-07-15 06:09 Goober5000 Assigned To => Goober5000
2007-07-15 06:09 Goober5000 Note Added: 0008214
2007-07-15 19:30 CP5670 Note Added: 0008223
2007-07-15 19:31 CP5670 Note Edited: 0008223
2012-12-22 16:59 Valathil Note Added: 0014568
2012-12-22 16:59 Valathil Status assigned => closed
2012-12-22 16:59 Valathil Resolution open => no change required
2012-12-22 17:45 Goober5000 Note Added: 0014571
2012-12-22 17:45 Goober5000 Severity tweak => minor
2012-12-22 17:45 Goober5000 Status closed => assigned
2012-12-22 17:45 Goober5000 Resolution no change required => reopened
2020-04-15 15:30 Goober5000 Status assigned => code review
2020-04-15 15:30 Goober5000 Note Added: 0016981
2020-05-03 19:09 Goober5000 Status code review => resolved
2020-05-03 19:09 Goober5000 Resolution reopened => fixed
2020-05-03 19:09 Goober5000 Note Added: 0016989
+Issue History