2019-10-19 00:14 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001271FSSCPFREDpublic2008-07-09 23:45
Reporterthesource2 
Assigned ToGoober5000 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.10 
Summary0001271: Built 20061130. Crash when File->Import->Fs1 mission is pressed
DescriptionJust crashes. Debug built does not give any message
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0007617

Goober5000 (administrator)

Try a newer build.

~0007627

thesource2 (reporter)

Where can I get it?
On http://fs2source.warpcore.org/exes/latest/February2007/ I see only fs2_open but not fred2

~0007628

thesource2 (reporter)

By the way do I need additional vp's to import fs1 missions. I tried icculus port fs1.vp but fs2_pen give error message that race shivan can not be found in icons.tbl

~0007632

Goober5000 (administrator)

Use the release from the HLP forums...
http://www.hard-light.net/forums/index.php/topic,44291.0.html

And use the FreeSpace Port VP...
http://fsport.hard-light.net

And FRED won't work on Linux. It's Windows-only, for the foreseeable future.

~0007637

thesource2 (reporter)

Built form hard-light (3_6_9 from 31 December) crashes too

~0007638

thesource2 (reporter)

However, I can just Open fs1 mission, no need to import

~0007639

Goober5000 (administrator)

Merely opening the mission does not do the import features.

I just tried importing a mission and it didn't crash. You'll have to be more specific. At what point did it crash? What system were you running it on? What messages did you see?

~0007641

thesource2 (reporter)

It crashes just when press Import in main menu. My system is PIII 1200MHz 1Gb RAM GeForce FX 5900 XT Audigy 4 Windows XP Pro SP2. I do not receive any error message even in debug built. Just crash.

~0007642

thesource2 (reporter)

Looks like crash happens if I press any option in Import menu. Are you sure you don't use some instructions like sse2 in normal built?

~0007948

Goober5000 (administrator)

I have still not been able to reproduce this crash in any build.

~0007963

thesource2 (reporter)

Veeeery strange. A hardware dependent bug?

~0007975

Goober5000 (administrator)

Maybe. Try running both with and without -fredhtl.

~0008265

Goober5000 (administrator)

What version of Windows are you running?

~0008283

thesource2 (reporter)

I can't run with or without fredhtl since latest builts (for example C05282007s) do not use this option anymore. My windows is WinXp SP2 Pro with all latest updates. I just bought new PC and now I have different hardware but problem persists.

~0008284

Goober5000 (administrator)

Last edited: 2007-07-24 15:02

Build is spelled B-U-I-L-D, not B-U-I-L-T. BUILT is a verb in the past tense.

Try testing with and without -fredhtl using the 3.6.9 final version of FRED. Then try the -nohtl flag with WMC's latest version.

~0008286

thesource2 (reporter)

Crashes in all cases

~0008369

phreak (developer)

or upload the mission so goober can debug it.

~0008378

Goober5000 (administrator)

See if this build works.
http://fs2source.warpcore.org/exes/latest/20070815-Goober5000.7z

~0008421

thesource2 (reporter)

No it does not :(
P.S. Why are you requesting mission attachment? Crash happens not when I select fs1 mission file to import but when I press File->Import->fs1 mission.

~0008661

Goober5000 (administrator)

I have never been able to reproduce this. I have to assume it's a problem with the user's computer.

~0008663

thesource2 (reporter)

Last edited: 2007-11-18 08:14

The bug happens on both of my machines which have very different hardware.

1. Core 2 Duo E6600 2.4 GHz, 2GB RAM Dual, GeForce 8800 GTX, Windows Vista 32 bit.
2. Pentium 3 1.2 GHZ, 1GB RAM, GeForce 5900 XT, Windows XP Pro 32 bit.

P.S My first machine was tested with nvidia tools on stability and it is rock stable.

~0008664

ARSPR (reporter)

Last edited: 2007-11-18 10:24

I'm sorry to say I can't reproduce it either. I've just tested with:
+ CVS 2007-09-22 http://www.hard-light.net/forums/index.php/topic,49738.0.html
+ 2007-10-28 http://www.hard-light.net/forums/index.php/topic,50258.0.html
+ Taylor's BETA Xt1115

I've got also a quite similar PC:

+ Core 2 Quad Q6600 2.4 GHz, 2 GB RAM, 8800 GTX, Vista 32-bit

~0008668

thesource2 (reporter)

I'll try the latest build.

~0008670

thesource2 (reporter)

Tried 20070922-Goober5000. Crashes :(

~0008672

castor (reporter)

Where did you install it (maybe it has something to do with file paths)?

~0008673

Goober5000 (administrator)

List all the mods you have installed while you are running the import.

~0008675

thesource2 (reporter)

Derelict, fs1, brshivans

~0008677

Goober5000 (administrator)

Are you trying to run all those mods at the same time, or something?

Post your copy of cmdline_fso.cfg.

~0008679

thesource2 (reporter)

Here's from launcher6.ini file
game_flags = -spec -glow -env -mipmap -missile_lighting -cache_bitmaps -orbradar -3dwarp -warp_flash -snd_preload -alpha_env

I use the same command line for fred (except useless ones like -orbradar).

~0008680

Goober5000 (administrator)

Well, you're not using the -mod commandline. Do you have all those VP files installed in your root FS2 folder at the same time? Or do you have them each in their own separate mod folder?

~0008681

thesource2 (reporter)

In a separate folder each. In root folder I have only fs2 and mvp packs.

~0008682

Goober5000 (administrator)

You shouldn't have the mediaVPs in the root folder. Move them to the mediavps folder and see if that fixes it.

~0008694

thesource2 (reporter)

No, that didn't help. I also tried to launch without any parameters but result is the same. I attach a screenshot of my FS2 folder. Maybe I have some more wrong files in it?

~0008695

ARSPR (reporter)

Could it be any kind of strange cross effect with the Russian Cyrillic alphabet and OS?

(Supposing it's Russian ... ;) )

~0008696

thesource2 (reporter)

Last edited: 2007-11-24 15:23

Yes, it's Russian. But it is not the problem. My other PC has English version of Win XP and crash happens there too.

Please note that I have some dlls from other apps there. I will try to run fred without them. Just tell me which dlls are actually from Freespace so I don't delete something necessary.

~0008697

ARSPR (reporter)

FSOpen doesn't need any dll. You can freely delete or move them.

I don't remember retail FS2 so I suggest you renaming them to xxx.OLDdll or something like that in case you need them in the future.

~0008700

thesource2 (reporter)

That didn't help. Debugger breaks with the following message:
Unhandled exception at 0x00419bad in fred2_open_3_6_9.exe: 0xC0000005: Access violation writing location 0x00000000.
at instruction:
00419BAD rep movs dword ptr es:[edi],dword ptr [esi]

Do you have map file for this exe?

~0009438

Goober5000 (administrator)

Fixed.
+Notes

-Issue History
Date Modified Username Field Change
2007-02-11 13:37 thesource2 New Issue
2007-02-11 19:20 Goober5000 Note Added: 0007617
2007-02-12 17:16 thesource2 Note Added: 0007627
2007-02-12 17:18 thesource2 Note Added: 0007628
2007-02-12 22:12 Goober5000 Note Added: 0007632
2007-02-16 18:28 thesource2 Note Added: 0007637
2007-02-16 18:31 thesource2 Note Added: 0007638
2007-02-16 19:39 Goober5000 Note Added: 0007639
2007-02-16 20:33 thesource2 Note Added: 0007641
2007-02-16 21:10 thesource2 Note Added: 0007642
2007-03-07 19:21 Goober5000 Status new => assigned
2007-03-07 19:21 Goober5000 Assigned To => Goober5000
2007-04-11 02:52 Goober5000 Note Added: 0007948
2007-04-11 05:09 thesource2 Note Added: 0007963
2007-04-12 02:12 Goober5000 Note Added: 0007975
2007-07-24 05:25 Goober5000 Note Added: 0008265
2007-07-24 14:59 thesource2 Note Added: 0008283
2007-07-24 15:02 Goober5000 Note Added: 0008284
2007-07-24 15:02 Goober5000 Note Edited: 0008284
2007-07-24 16:09 thesource2 Note Added: 0008286
2007-08-13 02:17 phreak Note Added: 0008369
2007-08-15 07:02 Goober5000 Note Added: 0008378
2007-08-28 15:38 thesource2 Note Added: 0008421
2007-11-18 08:01 Goober5000 Note Added: 0008661
2007-11-18 08:01 Goober5000 Reproducibility always => unable to reproduce
2007-11-18 08:01 Goober5000 Status assigned => resolved
2007-11-18 08:01 Goober5000 Resolution open => unable to reproduce
2007-11-18 08:13 thesource2 Status resolved => feedback
2007-11-18 08:13 thesource2 Resolution unable to reproduce => reopened
2007-11-18 08:13 thesource2 Note Added: 0008663
2007-11-18 08:14 thesource2 Note Edited: 0008663
2007-11-18 10:22 ARSPR Note Added: 0008664
2007-11-18 10:24 ARSPR Note Edited: 0008664
2007-11-18 12:36 thesource2 Note Added: 0008668
2007-11-18 16:34 thesource2 Note Added: 0008670
2007-11-18 19:27 castor Note Added: 0008672
2007-11-18 21:26 Goober5000 Note Added: 0008673
2007-11-20 04:36 thesource2 Note Added: 0008675
2007-11-20 05:27 Goober5000 Note Added: 0008677
2007-11-20 17:24 thesource2 Note Added: 0008679
2007-11-20 18:53 Goober5000 Note Added: 0008680
2007-11-21 05:59 thesource2 Note Added: 0008681
2007-11-21 07:47 Goober5000 Note Added: 0008682
2007-11-24 13:20 thesource2 Note Added: 0008694
2007-11-24 13:21 thesource2 File Added: fs2folder.jpg
2007-11-24 13:38 ARSPR Note Added: 0008695
2007-11-24 15:21 thesource2 Note Added: 0008696
2007-11-24 15:23 thesource2 Note Edited: 0008696
2007-11-24 23:29 ARSPR Note Added: 0008697
2007-11-25 08:27 thesource2 Note Added: 0008700
2008-07-09 23:45 Goober5000 Note Added: 0009438
2008-07-09 23:45 Goober5000 Reproducibility unable to reproduce => sometimes
2008-07-09 23:45 Goober5000 Status feedback => resolved
2008-07-09 23:45 Goober5000 Resolution reopened => fixed
2008-07-09 23:45 Goober5000 Fixed in Version => 3.6.10
+Issue History