2018-12-14 14:15 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000012FSSCPgameplaypublic2006-10-26 23:31
Reporterdiamondgeezer 
Assigned ToRighteous1 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionsuspended 
Product Version 
Target VersionFixed in Version3.6 
Summary0000012: 'Paused' message does not appear upon restore after minimizing game
DescriptionMinimizing FS2 automatically pauses the game. But restoring FSo builds does not display the 'paused' message box. This may be confusing for new players.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000129

RandomTiger (developer)

Confirmed

~0000266

kasperl (developer)

confirmed in 20-01-04 as well.

~0000714

Righteous1 (developer)

Added the function alt_tab_pause() to call the pause routine and disable sounds when the game is minimized. The function is called from osapi.cpp when the game is minimized.
Modules updated:
freespace.h
freespace.cpp
osapi.cpp

~0000759

Goober5000 (administrator)

I'm reopening this because of the related issue of music not resuming when FSO is restored. ;) Any progress on that front, Righteous1?

~0000761

Righteous1 (developer)

See Mantis Bug 116 for the status of that bug. The pause box had nothing to do with that. I backed out the update that caused that issue.

~0000766

Goober5000 (administrator)

Oh. But the pause box is supposed to be displayed?

Funny - I haven't seen it. Lemme look again.

~0000770

Righteous1 (developer)

Only in game, not at the other screens

~0000778

Goober5000 (administrator)

K, I updated and saw it. I suppose this can be re-resolved, except for one thing...

Shouldn't the pause box be overlaid with the battle scene, as when you pause the game normally? Right now your pause is overlaid on a pure black background.

This is just a nitpick, and I'm not sure how easy or practical it is to fix.

~0000779

Righteous1 (developer)

I looked into that at the time and decided it was more trouble than it was worth. IIRC, calling the function that stores and draws the background does other things that caused problems when restoring the game. I seems I had to either push the pause key twice to get it unpaused or had problems with sound. But one of the pause routines (I don't recall which one) would have to be copied and rewritten special for this case. I didn't think it was worth the effort since we just need an indication that the game is paused.

But if you want it persued, I'll pursue it some more.

~0000780

Goober5000 (administrator)

Nah, probably not necessary. Maybe if you're feeling masochistic one day, but in the meantime we should concentrate on other bugs. :)
+Notes

-Issue History
Date Modified Username Field Change
2003-12-19 15:27 diamondgeezer New Issue
2004-01-04 23:15 Kazan Severity trivial => minor
2004-01-29 15:48 RandomTiger Note Added: 0000129
2004-03-04 08:40 kasperl Note Added: 0000266
2004-03-04 15:45 RandomTiger Status new => acknowledged
2004-03-09 03:22 Rga_Noris Summary 'Paused' message does not appear upon restore => 'Paused' message does not appear upon restore after minimizing game
2004-04-02 11:09 Righteous1 Status acknowledged => assigned
2004-04-02 11:09 Righteous1 Assigned To => Righteous1
2004-04-06 23:39 Righteous1 Note Added: 0000714
2004-04-12 14:34 Righteous1 Status assigned => resolved
2004-04-12 14:34 Righteous1 Resolution open => fixed
2004-04-13 05:39 Goober5000 Status resolved => feedback
2004-04-13 05:39 Goober5000 Resolution fixed => reopened
2004-04-13 05:39 Goober5000 Note Added: 0000759
2004-04-13 09:49 Righteous1 Note Added: 0000761
2004-04-14 01:09 Goober5000 Note Added: 0000766
2004-04-14 08:59 Righteous1 Note Added: 0000770
2004-04-14 12:18 Goober5000 Note Added: 0000778
2004-04-14 14:56 Righteous1 Note Added: 0000779
2004-04-14 16:43 Goober5000 Note Added: 0000780
2004-04-14 16:43 Goober5000 Status feedback => resolved
2006-10-26 23:31 Goober5000 Status resolved => closed
2006-10-26 23:31 Goober5000 Resolution reopened => suspended
2006-10-26 23:31 Goober5000 Fixed in Version => 3.6
+Issue History