2017-09-19 19:09 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001186FSSCPcutscenespublic2007-11-22 05:37
ReporterCP5670 
Assigned Totaylor 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version3.6.9 
Target VersionFixed in Version3.6.10 
Summary0001186: Fade sexps no longer work
DescriptionThe fade-in and fade-out operators don't have any effect in RC8 (in OGL mode, if it matters). However, they were working fine in RC7.9, so it looks like this is due to some fairly recent change.
TagsNo tags attached.
Attached Files
  • ? file icon fade.fs2 (3,283 bytes) 2006-12-31 20:04

-Relationships
+Relationships

-Notes

~0007345

taylor (administrator)

It was changed in between 7.9 and RC8 as part of code cleanup and optimization. Technically it should work the same however. Do you have a test mission I can try to replicate the problem with (you can just point out an existing mission, so long as it doesn't take forever to see the problem).

~0007346

CP5670 (reporter)

I uploaded a simple test mission with some fades.

~0007347

taylor (administrator)

Fixed.

And your lucky with your timing btw, 3.6.9 final was about to be uploaded when I saw this bug. :)

~0007350

CP5670 (reporter)

Is the fix in the 3.6.9 build in Goober's post? I just tried it out but wasn't getting the fades in it.

~0007353

taylor (administrator)

Hmm, freaky. It does contain the fix, I double checked, and it works perfectly under Linux. Not sure why it doesn't work in Windows though. Give me a few minutes to figure that out and I'll update the build.

~0007354

taylor (administrator)

Yep, that's what a severe lack of sleep will get you. :(

All fixed now, the properly compiled EXEs have been uploaded in place of the previous ones. Download the 3.6.9 release once more to double-check, but it should be working as expected now.

~0007357

CP5670 (reporter)

Tell me about it. :D

This is almost fixed now, but there is still one small issue with fade-out. After it fades out, it doesn't stay faded anymore like it used to; the fade effect works fine, but the screen then switches back to the normal view instantly instead of remaining black or whatever color.

~0007359

taylor (administrator)

It actually should have done that before, and I tried to preserve that behavior, even though I don't really approve of it. If you are using a standard fade then then at least one of the RGB values can't be 0. The alpha version of the fade (what I think the sexp uses), allows RGB values of 0, so long as the alpha value is > 0.

~0007362

CP5670 (reporter)

I'm not sure what you're talking about. The fade-out sexp only gives you a choice of three colors (black, white and red, and white apparently doesn't work) and in 3.6.9, they all revert to the normal image after the fade is finished.

Is there any way to retain the color after the fade, like the way it used to work?

~0007493

Ransom Arceihn (reporter)

What's the status of this? Any chance of it getting fixed?

~0007494

taylor (administrator)

It's fixed, CP5670 and I worked it out via PM. :)

All of the fix isn't in CVS yet though, hence why the bug is still open. I'll have time to catch up on my commits again this weekend.

~0007616

taylor (administrator)

Going in CVS now, so...

Fixered.

~0007828

CP5670 (reporter)

This bug has unfortunately returned in your 2/27 XT build.

~0007895

taylor (administrator)

All of the previous test missions work fine for me. I still need to get you a new build though, so hold on and I'll PM you a link to a newer build later today and you can test again with that.

~0008021

taylor (administrator)

fade.fs2 still works fine with both fade-in and fade-out for me. I also have a fadetest.fs2, which fades in and out for black, white, and red. It also works perfectly. ... But not under Windows. :) It all functions, but there is obviously some issue with fade-out since it works, but it's extremely slow.

That issue doesn't show up on Linux or OS X, so I'm not totally sure what the problem might be. But I'm trying to track it down now.

~0008025

CP5670 (reporter)

Strange. If you find anything, send me a build and I'll check it out.

~0008598

taylor (administrator)

Although I haven't changed anything specific to the fade problem, give this build a try and see if it works any better:
http://fs2source.warpcore.org/exes/latest/taylor/20071028-win32.rar

~0008602

ARSPR (reporter)

CP5670, check the build Taylor points because at least in my PC this bug has gone since at least XT0911 (See 0001510)

~0008684

taylor (administrator)

Fixered.
+Notes

-Issue History
Date Modified Username Field Change
2006-12-31 18:18 CP5670 New Issue
2006-12-31 19:47 taylor Note Added: 0007345
2006-12-31 19:47 taylor Status new => assigned
2006-12-31 19:47 taylor Assigned To => taylor
2006-12-31 20:04 CP5670 File Added: fade.fs2
2006-12-31 20:04 CP5670 Note Added: 0007346
2006-12-31 20:28 taylor Note Added: 0007347
2007-01-01 00:35 CP5670 Note Added: 0007350
2007-01-01 04:00 taylor Note Added: 0007353
2007-01-01 04:19 taylor Note Added: 0007354
2007-01-01 12:01 CP5670 Note Added: 0007357
2007-01-01 14:16 taylor Note Added: 0007359
2007-01-01 19:24 CP5670 Note Added: 0007362
2007-01-18 12:10 Ransom Arceihn Note Added: 0007493
2007-01-18 13:37 taylor Note Added: 0007494
2007-02-11 10:06 taylor Status assigned => resolved
2007-02-11 10:06 taylor Fixed in Version => 3.6.10
2007-02-11 10:06 taylor Resolution open => fixed
2007-02-11 10:06 taylor Note Added: 0007616
2007-03-10 00:19 CP5670 Status resolved => feedback
2007-03-10 00:19 CP5670 Resolution fixed => reopened
2007-03-10 00:19 CP5670 Note Added: 0007828
2007-03-23 21:06 taylor Note Added: 0007895
2007-04-19 18:42 taylor Note Added: 0008021
2007-04-21 16:48 CP5670 Note Added: 0008025
2007-10-28 06:45 taylor Note Added: 0008598
2007-10-28 09:14 ARSPR Note Added: 0008602
2007-11-22 05:37 taylor Status feedback => resolved
2007-11-22 05:37 taylor Resolution reopened => fixed
2007-11-22 05:37 taylor Note Added: 0008684
+Issue History