2020-07-06 19:01 EDT


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0001090FSSCPmultiplayerpublic2012-01-09 13:06
ReporterFUBAR-BDHR 
Assigned ToWanderer 
PrioritynormalSeveritymajorReproducibilityrandom
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001090: Null vec3d in vec3d normalize
DescriptionI saw that this error was reported before in 0000392 and showed resolved. Well it's not. Had it a couple of times today and finally in the last 2 missions I played. Seems to occur near respawn. Possibly a side effect of self destruct???
Additional InformationSorry didn't know what to do if the error was in resolved status so I started a new one.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0006811

FUBAR-BDHR (developer)

Forgot to add it usually shows up as a warning but the last time it crashed.

~0006819

taylor (administrator)

Should be fixed in the next build.


Fixered.

~0007457

FUBAR-BDHR (developer)

Got it several times in a row playing cold sword today.

~0008246

Kazan (developer)

status of this bug report

~0009433

FUBAR-BDHR (developer)

Last edited: 2008-07-04 15:50

It's back. Just got it testing Kara's standalone fixes. http://www.freespacefaq.com/Misc-Downloads/Builds/StandaloneFixes-1.7z

It's coming up as:

WARNING: "Null vec3d in vec3d normalize. Trace out of vecmat.cpp and find offending code." at VecMat.cpp:803


It let me continue but crashed later with another error.

~0009434

taylor (administrator)

It's not back, it's just a generic warning message that can get generated from a thousand different places in the game. The message is useless except to someone who is debugging so it really doesn't help to keep bringing up this issue again and again. When we notice it during debugging then we'll fix it, but otherwise you should just ignore it.

~0011124

Wanderer (developer)

I'll reopen the issue... FUBAR was running a debugger and we were able to see the cause of the null vec warning this time.

FUBAR's stack's relevant portion
...> fs2_open_3_6_11d.exe!debug_int3
     fs2_open_3_6_11d.exe!Warning
     fs2_open_3_6_11d.exe!vm_vec_copy_normalize
     fs2_open_3_6_11d.exe!vm_vec_normalize
     fs2_open_3_6_11d.exe!multi_oo_calc_interp_splines
     fs2_open_3_6_11d.exe!multi_oo_unpack_data
...

Where it was seen that in 'multi_oo_calc_interp_splines' vdir was very small (0,6.658070e-025,0). Given how vm_vec_copy_normalize works (all math is done in floats and not in doubles/long doubles) this will generate null vec issue ((6.658070e-025)^2 << 3.4E - 38).

Either the safeguards used (IS_NULL_VECS) needs to be updated to check for either against null with squared vector components or by setting the check from '== 0.0' to '> -1e-16 && < 1e-16'. Or by using higher precision elements (long double) in the vm_vec_copy_normalize. I'm not sure which is the best approach.

In addition to FUBAR also Chief reported that similar issues have been causing trouble in multi lately.

~0011134

portej05 (reporter)

See commit 5518
IS_VEC_NULL now checks the range -1e16 to 1e16 (checking == 0 is not really a good idea with floating point values)

~0011137

FUBAR-BDHR (developer)

Haven't seen any in multi yet. Seem to be getting quite a few ships reporting null MOI errors now that weren't before. They do have small values in the MOI.

~0011154

Wanderer (developer)

Fix for the additional null MOIs caused by the code changes should now be in (r5531).

~0011171

Wanderer (developer)

Assumed fixed - reopen if necessary.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2006-10-05 22:13 FUBAR-BDHR New Issue
2006-10-05 22:13 FUBAR-BDHR File Added: Media-10-05-06e.rar
2006-10-05 22:13 FUBAR-BDHR File Added: Media-10-05-06f.rar
2006-10-05 22:14 FUBAR-BDHR Note Added: 0006811
2006-10-06 05:00 taylor Status assigned => resolved
2006-10-06 05:00 taylor Resolution open => fixed
2006-10-06 05:00 taylor Note Added: 0006819
2007-01-13 21:29 FUBAR-BDHR Status resolved => feedback
2007-01-13 21:29 FUBAR-BDHR Resolution fixed => reopened
2007-01-13 21:29 FUBAR-BDHR Note Added: 0007457
2007-01-13 21:30 FUBAR-BDHR File Added: Media-01-13-07a.rar
2007-07-23 16:12 Kazan Note Added: 0008246
2007-07-23 16:37 taylor Status feedback => resolved
2007-07-23 16:37 taylor Resolution reopened => fixed
2008-07-04 15:47 FUBAR-BDHR Status resolved => feedback
2008-07-04 15:47 FUBAR-BDHR Resolution fixed => reopened
2008-07-04 15:47 FUBAR-BDHR Note Added: 0009433
2008-07-04 15:48 FUBAR-BDHR File Added: fs2_open.log
2008-07-04 15:50 FUBAR-BDHR Note Edited: 0009433
2008-07-04 16:38 taylor Note Added: 0009434
2008-07-04 16:38 taylor Status feedback => resolved
2008-07-04 16:38 taylor Resolution reopened => suspended
2009-08-05 17:13 Wanderer Assigned To taylor =>
2009-08-05 17:13 Wanderer Status resolved => feedback
2009-08-05 17:13 Wanderer Resolution suspended => reopened
2009-08-05 17:13 Wanderer Note Added: 0011124
2009-08-14 08:31 portej05 Note Added: 0011134
2009-08-18 05:11 FUBAR-BDHR Note Added: 0011137
2009-08-23 08:10 Wanderer Note Added: 0011154
2009-09-06 04:29 Wanderer Status feedback => resolved
2009-09-06 04:29 Wanderer Resolution reopened => fixed
2009-09-06 04:29 Wanderer Assigned To => Wanderer
2009-09-06 04:29 Wanderer Note Added: 0011171
2012-01-05 17:55 taylor Changeset attached => Import 2012-01-05 17:52:05 fs2_open_3_6_9 r3625
2012-01-09 13:06 taylor Changeset attached => fs2open_websvn fs2_open_3_6_9 r3625
+Issue History