2018-09-26 05:42 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001063FSSCPuser interfacepublic2007-03-22 22:02
ReporterBackslash 
Assigned Totaylor 
PrioritynormalSeverityminorReproducibilityrandom
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.10 
Summary0001063: Lab screen -- if you click between top buttons, they hide and there is no way to exit
DescriptionIn the F3 Lab, if you click between the top buttons, they disappear and now there is no way to exit the lab (or the game).
Additional InformationI did a search and couldn't find this Mantised, so here we go. Normally I'd consider this a minor bug, but the fact that it prevents one from exiting (without an alt+tab, or being in windowed mode) makes it quite a bit more annoying.

I noticed that if I removed the flag WS_NOTITLEBAR (lab.cpp line 1078), a titlebar for the main window would show up and now clicking between the buttons does not have a problem. [However, clicking the 'close' X button makes the buttons disappear as expected, including the Exit button, thus stranding us again.] I wondered if this means clicking between the buttons on a no-title-bar window was somehow clicking the 'close' button, but so far I'm not seeing it, as far as I understand the code.

Another thing this brings up is keypress code -- whether or not the above bug is fixed, it would be a good idea to have a key work for exiting the lab, perhaps ESC. I'm guessing this is simple to implement (at least for those who know about this GUI code) but I can't figure out the proper syntax, and maybe I'm putting it in the wrong function anyway. So, some example code would be appreciated (should I make a new thread for this?) Plus, if you give me this example, I could then add lots more requested features involving keys... :-)
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0006686

taylor (administrator)

Hmm, I know that it did this, but I can't get it to happen for me now. I thought that I had fixed this at some point, but never committed it. Can't remember what was the cause however. That was about 3 code trees back though, so I'm not exactly sure if I even have that old fix still, and I'm not really willing to dig up everything to find that out.

As far as keypress capturing, it just needs to be implemented period. I'm not sure what you've done so far with it though. Might be a good thing to open a thread in the internal forum about, so we can try and drum up more support for getting this done. I suspect that it would only take an hour or so to code up, depending on how it was done.

~0006913

taylor (administrator)

* BUMP *

I still can't get this to happen anymore. Can you still get it to happen Backslash?

~0006937

Fractux (reporter)

Last edited: 2006-10-19 15:30

I've just tried to reproduce this with 3.6.9 RC7 and RC6 and I have not been able to do so.

edited on: 10-19-06 15:30

~0006958

taylor (administrator)

Well, no response from Backslash and I can't replicate this any longer in the stable or unstable branches. Since Fractux is apparently getting the same results I'll just assume that this is actually fixed, or some build specific (compiler settings or something) issue, and close this.

If a good test case to replicate this with becomes available then reopen.

~0006959

taylor (administrator)

Closered.

~0007547

taylor (administrator)

Reopening this because I finally tracked it down, after being able to reproduce it regularly. It's actually to do with the bar getting hidden when the left mouse button is raised. An extra flag check to ignore that (just like it does when the left mouse button is pressed) and the problem went away.

I also added ESC key support, so it's possible to exit even if the toolbar does disappear.

I'll resolve this once the code hits CVS.

~0007881

taylor (administrator)

Fixered.
+Notes

-Issue History
Date Modified Username Field Change
2006-09-23 06:59 Backslash New Issue
2006-09-23 09:25 taylor Note Added: 0006686
2006-10-19 00:41 taylor Note Added: 0006913
2006-10-19 15:19 Fractux Note Added: 0006937
2006-10-19 15:30 Fractux Note Edited: 0006937
2006-10-21 01:08 taylor Note Added: 0006958
2006-10-21 01:08 taylor Status new => closed
2006-10-21 01:08 taylor Note Added: 0006959
2007-01-25 02:56 taylor Note Added: 0007547
2007-01-25 02:56 taylor Assigned To => taylor
2007-01-25 02:56 taylor Severity block => minor
2007-01-25 02:56 taylor Reproducibility always => random
2007-01-25 02:56 taylor Status closed => assigned
2007-01-25 02:56 taylor Resolution open => reopened
2007-01-25 02:56 taylor Projection none => tweak
2007-03-22 22:02 taylor Status assigned => resolved
2007-03-22 22:02 taylor Fixed in Version => 3.6.10
2007-03-22 22:02 taylor Resolution reopened => fixed
2007-03-22 22:02 taylor Note Added: 0007881
+Issue History