2018-02-21 12:45 EST


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0001041FSSCPcutscenespublic2012-01-09 13:06
Reporterleeisl 
Assigned Totaylor 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.10 
Summary0001041: red tint in end cutscene
DescriptionIn the final mission after jumping out both end cutscenes are played with a distinctively red tint. If I don't jump out however the cutscenes play normally.
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0001302resolvedtaylor green tint in starting intro 
has duplicate 0001305resolvedtaylor Green Cutscenes 
+Relationships

-Notes

~0006579

taylor (administrator)

Are these the MVE or AVI versions of the end movies?

~0006580

leeisl (reporter)

original MVE's

~0006584

Goober5000 (administrator)

I got this bug too. It was rather fun to see the Shivans in redscale, despite it being a bug. :)

When I replayed the cutscenes from the tech room they looked fine.

~0006587

taylor (administrator)

Neither the clear color nor standard color is reset before movie playback. I assume something is getting carried over from that mission and doesn't get the benefit of being automatically reset by the interface.

I'm not going to have the chance to test whether it works or not, but I'll go ahead and commit the changes. It shouldn't hurt anything if it ends up being wrong since those two things are reset every time they need to be used anyway.

~0006591

taylor (administrator)

Going to assume that this is fixed. Reopen if it's still a problem in the next set of builds.

~0006592

taylor (administrator)

Fixered.

~0006862

Goober5000 (administrator)

Reposted from 0001106...

Since your site is buggy and I didn't find reopen bug button (and add bugnote link does not work for resolved bugs) I report this again. Red tint in end cutscene was NOT fixed. Bug still present in redmenace-20061008

~0006866

taylor (administrator)

Works fine for me. Can you reproduce it Goober?

~0006868

Goober5000 (administrator)

I can't test it right now, but is it possible you only committed the original fix to one branch?

~0006869

taylor (administrator)

I thought that I might have, but I checked and the fix is in both branches.

~0006870

Goober5000 (administrator)

Oh, gak. It seems to be one of those debug/release things. It worked for me in both debug builds, but in neither release build. The -window command line made no difference.

~0006873

taylor (administrator)

Hmm, still works fine for me. A Windows only thing perhaps? It must be build setting related if it's only happening in release builds, so that would likely make it Windows only as well.

And just to confirm, it also happens in the 7dot8 build, correct?

~0006874

thesource2 (reporter)

Yes for me. Actually I first noticed this bug in RC7dot8

~0006875

Goober5000 (administrator)

Thesource2, does it happen in the debug build of RC7dot8?

~0006879

thesource2 (reporter)

Tried to check it,but....
1. I have spent at least 10 minutes waiting your built to load the mission: it loaded models (it took much more time then in release built), preloaded sounds and then....loaded models again! Is that supposed to be funny?
2. In mission when two Cains arrived fs2 started to give warning dialogs about "turret spline path" each time cruiser fired it's beam, minimizing freespace. This freak-show continued for about a minute, after that windows droped to blue screen of death.
Sorry, but it is impossible to test something under these conditions.

~0006883

Goober5000 (administrator)

1. It's probably converting extra models to IBX. It's not being funny; it's necessary.

2. The "turret spline path" message happens a lot with the mediaVPs. Just disable them.

~0006884

thesource2 (reporter)

Tried it, but got tones of warning messages about missing bitmaps. Too many - can not wait until mission start. By the way they show that the same bitmaps are loaded many times. Why? Is there any way to supress warning dialogs?

~0006886

Goober5000 (administrator)

Try the -noparseerrors command-line option.

~0006887

thesource2 (reporter)

-noparseerrors does not work. Still tones of warnings

~0006888

thesource2 (reporter)

Got to mission, but when super-nova started and I engaged my jump drive, rc7dot8-debug crashed with the following error:
Assert: Viewer_obj
File: c:\temp\fs2_open_3_6_9.rc7dot8\code\freespace2\freespace.cpp
Line: 2407
[This filename points to the location of a file on the computer that built this executable]

Call stack:
------------------------------------------------------------------
    game_render_frame() game_frame() game_do_frame() game_do_state() gameseq_process_events() game_main() WinMain() WinMainCRTStartup() kernel32.dll 7c816fd7()
------------------------------------------------------------------

~0006889

Goober5000 (administrator)

Assert: Viewer_obj

I got that too. Just keep clicking OK and it should work.

~0006893

thesource2 (reporter)

Goober5000, what are you talking about? When I press OK Visual Studio debugger is launched. This is crash, I can not continue

~0006894

Goober5000 (administrator)

Then click "continue" in Visual Studio.

The Viewer_obj should probably be reported as a separate bug.

~0006898

thesource2 (reporter)

In Visual Studio I can press OK to Debug and cancel to exit. That's it.

~0007126

taylor (administrator)

* BUMP *

Please try to replicate this bug again with this build:
http://icculus.org/~taylor/fso/testing/rc7dot9u.rar

~0007176

thesource2 (reporter)

redmenace-20061115
Bug present in retail
Can not test debug due to tones of warnings on mission start.
I can get rid of them by enabling MediaVP but until particle rendering bug and Cain turret bug are fixed I can't use this way either

~0007250

taylor (administrator)

Try again with: http://icculus.org/~taylor/fso/willrobinson/hoopla.rar

~0007607

taylor (administrator)

Should be fixed in the next available build (from stable or unstable CVS). Reopen if it's still not working.

Fixered.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2006-09-09 06:33 leeisl New Issue
2006-09-09 06:57 taylor Note Added: 0006579
2006-09-09 07:02 leeisl Note Added: 0006580
2006-09-09 12:55 Goober5000 Note Added: 0006584
2006-09-09 14:03 taylor Note Added: 0006587
2006-09-09 14:03 taylor Status new => assigned
2006-09-09 14:03 taylor Assigned To => taylor
2006-09-10 16:44 taylor Note Added: 0006591
2006-09-10 16:44 taylor Status assigned => resolved
2006-09-10 16:44 taylor Resolution open => fixed
2006-09-10 16:44 taylor Note Added: 0006592
2006-10-11 15:02 Goober5000 Status resolved => feedback
2006-10-11 15:02 Goober5000 Resolution fixed => reopened
2006-10-11 15:02 Goober5000 Note Added: 0006862
2006-10-11 17:24 taylor Note Added: 0006866
2006-10-11 17:41 Goober5000 Note Added: 0006868
2006-10-11 18:27 taylor Note Added: 0006869
2006-10-11 20:24 Goober5000 Note Added: 0006870
2006-10-12 03:53 taylor Note Added: 0006873
2006-10-12 07:24 thesource2 Note Added: 0006874
2006-10-12 08:18 Goober5000 Note Added: 0006875
2006-10-13 05:53 thesource2 Note Added: 0006879
2006-10-13 11:59 Goober5000 Note Added: 0006883
2006-10-13 12:51 thesource2 Note Added: 0006884
2006-10-14 00:13 Goober5000 Note Added: 0006886
2006-10-14 05:47 thesource2 Note Added: 0006887
2006-10-14 10:13 thesource2 Note Added: 0006888
2006-10-14 11:22 Goober5000 Note Added: 0006889
2006-10-15 00:58 thesource2 Note Added: 0006893
2006-10-15 11:23 Goober5000 Note Added: 0006894
2006-10-16 04:17 thesource2 Note Added: 0006898
2006-11-14 19:59 taylor Note Added: 0007126
2006-11-26 04:05 thesource2 Note Added: 0007176
2006-12-06 03:40 taylor Note Added: 0007250
2007-02-10 00:22 taylor Status feedback => resolved
2007-02-10 00:22 taylor Fixed in Version => 3.6.10
2007-02-10 00:22 taylor Resolution reopened => fixed
2007-02-10 00:22 taylor Note Added: 0007607
2007-02-24 22:43 phreak Relationship added has duplicate 0001270
2007-02-24 22:52 taylor Relationship deleted has duplicate 0001270
2007-02-25 00:15 taylor Relationship added has duplicate 0001302
2007-02-28 05:06 taylor Relationship added has duplicate 0001305
2012-01-05 17:55 taylor Changeset attached => Import 2012-01-05 17:52:05 fs2_open_3_6_9 r3515
2012-01-09 13:06 taylor Changeset attached => fs2open_websvn fs2_open_3_6_9 r3515
+Issue History