2019-10-14 13:02 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001007FSSCPgraphicspublic2006-12-19 17:51
ReporterShotman 
Assigned Totaylor 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformPC 32OSWindowsOS VersionXP
Product Version3.6.9 
Target VersionFixed in Version3.6.9 
Summary0001007: Explosions are sometimes blury and undetailed
DescriptionLook at the screenshots. Fighter explosions are OK but if something bigger goes down, explosions are undetailed and look retailish. Explosion texture in adveffects is good{thanx Lightspeed} and gameplay is smooth, so why the game take this blurry LOD? It looks very bad.
Steps To ReproduceBlow up something bigger than fighter and be close to it so the game should choose best LOD.{but it doesnt}
Additional InformationI use latest CVS but this problem was on every build I had. I use latest 3.6.8. zeta mediavps and mp-710 files.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0006284

taylor (administrator)

I noticed this a few days ago. It's on my todo list for this weekend.

~0006420

taylor (administrator)

I think this is fixed, at least I can't reproduce it anymore, so try with the next available build and make sure it's working for you too.

~0006431

Shotman (reporter)

I tried 369rc6 and the bug is still there, at least 2 Satises in Surrender belisarius explode ugly. Is it supposed to be fixed in that build?

~0006433

taylor (administrator)

It wasn't fixed (if it was actually fixed) until after R6. You'll have to wait for the next build. I'll probably release a small test build this weekend though, and I'll include a link here so you can check it out.

~0006487

taylor (administrator)

I think that this is good and fixed now, after a lot of testing. If there is an RC7 soon, and the problem is still there, then just reopen this bug and I'll take another look.

~0006488

taylor (administrator)

Fixered.

~0007226

Shotman (reporter)

I tested it on rc7.9x and issue is still there. Is it something wrong with mipmapping? I noticed it doesnt work in FS even if checked in launcher.

~0007227

taylor (administrator)

Post a screenshot.

~0007245

taylor (administrator)

* BUMP *

No response for a week, and I can't reproduce it. If no response by tomorrow, I'm closing this again.

~0007274

taylor (administrator)

Can't replicate, and no response from reporter.

Marking this as fixed once more.

~0007278

Shotman (reporter)

Last edited: 2006-12-09 16:13

sorry for the delay i had some other things to do. Here are the screens.
Is it a bug or no?

~0007279

taylor (administrator)

Please attach your fs2_open.log file too (it's in "data/" now).

~0007285

Shotman (reporter)

here it is...

~0007301

taylor (administrator)

The bug was fixed, and I can't reproduce the problem in current builds. No one else has reported it either, so I'm going to lean towards it not being a code problem.

Do the explosions still look blurry if you don't use anything except for the retail VPs and no cmdline options?

~0007308

Shotman (reporter)

Last edited: 2006-12-19 14:34

Yes, explosions in retail were always blurry, didnt you mean with mediavps which are supposed to have High-quality explosion textures {Lightspeed}? Anyway I tried it all ways and nothing. Almost all small explosions are good detailed except of anything cruiser sized and larger and even they are sometimes detailed.
I posted a thread on hard-light to discuss this http://www.hard-light.net/forums/index.php/topic,43945.0.html

~0007309

taylor (administrator)

Ok, if it happens without the MediaVPs, and without cmdline options, then it's not this bug. The retail explosions (unless you try and use certain cmdline options) don't have mipmaps, and the game can only show exactly what the explosion textures look like. This means that you either have a system issue (be it a setting, or some video driver thing) or a data issue (something other than retail or MediaVP files getting used).

Given that, I'm marking this as resolved again, and we can continue working out the problem in your HLP forum thread about it.
+Notes

-Issue History
Date Modified Username Field Change
2006-07-22 11:54 Shotman New Issue
2006-07-22 11:58 Shotman File Added: nice_exp_fighter.jpg
2006-07-22 11:58 Shotman File Added: ugly_exp_corvette.jpg
2006-07-22 11:59 Shotman File Added: ugly_exp_corvette2.jpg
2006-07-22 12:37 taylor Note Added: 0006284
2006-07-22 12:37 taylor Assigned To => taylor
2006-07-22 12:37 taylor Status new => assigned
2006-08-09 11:47 taylor Note Added: 0006420
2006-08-10 12:57 Shotman Note Added: 0006431
2006-08-10 13:32 taylor Note Added: 0006433
2006-08-19 00:44 taylor Note Added: 0006487
2006-08-19 00:44 taylor Status assigned => resolved
2006-08-19 00:44 taylor Resolution open => fixed
2006-08-19 00:44 taylor Note Added: 0006488
2006-11-30 15:55 Shotman Status resolved => feedback
2006-11-30 15:55 Shotman Resolution fixed => reopened
2006-11-30 15:55 Shotman Note Added: 0007226
2006-11-30 17:33 taylor Note Added: 0007227
2006-12-06 03:18 taylor Note Added: 0007245
2006-12-07 15:46 taylor Status feedback => resolved
2006-12-07 15:46 taylor Fixed in Version => 3.6.9
2006-12-07 15:46 taylor Resolution reopened => fixed
2006-12-07 15:46 taylor Note Added: 0007274
2006-12-07 15:50 Shotman File Added: screen0017.jpg
2006-12-07 15:51 Shotman Status resolved => feedback
2006-12-07 15:51 Shotman Resolution fixed => reopened
2006-12-07 15:51 Shotman Note Added: 0007278
2006-12-07 15:52 Shotman File Added: screen0027.jpg
2006-12-07 15:55 Shotman Note Edited: 0007278
2006-12-07 15:55 Shotman Note Edited: 0007278
2006-12-07 16:11 taylor Note Added: 0007279
2006-12-08 15:24 Shotman File Added: fs2_open.log
2006-12-08 15:24 Shotman Note Added: 0007285
2006-12-09 16:13 Shotman Note Edited: 0007278
2006-12-17 05:53 taylor Note Added: 0007301
2006-12-19 14:30 Shotman Note Added: 0007308
2006-12-19 14:34 Shotman Note Edited: 0007308
2006-12-19 17:51 taylor Note Added: 0007309
2006-12-19 17:51 taylor Status feedback => resolved
2006-12-19 17:51 taylor Resolution reopened => fixed
+Issue History