2019-11-21 05:36 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000953FSSCPmediaVPpublic2007-11-16 22:18
ReporterShotman 
Assigned ToDa_Brain 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformPCOSWindowsOS VersionXP SP 2
Product Version3.6.9 
Target VersionFixed in Version3.6.10 
Summary0000953: Debrises from Satis are not rotating correctly
DescriptionDebrises from Satis are not rotating correctly.
Steps To ReproduceJust try to blow up some Satis and look at debrises. I think its because they dont have center on correct xyz coordinates in the middle of model.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0005872

Shotman (reporter)

I also noticed that sometimes you can shoot through this model. Maybe bad collision model?

~0005873

Goober5000 (administrator)

We need more information. The following would be helpful:

What mods are you running?
Are you using the mediaVPs?
Is the Satis a retail model or an HTL model?
How is the rotation in FSO different from the rotation in retail?
Can you get a video capture of the correct rotation and a video capture of the incorrect rotation, so we can compare them?

~0005887

Shotman (reporter)

1. No mods {first mission in main fs2 campaign}
2.Yes, I use 3.6.8 Zeta
3.Its HTL model High-poly Satis {Raa Tor'h/StratComm}
4. Debrises rotate around point that is not in the middle of them. I cant get video capture because its bigger than 5 MB.

~0005889

taylor (administrator)

I don't know that them not rotating on exact center is actually a bug. It may be by design. Unless it's obviously wrong (like the center is one end, in a bad way) then it's probably not a bug.

~0005891

Shotman (reporter)

Look at this video: http://www.youtube.com/watch?v=8SiC5zz9pus

~0005892

taylor (administrator)

Ok, that's deffinitely a bug. Doesn't happen on the retail model either, though it appears to break into the same peices, so this is just a problem with the hi-poly model.

It's not really a SCP problem though. This needs to be reported to Raa and/or StratComm for them to deal with. Hopefully one of them will get over here to see the problem, then I'll close this.

~0005893

Goober5000 (administrator)

DaBrain ought to know who to bug about this.

~0005979

StratComm (reporter)

Last edited: 2006-06-27 22:53

It's just a conversion oversight, not really a bug as much as just incomplete media. This comes up all too often really (remember the Orion floating turret bug? Same problem) but I can't fix it unless I can find the original model. I'll see what I can do but it's probably going to be a little hacky.

EDIT: Can someone (Shotman? DaBrain?) please test the model I attached? Specifically, look at the always annoying multipart turret and stability issues; the rotation problems should be fixed. Sorry I don't have time to test it myself.

edited on: 06-27-06 22:53

~0005980

taylor (administrator)

Looks and works great for me. :)

~0005989

Shotman (reporter)

Works great too, the bug is resolved.

~0005990

Goober5000 (administrator)

Cool. Marking as resolved. :)

~0005992

taylor (administrator)

How about we wait until this fix in actually in the MediaVPs before this is considered "Resolved". :)

DaBrain can take care of resolving this when he has time to fold the new model into the VPs

~0005993

Goober5000 (administrator)

Oh right. And I've gotten on your case for that before too. :D

~0008656

Da_Brain (developer)

Ok problem solved.
+Notes

-Issue History
Date Modified Username Field Change
2006-06-19 12:22 Shotman New Issue
2006-06-19 12:27 Shotman Note Added: 0005872
2006-06-19 13:01 Goober5000 Note Added: 0005873
2006-06-20 13:15 Shotman Note Added: 0005887
2006-06-20 13:40 taylor Note Added: 0005889
2006-06-20 15:05 Shotman Note Added: 0005891
2006-06-20 15:51 taylor Note Added: 0005892
2006-06-21 11:29 Goober5000 Note Added: 0005893
2006-06-21 11:29 Goober5000 Assigned To => Da_Brain
2006-06-21 11:29 Goober5000 Status new => assigned
2006-06-27 18:19 StratComm Note Added: 0005979
2006-06-27 22:51 StratComm File Added: freighter04.pof
2006-06-27 22:52 StratComm Note Edited: 0005979
2006-06-27 22:53 StratComm Note Edited: 0005979
2006-06-28 00:06 taylor Note Added: 0005980
2006-06-29 06:13 Shotman Note Added: 0005989
2006-06-29 09:37 Goober5000 Note Added: 0005990
2006-06-29 09:37 Goober5000 Status assigned => resolved
2006-06-29 09:40 taylor Status resolved => feedback
2006-06-29 09:40 taylor Resolution open => reopened
2006-06-29 09:41 taylor Note Added: 0005992
2006-06-29 09:41 taylor Status feedback => assigned
2006-06-29 10:39 Goober5000 Note Added: 0005993
2006-07-15 18:16 taylor Category models => mediaVP
2007-11-16 22:17 Da_Brain Note Added: 0008656
2007-11-16 22:18 Da_Brain Status assigned => resolved
2007-11-16 22:18 Da_Brain Fixed in Version => 3.6.10
2007-11-16 22:18 Da_Brain Resolution reopened => fixed
+Issue History