2019-11-20 21:33 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000080FSSCPOpenGLpublic2007-03-23 04:17
ReporterRandomTiger 
Assigned Totaylor 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6 
Summary0000080: OGL HT&L poof effects not working
DescriptionThe screenshot makes it clear.
The poof effect is rendered in 3D space rather than in front of the eye. D3D works perfectly so OGL may need to branch its codepath off.

Also fogging doesnt work. I had a look into fixing this but got lost in unfamilar OGL code. Give me a shout if you need any info on how I implemented it in D3D.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000154

RandomTiger (developer)

Fogging now works in htl, but not in non htl because its not setup to shade the vertices from an average background pixel colour. Perhaps not an issues since no-one uses non htl anyway.

Poofs are still messed up though

~0000763

taylor (administrator)

This (poofs) is fixed now right? My OGL fixes for the whiteout and neb2 lightning bugs will go in CVS as soon as I get the chance. Neb2 OGL should work the same as D3D after that.

~0000768

taylor (administrator)

all fixes in and tested in OGL/D3D
+Notes

-Issue History
Date Modified Username Field Change
2004-01-22 14:01 RandomTiger New Issue
2004-01-22 14:01 RandomTiger File Added: gl_fog.jpg
2004-02-04 15:47 RandomTiger Note Added: 0000154
2004-03-04 15:48 RandomTiger Status new => acknowledged
2004-03-04 15:52 RandomTiger Assigned To => phreak
2004-03-11 16:03 RandomTiger Summary OGL HT&L nebula fog and poof effects not working => OGL HT&L poof effects not working
2004-04-13 10:10 taylor Note Added: 0000763
2004-04-14 02:36 RandomTiger Assigned To phreak => taylor
2004-04-14 06:27 taylor Status acknowledged => resolved
2004-04-14 06:27 taylor Resolution open => fixed
2004-04-14 06:27 taylor Note Added: 0000768
2007-03-23 04:17 taylor Status resolved => closed
2007-03-23 04:17 taylor Fixed in Version => 3.6
+Issue History