2021-03-06 22:56 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001983FSSCPmultiplayerpublic2014-04-21 03:00
ReporterFUBAR-BDHR 
Assigned To 
PrioritynormalSeverityfeatureReproducibilitysometimes
StatusfeedbackResolutionreopened 
Product Version3.6.11 
Target VersionFixed in Version3.6.13 
Summary0001983: Discussion: Hand off nebula rendering to clients completely from standalone
DescriptionDebugger call stack and variables attached.

Basically your_basic_hot_sauce is turning up null along with start and strike.
Additional Information3.6.11 r5524
TagsNo tags attached.
Attached Files
  • txt file icon hot_sauce.txt (3,692 bytes) 2009-08-23 03:15 -
     	fs2_open_3_6_11d.exe!debug_int3(char * file=0x00dd2b84, int line=1250)  Line 760	C++
     	fs2_open_3_6_11d.exe!Warning(char * filename=0x00dd1a76, int line=452, const char * format=0x00dd1b78, ...)  Line 1250 + 0x13 bytes	C++
     	fs2_open_3_6_11d.exe!vm_vec_copy_normalize(vec3d * dest=0x0012f430, vec3d * src=0x0012f430)  Line 453 + 0x18 bytes	C++
     	fs2_open_3_6_11d.exe!vm_vec_normalize(vec3d * v=0x0012f430)  Line 477 + 0xd bytes	C++
    >	fs2_open_3_6_11d.exe!nebl_process()  Line 679 + 0xc bytes	C++
     	fs2_open_3_6_11d.exe!game_frame(int paused=0)  Line 4830	C++
     	fs2_open_3_6_11d.exe!game_do_frame()  Line 5121 + 0x7 bytes	C++
     	fs2_open_3_6_11d.exe!game_do_state(int state=2)  Line 6892	C++
     	fs2_open_3_6_11d.exe!gameseq_process_events()  Line 405 + 0x14 bytes	C++
     	fs2_open_3_6_11d.exe!game_main(char * cmdline=0x00151f1b)  Line 7453 + 0x5 bytes	C++
     	fs2_open_3_6_11d.exe!WinMain(HINSTANCE__ * hInst=0x00400000, HINSTANCE__ * hPrev=0x00000000, char * szCmdLine=0x00151f1b, int nCmdShow=1)  Line 7527 + 0x9 bytes	C++
     	fs2_open_3_6_11d.exe!__tmainCRTStartup()  Line 263 + 0x2c bytes	C
     	fs2_open_3_6_11d.exe!WinMainCRTStartup()  Line 182	C
     	kernel32.dll!7c817067() 	
     	[Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]	
    
    Autos:
    
     	fs2_open_3_6_11d.exe!debug_int3(char * file=0x00dd2b84, int line=1250)  Line 760	C++
     	fs2_open_3_6_11d.exe!Warning(char * filename=0x00dd1a76, int line=452, const char * format=0x00dd1b78, ...)  Line 1250 + 0x13 bytes	C++
     	fs2_open_3_6_11d.exe!vm_vec_copy_normalize(vec3d * dest=0x0012f430, vec3d * src=0x0012f430)  Line 453 + 0x18 bytes	C++
     	fs2_open_3_6_11d.exe!vm_vec_normalize(vec3d * v=0x0012f430)  Line 477 + 0xd bytes	C++
    >	fs2_open_3_6_11d.exe!nebl_process()  Line 679 + 0xc bytes	C++
     	fs2_open_3_6_11d.exe!game_frame(int paused=0)  Line 4830	C++
     	fs2_open_3_6_11d.exe!game_do_frame()  Line 5121 + 0x7 bytes	C++
     	fs2_open_3_6_11d.exe!game_do_state(int state=2)  Line 6892	C++
     	fs2_open_3_6_11d.exe!gameseq_process_events()  Line 405 + 0x14 bytes	C++
     	fs2_open_3_6_11d.exe!game_main(char * cmdline=0x00151f1b)  Line 7453 + 0x5 bytes	C++
     	fs2_open_3_6_11d.exe!WinMain(HINSTANCE__ * hInst=0x00400000, HINSTANCE__ * hPrev=0x00000000, char * szCmdLine=0x00151f1b, int nCmdShow=1)  Line 7527 + 0x9 bytes	C++
     	fs2_open_3_6_11d.exe!__tmainCRTStartup()  Line 263 + 0x2c bytes	C
     	fs2_open_3_6_11d.exe!WinMainCRTStartup()  Line 182	C
     	kernel32.dll!7c817067() 	
     	[Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]	
    
    Locals:
    
    
    
    
    
    -		your_basic_hot_sauce	{xyz={...} a1d=0x0012f430 }	vec3d
    +		xyz	{x=0.00000000 y=0.00000000 z=0.00000000 }	vec3d::<unnamed-tag>::<unnamed-type-xyz>
    +		a1d	0x0012f430	float [3]
    -		the_mixture	{xyz={...} a1d=0x0012f3f0 }	vec3d
    +		xyz	{x=-1.0737418e+008 y=-1.0737418e+008 z=-1.0737418e+008 }	vec3d::<unnamed-tag>::<unnamed-type-xyz>
    +		a1d	0x0012f3f0	float [3]
    		how_much_hot_sauce	-1.0737418e+008	float
    -		wing_sauce	{xyz={...} a1d=0x0012f410 }	vec3d
    +		xyz	{x=-1.0737418e+008 y=-1.0737418e+008 z=-1.0737418e+008 }	vec3d::<unnamed-tag>::<unnamed-type-xyz>
    +		a1d	0x0012f410	float [3]
    		how_much_of_that_good_wing_sauce_to_add	-1.0737418e+008	float
    		e1	1	int
    		s1	0	int
    		s2	2	int
    -		start	{xyz={...} a1d=0x0012f458 }	vec3d
    +		xyz	{x=0.00000000 y=0.00000000 z=0.00000000 }	vec3d::<unnamed-tag>::<unnamed-type-xyz>
    +		a1d	0x0012f458	float [3]
    -		strike	{xyz={...} a1d=0x0012f444 }	vec3d
    +		xyz	{x=0.00000000 y=0.00000000 z=0.00000000 }	vec3d::<unnamed-tag>::<unnamed-type-xyz>
    +		a1d	0x0012f444	float [3]
    		e3	4	int
    		type	-858993460	int
    		s3	0	int
    		e2	2	int
    		idx	0	int
    		num_bolts	3	int
    
    txt file icon hot_sauce.txt (3,692 bytes) 2009-08-23 03:15 +

-Relationships
+Relationships

-Notes

~0011152

Wanderer (developer)

Last edited: 2009-08-23 05:41

Fairly likely cause seems to be the neblightning.cpp line 621 which does not explicitly prevent standalone servers from running that function even though the Neb2_cubes[][][] as not stuffed for standalone builds.

~0012735

The_E (administrator)

Fixed in rev 7288

~0012737

The_E (administrator)

Reminder for self:

Okay, not actually fixed, just no longer causing warnings.

What this apparently needs is a bit of a rethink regarding how to handle nebulas for multi. The server needs to generate lightning for all players, then send that data over in order to get the desired effect, which is a bit complicated for standalones due to them not having data like the player position and orientation available.

A correct fix would be to get the position/orientation data for player 1, and use that.

~0012739

The_E (administrator)

Okay, so after thinking about this, it might be worthwhile to think about handing nebula rendering (and more importantly, lightning rendering) off to the clients completely.
+Notes

-Issue History
Date Modified Username Field Change
2009-08-23 03:15 FUBAR-BDHR New Issue
2009-08-23 03:15 FUBAR-BDHR File Added: hot_sauce.txt
2009-08-23 05:41 Wanderer Note Added: 0011152
2009-08-23 05:41 Wanderer Note Edited: 0011152
2011-06-28 15:48 The_E Note Added: 0012735
2011-06-28 15:48 The_E Status new => resolved
2011-06-28 15:48 The_E Fixed in Version => 3.6.13
2011-06-28 15:48 The_E Resolution open => fixed
2011-06-28 15:48 The_E Assigned To => The_E
2011-06-28 17:32 The_E Note Added: 0012737
2011-06-28 17:32 The_E Status resolved => feedback
2011-06-28 17:32 The_E Resolution fixed => reopened
2011-06-29 05:24 The_E Note Added: 0012739
2012-10-27 07:25 The_E Assigned To The_E =>
2013-12-03 04:45 Echelon9 Category nebulas => multiplayer
2014-04-21 03:00 Echelon9 Severity crash => feature
2014-04-21 03:00 Echelon9 Summary Nebula lightning causes null vec3d on standalone => Discussion: Hand off nebula rendering to clients completely from standalone
+Issue History