2018-06-18 10:44 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001795FSSCPmultiplayerpublic2008-10-23 08:59
ReporterFUBAR-BDHR 
Assigned Totaylor 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
Product Version3.6.9 
Target VersionFixed in Version3.6.10 
Summary0001795: Fighter beams crash multi in recent builds
DescriptionDoing testing for another bug I tried firing a beam weapon from a fighter. Immediate crash. Tried different fighters. Ones without beams work, ones with don't. This not only effects player ships but AI as well. As soon as an AI ship fires a beam splat.
Additional InformationTested in TBP using the 3.6.10 4874 Knightly build. Confirmed in at least one other recent build. Any Vorlon dogfight or Ultimate Gauntlet are good choices for reproducing the crash.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0009951

taylor (administrator)

Should be fixed in the next multi_test build.

~0009961

FUBAR-BDHR (developer)

Looks good. Tested both AI firing and host firing.

~0009974

taylor (administrator)

Fixered.

~0010030

taylor (administrator)

This is still broken. Not sure how it got through testing, considering that it always should have crashed still.

A proper fix is in the works now and it will be committed after confirmation that it works in a new test build this weekend.

~0010054

FUBAR-BDHR (developer)

Got past the last crash but ran into another instance of it. Another hard crash when firing a beam. This time the last entry in the log had something to do with the beam being out of energy. New logs attached.

~0010055

taylor (administrator)

Yep, sorry, didn't notice an existing bug in there. The beam fire info can end up containing a lot of invalid data for anything that you don't specifically set. This actually affects more than just fighter beams, but it is really only hit when the energy level drops which is why it doesn't generally happen (with capships). There was also an error with my updated fix which didn't set something properly either, so I can't just blame it on :v:. ;)

Easy to fix though, it's just annoying.

~0010058

FUBAR-BDHR (developer)

Just in case reminder. The WhiteStar can actually go into negative energy when firing the main beam. This wasn't the ship I was testing with but since were on the topic of possible causes of beam crashes.......

~0010105

taylor (administrator)

Fixered ... for real this time. (I hope)
+Notes

-Issue History
Date Modified Username Field Change
2008-10-13 02:51 FUBAR-BDHR New Issue
2008-10-13 02:51 FUBAR-BDHR File Added: fs2_open.log
2008-10-13 03:34 taylor Note Added: 0009951
2008-10-13 20:37 FUBAR-BDHR Note Added: 0009961
2008-10-13 21:05 taylor Status new => assigned
2008-10-13 21:05 taylor Assigned To => taylor
2008-10-14 12:56 taylor Status assigned => resolved
2008-10-14 12:56 taylor Fixed in Version => 3.6.10
2008-10-14 12:56 taylor Resolution open => fixed
2008-10-14 12:56 taylor Note Added: 0009974
2008-10-17 13:56 taylor Status resolved => feedback
2008-10-17 13:56 taylor Resolution fixed => reopened
2008-10-17 13:56 taylor Note Added: 0010030
2008-10-20 00:54 FUBAR-BDHR File Added: new_beam.rar
2008-10-20 00:55 FUBAR-BDHR Note Added: 0010054
2008-10-20 01:55 taylor Note Added: 0010055
2008-10-20 02:06 FUBAR-BDHR Note Added: 0010058
2008-10-23 08:59 taylor Status feedback => resolved
2008-10-23 08:59 taylor Resolution reopened => fixed
2008-10-23 08:59 taylor Note Added: 0010105
+Issue History