2019-11-13 14:13 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001003FSSCPFREDpublic2006-11-24 15:05
ReporterARSPR 
Assigned ToGoober5000 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformP4 2.8 HT - 1.5GB - 7800GSOSWindows XPOS VersionSP2
Product Version3.6.9 
Target VersionFixed in Version3.6.9 
Summary0001003: Asteroid field types are wrong
DescriptionI'm starting playing with FRED but I've noticed that at least in Derelict "Playing Possum" DL04-05.fs2 the debris behind the GTCv are coded as "Vasudan Small" in Asteroid Editor, but what you see in game is terran ones.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0006303

ARSPR (reporter)

I have investigated a little.

Asteroid field type (asteroid or ship) is toggled with "+Debris Genre:" (0 or 1).

Even with ship type you can have asteroids as the debris type is set by "+Field Debris Type:". And here you've got the problem

+What FRED sets: From 0 to 8: Terran (Small, Medium, Large) > Vasudan (S,M,L) > Shivan (S,M,L)

+What FS2 understands: From 0 to 11: Brown Asteroid (Small, Medium, Large) > Terran (S,M,L) > Vasudan (S,M,L) > Shivan (S,M,L)

So I think you should change the drop lists in FRED to match FS2 coding.

~0006304

Goober5000 (administrator)

Fixed.

~0006391

ARSPR (reporter)

I've just test 3.6.9. RC6 and this bug is fixed. But why haven't you added the Brown Asteroids within FRED list?

I mean even with ship field, you can get brown asteroids with "+Field debris type" from 0 to 2 (small, medium, large).

~0006454

ARSPR (reporter)

Anything new on this?

~0006455

Goober5000 (administrator)

I've been busy. I'll try to get to it this week.

~0006538

Goober5000 (administrator)

Okay, can you describe this a little more thoroughly? I'm not sure I understand what the problem is.

~0006545

ARSPR (reporter)

Sorry for my English...

In FS2 you can have two kind of asteroid fields: Rock ones or Ship Debris ones. This is selected by "+Debris Genre" with 0 or 1 as values.

In Ship debries fiels you can mix up to 3 kind of diferent debris types ("+Field Debris Type" entries). With yor fix in FRED you get a drop list from Terran Small (value = 3) to Shivan Large (value = 11).

But values from 0 to 2 DO also work and generate Brown Asteroids (small, medium and large). So why don't you add these types to the drop list in FRED? (Just now, you CAN'T set brown asteroids within FRED, you have to edit the .fs2 mission file within Notepad).

~0007001

ARSPR (reporter)

* bump *

(I've just seen it again in Mantis, so please don't forget about it ;) )

~0007154

Goober5000 (administrator)

Okay, I still don't understand your problem. You can specify brown asteroids in both FRED and FRED_open. They appear the same in the mission file.

~0007157

ARSPR (reporter)

Last edited: 2006-11-24 10:18

Yes, you can have Brown Asteroids, but FRED does not allow you to put them inside a ship debris field.

My point is that FS2 DOES allow you Brown Asteroids in ship debris fields.

I attach an example (AsteroidExample.fs2). With Notepad, I have manually edited that mission file to set the first "+Field Debris Type:" as 0.
 
After that change, the mission has a Ship Asteroid Field ("+Debris Genre: 1") with Small Brown Asteroids ("+Field Debris Type: 0"), Small Terran debris ("+Field Debris Type: 3") and Small Vasudan debris ("+Field Debris Type: 6"). Play the mission and you will see all the 3 kinds of items inside the field.

Then, open the mission in FRED and go to Asteroid Field editor. You can see how the first drop-down list value is empty. FRED is missing Small Brown Asteroid ("+Field Debris Type: 0"), Medium Brown Asteroid ("+Field Debris Type: 1") and Large Brown Asteroid ("+Field Debris Type: 2") when you have selected a Ship Debris field class. But, as seen, those items are fully valid for FS2.

(I'm always talking about Open versions of FS2 and FRED. I do not know how retail worked).

~0007158

Goober5000 (administrator)

Oh, I see. So you want to have both debris and asteroids in the same field?

FRED is not designed to do that... the fact that you were able to edit Notepad is probably an "undocumented feature". I recommend putting in a feature request for multiple asteroid fields in one mission.
+Notes

-Issue History
Date Modified Username Field Change
2006-07-22 04:04 ARSPR New Issue
2006-07-23 11:53 ARSPR Note Added: 0006303
2006-07-23 12:25 Goober5000 Status new => resolved
2006-07-23 12:25 Goober5000 Resolution open => fixed
2006-07-23 12:25 Goober5000 Assigned To => Goober5000
2006-07-23 12:25 Goober5000 Note Added: 0006304
2006-08-08 10:22 ARSPR Status resolved => feedback
2006-08-08 10:22 ARSPR Resolution fixed => reopened
2006-08-08 10:22 ARSPR Note Added: 0006391
2006-08-15 15:13 ARSPR Note Added: 0006454
2006-08-15 16:22 Goober5000 Note Added: 0006455
2006-09-02 14:47 Goober5000 Note Added: 0006538
2006-09-04 01:36 ARSPR Note Added: 0006545
2006-10-26 11:22 ARSPR Note Added: 0007001
2006-11-23 21:21 Goober5000 Note Added: 0007154
2006-11-24 10:04 ARSPR Note Added: 0007157
2006-11-24 10:05 ARSPR File Added: AsteroidExample.fs2
2006-11-24 10:15 ARSPR Note Edited: 0007157
2006-11-24 10:18 ARSPR Note Edited: 0007157
2006-11-24 15:05 Goober5000 Note Added: 0007158
2006-11-24 15:05 Goober5000 Status feedback => resolved
2006-11-24 15:05 Goober5000 Resolution reopened => fixed
2006-11-24 15:05 Goober5000 Fixed in Version => 3.6.9
+Issue History