2019-12-07 09:18 EST


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000867FSSCPturretspublic2008-03-31 19:41
ReporterGoober5000 
Assigned ToWMCoolmon 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6.10 
Summary0000867: Multi-firepoint turrets should default to not using the extra firepoints
DescriptionI know you fixed this so they'd all be used, WMC, but it breaks balance in some retail missions - for example, the Orion's turrets now do 3x the original damage. Best to add a hook into ai_profiles to enable this. I'd add it myself except I'm not quite sure where the hook should go. :p
TagsNo tags attached.
Attached Files
  • ? file icon 0.fs2 (5,194 bytes) 2007-02-08 05:30

-Relationships
has duplicate 0001290resolvedWMCoolmon Turret issues 
+Relationships

-Notes

~0005180

The Trivial Psychic (reporter)

Actually, I'd like to be able to use this feature more selectively than simply by AI profiles. TBP uses some ships which have a single swarm weapon mounted on a multi-firepoint turret, so that it will cycle between the firepoints. However, other instances where there is a specific weapon slated for each firepoint, it'd be best to have them stick to the firepoint they've been assigned. Is there any way to accomodate this? Ships/weapons Table entry/flag?

~0005187

WMCoolmon (developer)

Per-subsys would be best. Damn, it's been a while since I worked on that code. Probably just a matter of changing the number of times a for loop is iterated through...maybe...

~0005996

WMCoolmon (developer)

I've uploaded a http://fs2source.warpcore.org/temp/wmc/turretbug.zip.

If you have any tables that use the existing subsystem flags, it will complain. I swapped the syntax to be $Flags: ("untargetable" "carry no damage" "use multiple guns") rather than keep on adding the + flags, since there's become more and more reason for subsys flags as of late.

~0006573

WMCoolmon (developer)

This should be in CVS now, does this fix the problem mission(s)?

~0006583

Goober5000 (administrator)

To be honest I didn't have a specific mission in mind. If you tell me which files you changed, I could look them over.

~0006589

The Trivial Psychic (reporter)

So, there's now a $flags line for each subsystem then? The Wiki should be updated to reflect this change.

~0007506

WMCoolmon (developer)

Assuming this is fixed, since I haven't heard any more complaints with the new code.

~0007509

Goober5000 (administrator)

Last edited: 2007-01-21 14:45

WMC, I never had a specific mission in mind. Could you tell me the commit you made to fix the issue, so I can look it over?

That's the whole reason I left this bug open. Look at the comment I made above. :)

~0007606

Goober5000 (administrator)

Okay, this is interesting. I've confirmed that the bug still exists in 3.6.9, but not in HEAD. Attached is a simple sample mission.

~0007654

Wanderer (developer)

I dont know if this is related but if i used 'same turret cooldown' weapon (with small fof) with the turrets and had defined two primary weapons for the turret i got double shots with alternating firepoints regardess of the 'use multiple guns' flag.

~0007690

Goober5000 (administrator)

Also, from Wanderer in bug 0001290...

"Turrets use only single firing point instead of alternating between multiple ones - tested using mediavp Aeolus, used twin points when using 369 builds and only single one with cvs builds.

'use multiple guns' flag didnt seem to have any effect."

~0009123

taylor (administrator)

Added the missing flag check, so...

Fixered.
+Notes

-Issue History
Date Modified Username Field Change
2006-03-18 13:52 Goober5000 New Issue
2006-03-18 22:28 The Trivial Psychic Note Added: 0005180
2006-03-19 02:29 WMCoolmon Note Added: 0005187
2006-06-30 01:30 WMCoolmon Note Added: 0005996
2006-09-09 03:20 WMCoolmon Note Added: 0006573
2006-09-09 12:54 Goober5000 Note Added: 0006583
2006-09-09 20:11 The Trivial Psychic Note Added: 0006589
2007-01-21 04:14 WMCoolmon Status assigned => resolved
2007-01-21 04:14 WMCoolmon Resolution open => fixed
2007-01-21 04:14 WMCoolmon Note Added: 0007506
2007-01-21 14:45 Goober5000 Note Added: 0007509
2007-01-21 14:45 Goober5000 Status resolved => feedback
2007-01-21 14:45 Goober5000 Resolution fixed => open
2007-01-21 14:45 Goober5000 Note Edited: 0007509
2007-02-08 05:27 Goober5000 File Added: 0.fs2
2007-02-08 05:28 Goober5000 File Deleted: 0.fs2
2007-02-08 05:28 Goober5000 File Added: 0.fs2
2007-02-08 05:30 Goober5000 File Deleted: 0.fs2
2007-02-08 05:30 Goober5000 File Added: 0.fs2
2007-02-08 05:31 Goober5000 Note Added: 0007606
2007-02-17 18:24 Wanderer Note Added: 0007654
2007-02-21 19:19 Goober5000 Relationship added has duplicate 0001290
2007-02-21 19:24 Goober5000 Note Added: 0007690
2008-03-31 19:41 taylor Note Added: 0009123
2008-03-31 19:41 taylor Status feedback => resolved
2008-03-31 19:41 taylor Resolution open => fixed
2008-03-31 19:41 taylor Fixed in Version => 3.6.10
+Issue History